Scroll indicators are not there for the scrolled iframe when scrolling content inside an iframe

RESOLVED WONTFIX

Status

Firefox for Android Graveyard
Panning/Zooming
RESOLVED WONTFIX
7 years ago
7 years ago

People

(Reporter: Martijn Wargers (zombie), Unassigned)

Tracking

({testcase})

Trunk
ARM
Android
testcase

Details

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
Created attachment 505403 [details]
testcase

See testcase, the iframe content is overflowing, so you should be able to scroll the iframe content by panning it.

Not sure when this regressed, but I can even see this bug on a 2010-08-17 build on Windows Fennec.
(Reporter)

Updated

7 years ago
tracking-fennec: --- → ?
Bug only recently (yesterday?) enabled scrolling in iframes. This has been broken forever.
(Reporter)

Comment 2

7 years ago
I'm not sure what you mean. You mean this has been broken forever on Fennec2.0 builds? With Fennec1.1 builds, this seems to work fine.
(In reply to comment #2)
> I'm not sure what you mean. You mean this has been broken forever on Fennec2.0
> builds? With Fennec1.1 builds, this seems to work fine.

Right. This has been broken ever since we implemented e10s.
(Reporter)

Comment 4

7 years ago
Ah, yeah, I see it working in today's trunk build (what a coincidence!), but the scroll indicators are at the wrong place.
(In reply to comment #4)
> Ah, yeah, I see it working in today's trunk build (what a coincidence!), but
> the scroll indicators are at the wrong place.

bugmorph?
(Reporter)

Comment 6

7 years ago
Ok, steps to reproduce:
- Visit testcase, pan the iframe of the testcase upwards to let the content of the iframe scroll downwards

Expected result:
- A vertical scroll indicator should appear in the iframe, indicating the scroll position of the iframe

Actual result:
- A vertical scroll indicator appears at the right side of the viewport.
Summary: Impossible to scroll content of frames → Scroll indicators are not there for the scrolled iframe when scrolling content inside an iframe
(Reporter)

Updated

7 years ago
Keywords: regression
Bugmorph!

Updated

7 years ago
Severity: normal → minor
tracking-fennec: ? → 2.0-
Priority: -- → P1
Severity: minor → normal
Priority: P1 → --
odd.  I don't see any scroll indicators for : http://www.htmlcodetutorial.com/frames/_IFRAME.html

Updated

7 years ago
Duplicate of this bug: 634636

Updated

7 years ago
Whiteboard: [fennec-4.1?]
Is this really needed?
tracking-fennec: - → 7+
Whiteboard: [fennec-4.1?]
Madhava - do we really want scroll indicators inside iframes? I haven't seen any other mobile browsers do this. We could try. It might not be easy.

What's the priority of this feature?
tracking-fennec: 7+ → ?
(Reporter)

Comment 12

7 years ago
Created attachment 547407 [details]
testcase2

This testcase also has a scrollable div under the iframe, for which the situation is basically the same.
(Reporter)

Comment 13

7 years ago
Btw, I noticed that the stock Android browser just ignores any height (and perhap also width?) set for the iframe. It makes the iframe just as high so there is nothing to scroll. The scrollable div is just not scrollable, there.

Opera Mobile does the same and also for the scrollable div.

Maybe this would be a good solution for Fennec too?
REOPEN if needed
Status: NEW → RESOLVED
tracking-fennec: ? → ---
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
(In reply to comment #13)
> Btw, I noticed that the stock Android browser just ignores any height (and
> perhap also width?) set for the iframe. It makes the iframe just as high so
> there is nothing to scroll. The scrollable div is just not scrollable, there.
> 
> Opera Mobile does the same and also for the scrollable div.
> 
> Maybe this would be a good solution for Fennec too?

It is a WebKit feature called Frame Flattening.
You need to log in before you can comment on or make changes to this bug.