The default bug view has changed. See this FAQ.

Lighnting deals on Amazon shows only closed teasers

VERIFIED FIXED

Status

Tech Evangelism Graveyard
English US
VERIFIED FIXED
6 years ago
2 years ago

People

(Reporter: montihouse, Unassigned)

Tracking

({regression})

Details

(URL)

(Reporter)

Description

6 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.13) Gecko/20101203 Ant.com Toolbar 2.0.1 Firefox/3.6.13 GTB7.1
Build Identifier: Firefox 4 beta 9 , i think it was 077

Amazon Gold Box site - http://www.amazon.com/gp/goldbox/ref=sv_gb_0# - has "lightening deals" on right side - Firefox 4 only shows closed deals, not current offer or upcoming teasers 

Additionally, I expected to be able to run 4.0 at the same time as 3.6 - no matter where I tried to start 3.6 from, including the actual program in the 3.6 file directory, all that would start was another instance of 4.0 - result, 4.0 has been discarded (that's the kind of single minded, "use only the newest version" that I would have expected from MS - now seriously thinking about going to Chrome or Opera

And, after removing 4.0 from my system and finally getting 3.6 to start, Amazon site displayed correctly.

Reproducible: Always

Steps to Reproduce:
1. go to http://www.amazon.com/gp/goldbox/ref=sv_gb_0#

Actual Results:  
2. that's all, full site doesn't display
3. try to open Firefox 3.6 to see if problem on site or 4.0, 3.6 won't start, ONLY OTHER INSTANCES OF 4.0
4. remove 4.0 from computer
You can't run 3.6 and 4.0 at the same time but you don't have to uninstall 4.0 to run 3.6. Just close all Firefox windows and you can select the version you want to run. 2 independent applications should not write to the same files in your userprofile or they would get damaged. The userprofile contains your bookmark, cookie etc files but that is outside of the scope of this bug report and is a question for the support.

now the bug:
I can see the problem with Seamonkey trunk and FF4.0b9 on win32. There are many errors in the error console and the safemode or disabling the html5 parser doesn't help. I will try to find a regression range.
Severity: major → normal
Status: UNCONFIRMED → NEW
Component: General → General
Ever confirmed: true
Product: Firefox → Core
QA Contact: general → general
Version: unspecified → Trunk
Last good nightly: 2009-12-01 First bad nightly: 2009-12-02

Pushlog: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=b7f3c1c9fb
57&tochange=a5e1b195ecf7
Summary: not working on one site; no warning on download that can not simultaneously install w/3.6 → Lighnting deals on Amazon shows only closed teasers
Boris: Do you have an idea what this could be ? 
There is a TM merge in that regression window but the safemode doesn't help..
The TM merge is the most likely issue.  Matti, can you figure out the regression range on that branch using TM nightlies?  The intersection of the two ranges might be enlightening.
blocking2.0: --- → ?
Keywords: regression
good 2009-11-19-04-tracemonkey http://hg.mozilla.org/tracemonkey/rev/c84622414ed3
bad 2009-11-20-05-tracemonkey http://hg.mozilla.org/tracemonkey/rev/2ca2a236da89

<http://hg.mozilla.org/tracemonkey/pushloghtml?fromchange=c84622414ed3&tochange=2ca2a236da89>
Assignee: nobody → general
Component: General → JavaScript Engine
QA Contact: general → general

Comment 6

6 years ago
My best guess is that jimb broke something with his strict mode work.
Note that the page's script are in strict mode, btw.  So it's possible that they're just doing stuff that's not allowed there.
Though I only see one JS error loading the page:

Error: assignment to undeclared variable ourPercentOff
Source File: http://z-ecx.images-amazon.com/images/G/01/goldbox/client-side/gbld_js-v39._V174650570_.js
Line: 5610

That's in the "multi_price_block" function.  The "price_block" function, which is similar, declares that var.

Of course maybe there's something else going on and they're catching the exception or something....
The multi_price_block: function in an object literal here assigns to a variable |ourPercentOff| which wasn't declared in that function.  (It clearly should have been, because the price_block: function immediately below it *does* declare a variable of that name.)  This looks like another concatenated script with a strict-ful json2.js at the top and non-strict scripts below it.  So this is just same song, second verse, of the Amazon-accidentally-using-strict-mode-due-to-concatenation bug.

Reminder (or hint, for anyone here who wasn't familiar with the idea) for the future: check the JavaScript error console.  :-)  Mine shows this error pretty clearly and, with a minor bit of source reading, fingers this as a site bug:

Error: assignment to undeclared variable ourPercentOff
Source File: http://z-ecx.images-amazon.com/images/G/01/goldbox/client-side/gbld_js-v39._V174650570_.js
Line: 5610
Assignee: general → english-us
blocking2.0: ? → ---
Component: JavaScript Engine → English US
OS: Windows Vista → All
Product: Core → Tech Evangelism
QA Contact: general → english-us
Hardware: x86 → All
Version: Trunk → unspecified
Well.... yes, but why did this only start being a problem in the regression range from comment 5?
Why wouldn't it?  Using an old build loads the new site code.  Before the first bits of strict mode landed nothing would have gone wrong.  After they landed (which occurred in that regression range), the first strict mode violation would be an error.  The first violation in this script is the one hit here.
Oh, I missed that the undeclared variable thing was in the range.  I thought it had landed earlier.... OK, then!
Kev, any update?

/be

Comment 14

6 years ago
It's been fixed, I thought... or was that another, related error? Current and upcoming offers are displayed for me right now...
Yeah, this looks fixed.  No more exceptions.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
verified fixed
Status: RESOLVED → VERIFIED
Blocks: 642201
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.