content at Amazon.de isn't shown due to misuse of strict mode

RESOLVED FIXED

Status

RESOLVED FIXED
8 years ago
4 years ago

People

(Reporter: uweruch, Unassigned)

Tracking

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0

On amazon.de under "Sonderangebote" (special offers), FF4 RC1 doesn't show the content in the lower section of the web page. No special offers are shown in this case. This problem is reproducible. With all other browsers, the content is shown.

Reproducible: Always

Steps to Reproduce:
1. Open http://www.amazon.de
2. Go to "special offers" (Sonderangebote)
3. In the lower region of the web page, the special offers are not shown with FF4 RC1.
Actual Results:  
No special offers are shown.

Expected Results:  
It should show the special offers.

Comment 1

8 years ago
Same problem here using the RC1 on Mac OS X.

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0) Gecko/20100101 Firefox/4.0

Works though with the latest 3.6 build as well as with Safari.

Comment 2

8 years ago
Error: assignment to undeclared variable Deal
Source file:
http://z-ecx.images-amazon.com/images/G/03/goldbox/client-side/csld_multi_category_center_js-v6._V173145405_.js
Line: 368

This is the site issue. 

This problem occurs due to misuse strict mode in
csld_multi_category_center_js-v6._V173145405_.js

TE?
Whiteboard: TE?

Comment 3

8 years ago
Created attachment 519741 [details]
Source code of the incorrectly rendered page

As the box "Blitzangebote" is likely to be removed after the special offers have expired, the source code of the page in question.

Look for "Blitzangebote" when inspecting the html source code.
(Reporter)

Comment 4

8 years ago
It looks like Java Scripting is not handled correctly in this special case. The box "Blitzangebote" ain't showed at all using FF4 RC1.

Comment 5

8 years ago
Can confirm the behaviour described in this bug. I'm running Firefox RC1 on Fedora 15 Alpha, 64bit.

I used Google Chrome for comparison on the same system. Google Chrome shows the ad-box in question.
(Reporter)

Updated

8 years ago
Summary: FF4 doesn't show the content of the web page → FF4 doesn't show the content of the web page at Amazon.de
(Reporter)

Updated

8 years ago
OS: Windows 7 → All
(Reporter)

Updated

8 years ago
Hardware: x86_64 → All
(Reporter)

Comment 6

8 years ago
This bug is very annoying. You never know if the web page, you are surfing on, contains more data than it virtually displays.
Assignee: nobody → german
Component: General → German
Product: Firefox → Tech Evangelism
QA Contact: general → german
Summary: FF4 doesn't show the content of the web page at Amazon.de → content at Amazon.de isn't shown due to misuse of strict mode
Whiteboard: TE?
You can report Site Issues on Amazon.de via https://www.amazon.de/gp/help/contact-us/general-questions.html?ie=UTF8 after Login.
grr, mid-air

This is a bug that Amazon already fixed on their en-us page (bug 627531).
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 9

8 years ago
So, what's the solution for this?

Amazon.de will eventually fix this issue, I'm sure.

But I guess there are a lot of websites out there with the exact same issue. That's because they're tested against Firefox 3.6 which shows a different behaviour in this situation.

As the bug report has been moved I guess this is not a show stopper for releasing the final version of Firefox 4?
>So, what's the solution for this?
The solution is that the site will fix the bug.

>As the bug report has been moved I guess this is not a show stopper for
>releasing the final version of Firefox 4?

No because this is not something that can or should be fixed in the source code.
Depends on: 627531
(Reporter)

Comment 11

8 years ago
It's a kind of weird. With all other Browsers, there is no trouble showing the content of the page. So, you say, it's not a browser problem, but rather a bug of the web page, right?

Comment 12

8 years ago
It's in fact fixing an old bug, that Firefox previously accepted code as strict that didn't match the strict criteria. The huge downside though is cutting off backwards compatibility. So, making a choice for either keeping the old behaviour or being strict leads to complaints :(.

Comment 13

8 years ago
For Amazon.de this seems to be fixed now. The script for the box has been replaced by a new version:
http://z-ecx.images-amazon.com/images/G/03/goldbox/client-side/csld_multi_category_center_js-v16._V183555462_.js

This new version besides numerous other changes contains a replacement of the line in question from:
  Deal = {};
to
  window.Deal = {};

Hopefully other sites with similar problems will be fixing this soon as well. Otherwise Firefox 4.0 users might encounter problems for a a while...
Seeing this fixed too with 14/Nightly -> resolving.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.