bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Arrow panel hidden behind Windows taskbar when browser not maximized

RESOLVED FIXED in Firefox 29

Status

()

Toolkit
XUL Widgets
RESOLVED FIXED
8 years ago
10 months ago

People

(Reporter: George Carstoiu, Assigned: Gijs)

Tracking

Trunk
mozilla30
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox29 fixed, firefox30 fixed)

Details

(Whiteboard: [4b10][good first verify])

Attachments

(5 attachments)

(Reporter)

Description

8 years ago
Created attachment 506081 [details]
Screenshot 1

Build identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b10pre) Gecko/20110121 Firefox/4.0b10pre

When browser is not maximized, the arrow panel is displayed in the background of the windows taskbar. Use attached "testcase" to test.

Steps to reproduce:
 1. Minimize browser such as the lower part of the window comes close to the windows taskbar, but it's not in contact with it.
 2. Open attached "testcase" and scroll page until you reach the bottom of the page
 3. Press "Submit"

Actual results:
 - the arrow panel is hidden behind the windows taskbar (Screenshot 1)
 
Expected results:
 - the arrow panel is displayed in such way that it is fully visible
(Reporter)

Comment 1

8 years ago
Created attachment 506082 [details]
Testcase

Comment 2

8 years ago
Created attachment 506091 [details]
Screenshot in maximized mode

Algorithm that calculates space on the screen where the panel could be displayed should take into account the taskbar
Component: General → XUL Widgets
Product: Firefox → Toolkit
QA Contact: general → xul.widgets

Comment 3

8 years ago
The popup uses level="parent", so that (from bug 561636) "if a form gets autosubmitted while the browser is behind another app's window, the popup [isn't] shown on top of the other app."

This causes the popup to appear above the firefox window but behind other windows.

So it seems the suggestion in comment 2 is a better option here. On Windows and GTK, popups can overlap the taskbar and other OS chrome. We could change this perhaps only for those popups with level='parent'.
(Reporter)

Updated

8 years ago
Whiteboard: [4b10]
OS: Windows 7 → All
Hardware: x86 → All
It would be indeed better to make sure these panels can overlay the taskbar instead of making them appear on top of all windows.
(Assignee)

Comment 5

5 years ago
Created attachment 8372383 [details] [diff] [review]
panels that aren't toplevel shouldn't overlap the taskbar,

I've made this change only for panels, not for other types of popups, but those checks could be removed if that were better...
Attachment #8372383 - Flags: review?(enndeakin)
(Assignee)

Updated

5 years ago
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
(Assignee)

Updated

5 years ago
Blocks: 963078

Comment 6

5 years ago
Comment on attachment 8372383 [details] [diff] [review]
panels that aren't toplevel shouldn't overlap the taskbar,

>     if (screen) {
>+      // Non-top-level panels should never overlap the OS bar:
>+      bool dontOverlapOSBar = mPopupType == ePopupTypePanel &&
>+                              aPopupLevel != ePopupLevelTop;

Non-panels are always ePopupLevelTop so the type check is redundant.
Attachment #8372383 - Flags: review?(enndeakin) → review+
(Assignee)

Comment 7

5 years ago
Comment on attachment 8372383 [details] [diff] [review]
panels that aren't toplevel shouldn't overlap the taskbar,

remote:   https://hg.mozilla.org/integration/mozilla-inbound/rev/95fc024ee46d
Attachment #8372383 - Flags: checkin+
(Assignee)

Comment 8

5 years ago
(In reply to :Gijs Kruitbosch from comment #7)
> Comment on attachment 8372383 [details] [diff] [review]
> panels that aren't toplevel shouldn't overlap the taskbar,
> 
> remote:   https://hg.mozilla.org/integration/mozilla-inbound/rev/95fc024ee46d

Meant to comment: removed the redundant check, and clarified the comments I added that mentioned panels based on comment #6.
https://hg.mozilla.org/mozilla-central/rev/95fc024ee46d
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla30
(Assignee)

Comment 10

5 years ago
Comment on attachment 8372383 [details] [diff] [review]
panels that aren't toplevel shouldn't overlap the taskbar,

[Approval Request Comment]
Bug caused by (feature/regressing bug #): n/a
User impact if declined: Australis' main menu panel goes underneath the Windows task bar when a subview is opened. This is bug 963078 (relatively new because we only recently switched to a non-top-level panel) which already has 5 dupes at time of writing. This is clearly affecting people a lot.
Testing completed (on m-c, etc.): On m-c, locally
Risk to taking this patch (and alternatives if risky): Low, alternative workarounds in bug 963078 aren't attractive and probably higher risk.
String or IDL/UUID changes made by this patch: none
Attachment #8372383 - Flags: approval-mozilla-aurora?
(Assignee)

Comment 11

5 years ago
Created attachment 8372811 [details] [diff] [review]
panels that aren't toplevel shouldn't overlap the taskbar,

Egh, forgot I needed a branch patch.
(Assignee)

Updated

5 years ago
Attachment #8372383 - Flags: approval-mozilla-aurora?
(Assignee)

Comment 12

5 years ago
Comment on attachment 8372811 [details] [diff] [review]
panels that aren't toplevel shouldn't overlap the taskbar,

Carrying over review, requesting approval on the patch that landed on m-c instead.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): n/a
User impact if declined: Australis' main menu panel goes underneath the Windows task bar when a subview is opened. This is bug 963078 (relatively new because we only recently switched to a non-top-level panel) which already has 5 dupes at time of writing. This is clearly affecting people a lot.
Testing completed (on m-c, etc.): On m-c, locally
Risk to taking this patch (and alternatives if risky): Low, alternative workarounds in bug 963078 aren't attractive and probably higher risk.
String or IDL/UUID changes made by this patch: none
Attachment #8372811 - Flags: review+
Attachment #8372811 - Flags: approval-mozilla-aurora?
Attachment #8372811 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Comment 13

5 years ago
remote:   https://hg.mozilla.org/releases/mozilla-aurora/rev/ed1d0b33ca0b
status-firefox29: --- → fixed
status-firefox30: --- → fixed

Updated

5 years ago
Duplicate of this bug: 968658

Updated

4 years ago
Whiteboard: [4b10] → [4b10][good first verify]
(Assignee)

Updated

4 years ago
Duplicate of this bug: 672365

Updated

10 months ago
Depends on: 1401477
You need to log in before you can comment on or make changes to this bug.