Quickly closing last two tabs with CTRL-W opens Panorama

RESOLVED WONTFIX

Status

Firefox Graveyard
Panorama
P3
normal
RESOLVED WONTFIX
7 years ago
2 years ago

People

(Reporter: Markus Fischer, Unassigned)

Tracking

Trunk
Future
x86
Windows 7

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b9) Gecko/20100101 Firefox/4.0b9
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b9) Gecko/20100101 Firefox/4.0b9

When I quickly close the last two tabs on the last window open, Panorama opens with a single tab.

Reproducible: Always

Steps to Reproduce:
1. Set "browser.tabs.closeWindowWithLastTab" to "false"
2. Ensure you have one window
3. Ensure you have at least two tabs open, empty tabs are OK
4. Quickly hit "CTRL-W" twice to close both (as fast as a double click on the mouse, for example)

Cannot be reproduces with there is a second window open.
Actual Results:  
You see both tabs closing and suddenly Panorama opens with an empty tab.

Expected Results:  
Panorama should not open and I should see one empty tab.

"browser.tabs.closeWindowWithLastTab" must be set to "false" to prevent Firefox being closed when the last tab is closed.
(Reporter)

Comment 1

7 years ago
I thought it's named Panorama but it seems it's called TabCandy also?
Component: General → TabCandy
Confirmed with Mozilla/5.0 (Windows NT 5.1; rv:2.0b10pre) Gecko/20110121 Firefox/4.0b10pre ID:20110122154308
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → Trunk
QA Contact: general → tabcandy
I don't think we're going to get to this for Fx4.
Priority: -- → P3
Target Milestone: --- → Future
Blocks: 653099
bugspam
No longer blocks: 653099
bugspam
Blocks: 660175
bugspam

(Fx7 was branched, removing open bugs from Fx7 meta bug, we won't create new meta bugs for upcoming Fx versions)
No longer blocks: 660175
Panorama has been removed from Firefox 45, currently in Beta and scheduled for release on March 7th. As such, I'm closing all existing Panorama bugs.

If you are still using Panorama, you will see a deprecation message in Firefox 44, and when 45 is released your tab group data will be migrated to bookmarks, with a folder for each group. There are also a few addons offering similar functionality.

See https://support.mozilla.org/en-US/kb/tab-groups-removal for more info.

We're removing Panorama because it has extremely low usage (about 0.01% of users), and has a large number of bugs and usability issues. The cost of fixing all those issues is far too high to justify, and so we'll instead be focusing our time and energy on improving other parts of Firefox.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

2 years ago
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.