messages deleted from inbox; compaction started on nothing; all lost

RESOLVED INCOMPLETE

Status

--
critical
RESOLVED INCOMPLETE
8 years ago
4 years ago

People

(Reporter: brettsalter, Unassigned)

Tracking

({dataloss})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13 ( .NET CLR 3.5.30729)
Build Identifier: 3.1.7

I deleted a message from the inbox while another was downloading. The deleted message went to trash, but the new message was lost and all other emails (4-6) in my inbox were lost. I reported this problem many months ago and never got an ack from Mozilla (just other users who have seen the same problem). It has happened to my wife numerous times. Please at least work on this very annoying bug!

Reproducible: Couldn't Reproduce




please contact me if you need more information. This is obviously a very intermittent problem. We'd be happy to run a special debug-out version of TB if that's what is needed to track this problem.

Comment 1

8 years ago
Brett, sorry, don't see your other report here in bugzilla. when/where did you report it?

If your inbox was completely gone, the likely cause is bug 498814 or antivirus that shouldn't be monitoring the thunderbird profile directory.

Is your inbox a pop account or imap?
And what antivirus do you run?
Keywords: dataloss
Whiteboard: [antivirus?]
(Reporter)

Comment 2

8 years ago
I reported the problem on bugzilla back in September of last year.

Yes, it does look like bug 498814 could be it. 

My inbox is a pop account. I run Microsoft Security Essentials.

I think the bug may really have something to do with messages being received while others in the inbox are being deleted. My inbox is so small that it wouldn't be compacted very often, so a crash caused by compaction and anti-virus is less likely than between active incoming and deletion messing up a pointer somewhere.

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 498814
(In reply to Brett Salter from comment #0)
> Build Identifier: 3.1.7

As I wrote in bug 498814, "Inbox file size=0 by Compact due to interfere(file open of Inbox) by other software" doen't occur if Tb 3.1 or later. It was Tb 2 and early builds of Tb 3.0xpre only problem. 
If "open Inbox file by Compact of official release of Tb 3.0 or later" is interfered by other software's read/write open of Inbox, different problem surely occurs(unable to copy/move mail to the folder, unable to o Compact, unable to do Repair folder).

Re-opening.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 5

6 years ago
The reporter claims that messages are gone because he deleted one, while others were loading.

The compaction may be the cause only if:
- it is enabled;
- and set to be automatic, starting whenever a certain amount of disk space is to be saved.

I list the workaround in the bug 674742.

Just in case it is to blame I mark your bug as dependent.

Please also find your older report, which you mentioned, so I can mark that too as dependent.

In the bug 674742 I mention that it is unfortunate that programmers did know the code. And some even did remember the wrong flags they introduced recently. Yet everybody failed to look at the code.

Instead they asked us to test, and reproduce.

They are not responsible or competent.
And there's nobody to enforce that.
This is strange.

Updated

6 years ago
Depends on: 674742

Comment 6

4 years ago
(In reply to Brett Salter from comment #2)
> 
> My inbox is a pop account. I run Microsoft Security Essentials.
> 
> I think the bug may really have something to do with messages being received
> while others in the inbox are being deleted. My inbox is so small that it
> wouldn't be compacted very often, so a crash caused by compaction and
> anti-virus is less likely than between active incoming and deletion messing
> up a pointer somewhere.

Brett, do you still see this problem?
Flags: needinfo?(brettsalter)
Whiteboard: [antivirus?] → [closeme 2014-07-21]

Comment 7

4 years ago
hopefully this is no longer happening for you. for now, we don't have your current information / status to keep this alive.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago4 years ago
Flags: needinfo?(brettsalter)
Resolution: --- → INCOMPLETE
Whiteboard: [closeme 2014-07-21]
You need to log in before you can comment on or make changes to this bug.