Closed Bug 628392 Opened 9 years ago Closed 9 years ago

release repacks do not list of locales failing easily

Categories

(Release Engineering :: General, defect, P3)

x86
macOS
defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: armenzg, Assigned: bhearsum)

References

()

Details

(Whiteboard: [l10n][releases])

Since the new multiple locales per builder work we have lost the ability to see which locale has failed on a release.

For example you can see an example on bug 628390 which ended like this:
> Traceback (most recent call last):
>   File "/builds/slave/rel-192-osx-rpk-4/build/scripts/scripts/l10n/create-release-repacks.py", line 180, in <module>
>     releaseConfig["mergeLocales"], options.platform, brandName)
>   File "/builds/slave/rel-192-osx-rpk-4/build/scripts/scripts/l10n/create-release-repacks.py", line 72, in createRepacks
>     raise RepackError("At least one repack failed, see above")
> __main__.RepackError: At least one repack failed, see above

I can think of two ways of fixing this:
A) the script is broken into a setup step + a step per locale

B) the script can post at the end which locales failed and at which step

What do you think?
I'll get to this soon-ish.
Assignee: nobody → bhearsum
Priority: -- → P3
Duplicate of this bug: 642700
This is likely to get fixed by the patch in bug 613970 this week.
Fixed by bug 613970.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.