Broken Updates on nightly build 01/25/2011 -notification appears but does not download the build

VERIFIED FIXED

Status

Firefox for Android Graveyard
General
P1
critical
VERIFIED FIXED
7 years ago
7 years ago

People

(Reporter: Ioana Chiorean, Unassigned)

Tracking

Trunk
ARM
Android

Details

(Reporter)

Description

7 years ago
Build Id:Mozilla/5.0 (Android; Linux armv71; rv:2.0b10pre) Gecko/20110125
Firefox/4.0b10pre Fennec/4.0b4pre
Device : HTC Desire A8181
OS: Android 2.1
Also reproduces on Motorola Droid 2 (android 2.2)

Steps to Reproduce:
1. go to about:firefox
2. Click on "Check for Updates"
3. Click on the resulting system notification
4. Click on "Get the New Version" button in the updater dialog that pops up

Actual Results:
- The download system notification pops up with no progress bar and then
disappears. No download is performed.

Expected Results:
- The download system notification pops up with and downloads the new nightly
update.

Note: 
- bug 621691 - is verified fixed
- bug 621698 - resolved dupe of 621691
(Reporter)

Updated

7 years ago
Severity: normal → critical
In beta 4 we removed the ability to even use the updater, but beta 3 still has the code. Did we also turn off creation of the server-side update.xml stuff for beta 4?

I'm just wondering why the notification is even displayed.
Severity: critical → normal

Comment 2

7 years ago
I can still reproduce this on the nightly builds.
Build ID: Mozilla /5.0 (Android;Linux armv7l;rv:2.0b11pre) Gecko/20110131 Firefox/4.0b11pre Fennec /4.0b5pre
Severity: normal → critical
Priority: -- → P1
Seems to work now, can someone else verify please?  I believe from some discussion on irc yesterday, Aki has fixed this.

Mozilla/5.0 (Android; Linux armv71; rv2.0b11pre) Gecko/20110201 Firefox/4.0b11pre Fennec/4.0b5pre

Comment 4

7 years ago
This is probably a dup of bug 623222, and will reoccur the next time the multilocale portion of the build fails until that's fixed.

Comment 5

7 years ago
Bug 623222 is fixed.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.