Hover state of Firefox Menu split button is sometimes not updated when hovering the arrow

RESOLVED WONTFIX

Status

()

Firefox
Menus
--
trivial
RESOLVED WONTFIX
8 years ago
2 years ago

People

(Reporter: Tiago Sá, Unassigned)

Tracking

Trunk
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13
Build Identifier: 4.0b10pre (2011-01-25)

This only happened to me once still, but it's there, so it needs to be checked out, if at all possible.

Reproducible: Always

Steps to Reproduce:
1. Open the Firefox menu
2. Put your mouse over a split menu arrow (the > thingy)
3. Wait a bit for the submenu to open
Actual Results:  
The arrow button never got to hover state, not immediately after the mouse got over it, and not after the submenu opened

Expected Results:  
The arrow button should get into hover state immediately, and keep that way.

I must stress that this ONLY HAPPENED ONCE, and even though I can't make it happen again, there's something wrong with the CSS code or whatever.
(Reporter)

Updated

8 years ago
Version: unspecified → Trunk
(Reporter)

Updated

8 years ago
Depends on: 589146

Comment 1

8 years ago
Created attachment 506857 [details]
Example of the ">" not highligted

I can reproduce it, but in a weird way:
1 - Locate a place with 2 split menu next to each other (option/help)
2 - Move from one menu to another quickly until both sub-menu flashes on after another (probably Bug628743)
3 - Jump to a ">"
4 - Try again (it's not a 100% hits)

Hope this helps.

Comment 2

7 years ago
This will probably be fixed by bug 633656, since there should not be a state where the main menuitem is highlighted but the arrow is not.

Comment 3

7 years ago
Build identifier: Mozilla/5.0 (Windows NT 5.1; rv:6.0a1) Gecko/20110502 Firefox/6.0a1

This is kinda still a problem. STR:

1. Open Firefox menu
2. Hover over "Downloads"
3. Quickly go over "History" (not the triangle)
4. Immediatly move mouse to the right to enter split menu
5. See the triangle without any highlight flash for 0.5 second
This UI doesn't exist anymore.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.