[Mac OS X] Enable copy and paste attachment in the compose window

VERIFIED DUPLICATE of bug 335783

Status

VERIFIED DUPLICATE of bug 335783
8 years ago
8 years ago

People

(Reporter: andreamonni, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b10) Gecko/20100101 Firefox/4.0b10
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.13) Gecko/20101207 Thunderbird/3.1.7

Mail.app on Mac OS X enables the user to copy any attachments in messages and to paste (and thus attach) it in a compose window. This is much more convenient than dragging an attachment from its original message and then dropping into the compose window. Moreover, existing user of Mail.app are used to that behavior and dragging and dropping is hard to discover.

Ideal behavior would be as follows:
1. Select attachment from message
2. Copy it
3. Open compose windon
4. Paste
5. Message is attached to message

Reproducible: Always

Comment 1

8 years ago
That's a combination of bug 379186 (Paste as attachment) and potentially also bug 452092 (Determine content disposition for attachments from MIME type and interaction) if you want the document pasted at some arbitrary location as inline content (I think you can do this in Mail.app, resulting in alternating message-body text and attachment parts).

This likely is a duplicate of bug 379186, but if you want to retain the placement in a Mail.app-like behavior, this would be a dependent on the ability to paste an attachment, but by itself a separate enhancement.
Whiteboard: dupeme?

Comment 2

8 years ago
> (comment #1) This likely is a duplicate of bug 379186,
Make that bug 335783, to which that other bug was duped itself...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 335783

Updated

8 years ago
Status: RESOLVED → VERIFIED
Whiteboard: dupeme?
You need to log in before you can comment on or make changes to this bug.