Last Comment Bug 628980 - browserscope richedit tests load http://www.google.com/intl/en_ALL/images/logo.gif over the network
: browserscope richedit tests load http://www.google.com/intl/en_ALL/images/log...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Editor (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla2.0b11
Assigned To: :Ehsan Akhgari
:
:
Mentors:
http://mxr.mozilla.org/mozilla-centra...
Depends on:
Blocks: 550569 626999
  Show dependency treegraph
 
Reported: 2011-01-26 06:18 PST by Ted Mielczarek [:ted.mielczarek]
Modified: 2012-02-22 14:54 PST (History)
3 users (show)
ehsan: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
.17-fixed
.19-fixed


Attachments
Patch (v1) (3.30 KB, patch)
2011-01-26 18:13 PST, :Ehsan Akhgari
roc: review+
Details | Diff | Splinter Review
For check-in (1.70 KB, patch)
2011-01-28 11:57 PST, :Ehsan Akhgari
no flags Details | Diff | Splinter Review

Description Ted Mielczarek [:ted.mielczarek] 2011-01-26 06:18:32 PST
Running mochitest-3/5 with Wireshark running, I caught this test making an external network request:

GET /intl/en_ALL/images/logo.gif HTTP/1.1
Host: www.google.com
User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b9pre) Gecko/20110105 Firefox/4.0b9pre
Accept: image/png,image/*;q=0.8,*/*;q=0.5
Accept-Language: en-us,en;q=0.5
Accept-Encoding: gzip, deflate
Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
Keep-Alive: 115
Connection: keep-alive
Referer: http://mochi.test:8888/tests/editor/libeditor/html/tests/browserscope/lib/richtext/richtext/editable.html

We need to fix this test to not hit the network.
Comment 1 :Ehsan Akhgari 2011-01-26 18:13:09 PST
Created attachment 507332 [details] [diff] [review]
Patch (v1)
Comment 2 Robert O'Callahan (:roc) (email my personal email if necessary) 2011-01-26 20:04:21 PST
Comment on attachment 507332 [details] [diff] [review]
Patch (v1)

This is OK, but would it be slightly better to use an image file loaded through the mochitest http server?
Comment 3 :Ehsan Akhgari 2011-01-26 21:49:15 PST
(In reply to comment #2)
> This is OK, but would it be slightly better to use an image file loaded through
> the mochitest http server?

Why would that be better?
Comment 4 :Ehsan Akhgari 2011-01-28 11:57:34 PST
Created attachment 507951 [details] [diff] [review]
For check-in

Well, I guess I don't care much either way!
Comment 6 Phil Ringnalda (:philor) 2011-01-30 22:10:43 PST
Looks like the test has been around for a while, we'll need it on 1.9.2 and 1.9.1 too.
Comment 7 Ted Mielczarek [:ted.mielczarek] 2011-02-01 06:09:09 PST
Pushed to 1.9.2:
http://hg.mozilla.org/releases/mozilla-1.9.2/rev/d69d7cf95377

Had to fiddle the patch because the tests had been renamed on trunk.
Comment 9 Daniel Veditz [:dveditz] 2011-03-04 10:15:10 PST
The "3.6.15" we're releasing today does not fix this bug, the release containing this bug fix has been renamed to "3.6.16" and the bugzilla flags will be updated to reflect that soon. Today's release is a re-release of 3.6.14 plus a fix for a bug that prevented many Java applets from starting up.

Note You need to log in before you can comment on or make changes to this bug.