AMO Image Preview Close Link hover should disappear

RESOLVED DUPLICATE of bug 647665

Status

()

defect
RESOLVED DUPLICATE of bug 647665
8 years ago
7 years ago

People

(Reporter: alex_mayorga, Unassigned)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.0; rv:2.0b11pre) Gecko/20110126 Firefox/4.0b11pre
Build Identifier: Mozilla/5.0 (Windows NT 6.0; rv:2.0b11pre) Gecko/20110126 Firefox/4.0b11pre

Link hover remains until you hover into another link.

Reproducible: Always

Steps to Reproduce:
1. Open https://addons.mozilla.org/en-US/firefox/addon/status-4-evar/
2. Click the picture so it previews
3. Click the green X to dismiss the preview picture
Actual Results:  
Minefield ends up with this in the location bar:
https://addons.mozilla.org/en-US/firefox/addon/status-4-evar/ > https://addons.mozilla.org/en-US/firefox/addon/status-4-evar/#

Expected Results:  
Minefield ends up with the current URL in the location bar.

To workaround hover in/out another link.

Comment 1

8 years ago
Confirmed
Mozilla/5.0 (X11; Linux i686; rv:2.0b11pre) Gecko/20110126 Firefox/4.0b11pre ID:20110126030333
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows Vista → All

Comment 2

8 years ago
In the Status 4 Evar preferences if I untick "clear the status after x seconds" the link stays for me also until I hover over another link, if I instead tick that option and input a time the links disappears according to the number of seconds set (note you also need to select "show status in the location bar")
(Reporter)

Comment 3

8 years ago
To clarify, this happens on any page https://addons.mozilla.org/en-US/firefox/addon/*/ that has pictures to preview, nothing to do with the "Status 4 Evar" add-on i.e. https://addons.mozilla.org/en-US/firefox/addon/barlesque/
(Reporter)

Updated

8 years ago
Blocks: 587908

Comment 4

8 years ago
This must be a weird bug with the script that generates the image popup on AMO.  This behavior also happens in 3.6.13.  Maybe this bug should be filed on AMO?
(Reporter)

Comment 5

8 years ago
The behavior described still happens on Mozilla/5.0 (Windows NT 6.0; rv:2.0b13pre) Gecko/20110316 Firefox/4.0b13pre ID:20110316030411  that displays hyperlink URLs at bottom of window (instead of right side of location bar) so I'm adding bug 541656 to block.
Blocks: 541656
Confirming that this Issue happens against
Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.2.18) Gecko/20110614 Firefox/3.6.18 ID:20110614230723

Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1.19) Gecko/20110420 Firefox/3.5.19 ID:20110420144310

Before that (i.e. 3.0/2.0) the Images are directly loaded.

Not sure if this is a Core or AMO Script Issue, but it's not related to Bug 541656/Bug 587908 obviously.

Would be nice to know if there are other Examples out there showing this Issue.
No longer blocks: 541656, 587908
Summary: Link hover should disappear when a link is clicked. → AMO Image Preview Close Link hover should disappear
Version: unspecified → Trunk
(Reporter)

Comment 7

7 years ago
This is no longer a problem on Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120817030555

I believe this was in fact a duplicate of bug 647665 so I'm marking it as such, please correct me if I'm wrong.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 647665
You need to log in before you can comment on or make changes to this bug.