Last Comment Bug 647665 - Url bar at bottom left does not disappear if link is removed from dom
: Url bar at bottom left does not disappear if link is removed from dom
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla14
Assigned To: Mounir Lamouri (:mounir)
:
Mentors:
http://firefogg.org/j/bugs/linkprevie...
: 629024 669686 (view as bug list)
Depends on:
Blocks: 629024
  Show dependency treegraph
 
Reported: 2011-04-04 03:54 PDT by Jan Gerber
Modified: 2012-08-17 11:31 PDT (History)
8 users (show)
mounir: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (1.50 KB, patch)
2012-04-16 02:17 PDT, Mounir Lamouri (:mounir)
bzbarsky: review+
gavin.sharp: approval‑mozilla‑central+
mounir: checkin+
Details | Diff | Review

Description Jan Gerber 2011-04-04 03:54:38 PDT
User-Agent:       Mozilla/5.0 (X11; Linux i686; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (X11; Linux i686; rv:2.0) Gecko/20100101 Firefox/4.0

If you hover over a link, the url shows up at the bottom right,
if now the link element is removed from the dom(or the div around it), the url preview is not removed and sticks around forever.


Reproducible: Always

Steps to Reproduce:
1. open http://firefogg.org/j/bugs/linkpreview.html
2. move mouse over 'link'
Actual Results:  
url preview stays around at bottom

Expected Results:  
url preview should be removed if the link that is previewed is removed from the dom
Comment 1 Thomas Ahlblom 2011-04-04 04:24:46 PDT
I have reproduced the alleged bug in:
Mozilla/5.0 (Windows NT 6.0; rv:2.2a1pre) Gecko/20110403 Firefox/4.2a1pre
Mozilla/5.0 (X11; Linux x86_64; rv:2.2a1pre) Gecko/20110403 Firefox/4.2a1pre
Comment 2 George Carstoiu 2011-04-07 06:35:18 PDT
Mozilla/5.0 (X11; Linux i686; rv:2.2a1pre) Gecko/20110407 Firefox/4.2a1pre

Confirming issue on latest trunk.

Present ever since Firefox 3.6.16
Comment 3 XtC4UaLL [:xtc4uall] 2011-07-07 09:52:04 PDT
Same Issue/Dupe of 629024?
Like that one it's repro'able against 3.5. and thus not related to Bug 541656.
It's just more obvious now ;-).
Comment 4 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-04-13 12:14:11 PDT
*** Bug 669686 has been marked as a duplicate of this bug. ***
Comment 5 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-04-13 12:19:12 PDT
The front-end actually just reacts to setOverLink() calls from the core. That ends up being triggered by nsGenericElement::LeaveLink in the link-hover case - seems like we should make it fire when links are removed from the DOM, somehow.
Comment 6 Mounir Lamouri (:mounir) 2012-04-16 02:17:13 PDT
Created attachment 615276 [details] [diff] [review]
Patch v1
Comment 7 Boris Zbarsky [:bz] 2012-04-17 13:41:48 PDT
Comment on attachment 615276 [details] [diff] [review]
Patch v1

r=me
Comment 8 Mounir Lamouri (:mounir) 2012-04-18 09:12:21 PDT
https://hg.mozilla.org/mozilla-central/rev/23a0762a0dd6
Comment 9 Mounir Lamouri (:mounir) 2012-04-18 10:04:50 PDT
Backed out because of excess of stupidity. I put some stuff that shouldn't be in the patch or even pushed the wrong patch (didn't check in details).

Backout rev:
https://hg.mozilla.org/mozilla-central/rev/f9fbee492a5c
Comment 10 Mounir Lamouri (:mounir) 2012-04-19 03:21:11 PDT
Comment on attachment 615276 [details] [diff] [review]
Patch v1

Pushed to inbound.
Comment 11 Ed Morley [:emorley] 2012-04-19 16:59:33 PDT
https://hg.mozilla.org/mozilla-central/rev/01cf4fb5a8c3
Comment 12 alex_mayorga 2012-08-17 11:31:31 PDT
*** Bug 629024 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.