Closed Bug 629303 Opened 10 years ago Closed 2 years ago

Profile gets corrupted after upgrading from 1.1 to beta4

Categories

(Firefox for Android Graveyard :: General, defect, P3)

ARM
Maemo
defect

Tracking

(fennec-)

RESOLVED WONTFIX
Tracking Status
fennec - ---

People

(Reporter: ahoza, Assigned: mfinkle)

References

Details

Attachments

(1 file)

Attached image Screenshot
Prerequisites: 
Have candidate repository installed from: http://ftp.mozilla.org/pub/mozilla.org/mobile/candidates/4.0b4-candidates/repos/multi/
 
Steps to reproduce:

1. Install Fennec 1.1 from: http://ftp.mozilla.org/pub/mozilla.org/mobile/candidates/1.1rc1-candidates/build3/maemo4/multi/.
2. Open fennec and do some browsing.
3. Check for updates in App manager, if there is no notification in Home screen.
3. Install Fennec 4.0b4.
4. Start Fennec.


Expected results:
Build from the following location is installed: http://ftp.mozilla.org/pub/mozilla.org/mobile/candidates/4.0b4-candidates/build1/maemo5-gtk/multi/
On start, about:home opens. Previously visited/bookmarked pages are available.

Actual results:
Fennec 1.1 is updated to Fennec 4.0b4
Upon start, blank page is displayed (see screenshot) and nothing works until I delete the profile (in Xterminal I enter: rm -r ~/.mozilla/fennec) and restart browser.
Whiteboard: [4.0b4]
Confirmed, I'm getting the same screenshot.
Mark asked for the profiles from Fennec1.1, Fennec2.0b4 running for the first time (corrupted profile), and finally Fennec2.0b4 after closing and restarting (then, suddenly, everything works fine).
I sent them by mail to him. If anyone else wants them, let me know.
tracking-fennec: --- → ?
Priority: -- → P3
tracking-fennec: ? → 2.0+
Whiteboard: [4.0b4]
Assignee: nobody → mark.finkle
tracking-fennec: 2.0+ → 2.0-
Duplicate of this bug: 643361
Closing all opened bug in a graveyard component
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.