Infinite loop of about:blank created when attempting load a .do file

RESOLVED DUPLICATE of bug 167320

Status

()

--
critical
RESOLVED DUPLICATE of bug 167320
8 years ago
8 years ago

People

(Reporter: trayce, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_6; en-us) AppleWebKit/533.19.4 (KHTML, like Gecko) Version/5.0.3 Safari/533.19.4
Build Identifier: Firefox 3.6.13

Inside many sites of utility companies where you can pay your bills online such as https://myaccount.sdge.com and http://ww2.cox.com there is an option under the bill paying section to view your actual billing statement. These are normally .do docs that are supposed to open in a new tab on the browser when you select which bill you'd like to view, or if you select a previous month's bill. Unfortunately every site I pay my bills on that has this option ends up crashing Firefox because it somehow creates an infinite loop of opening a new tab and not being able to load the .do doc so it opens another new tab and another new tab and it keeps going and going. I have to force quit Firefox to get it to stop, then be offline when I reopen so it doesn't try to reload the page. Safari handles the .do thing just fine, but Firefox freaks out. I think a lot of credit card companies have this option as well so perhaps you can try it there if you don't have a utility company you can log into. It's usually in a protected area of the site. Just try to view a detailed billing statement or something that would call up a .do.

Reproducible: Always

Steps to Reproduce:
1. Log into your utility company's web site
2. Go to section where you can view past bills online
3.Try to open a bill from a previous month (not sure how you'd make sure it was a .do it was trying to open but if it is, trust me, it will create the loop)
Actual Results:  
Again, it creates an infinite loop of opening window/tab after window/tab and you can't stop it cuz it goes so fast. You have to force quit the browser to get it to stop, then make sure it can't reload the page when you reopen Firefox.

Expected Results:  
It should have displayed the .do page in a new tab or window. I've noticed that Firefox has never handled .do's well, but it used to at least go to where you could choose to save the file or open with another program (like Acrobat)

My email is trayce@dragonflyinc.net. In the interest of getting this fixed, if you truly don't have an account with any companies that use this method of displaying past billing statements that you can test it out on, I can maybe record a screen video of what's happening and send it to you. Please contact me if this is necessary.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 167320
You need to log in before you can comment on or make changes to this bug.