subscribe tree slow to open "alt." using twisties

RESOLVED WORKSFORME

Status

defect
RESOLVED WORKSFORME
19 years ago
5 years ago

People

(Reporter: sspitzer, Unassigned)

Tracking

({perf})

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

once the crasher is fixed, you'll see that typing "alt." causes the subscribe
dialog to block why we open the "alt." subtree.

it should not be as slow as it is.
QA Contact: esther → stephend
adding perf keyword.

accepting.
Status: NEW → ASSIGNED
Keywords: perf

Comment 2

19 years ago
really really really slow. I can confirm. Looking forward to solution :)

Updated

18 years ago
Blocks: 49141

Updated

18 years ago
No longer blocks: 49141

Updated

18 years ago
Keywords: mozilla1.0
alt is fine for me, with the somewhat recent implementation of the flat view of
search. (on all builds, Windows 2000, RedHat 7.1 and MacOS 9.1)
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
there is no more typedown, so that part of the bug is invalid.

one thing to check is that opening the "alt" twisty in the tree view is slow or not.

I bet it still is.
Right, I thought of that, but just thought since the summary of this bug was
with typedown specifically that it would be another bug (and, that bug would
depend on the re-write of outliner for the main subscribe window).  If you want,
I can re-open and re-scope this.  I'll check if we're still slow using the twisties.
Okay, re-opening.  This takes 3 seconds on my opt build, whereas a ns 4.7x build
is almost instantaneous.  Updating summary to reflect that this affects the tree
view only, with the twisties.
Status: RESOLVED → REOPENED
Hardware: PC → All
Resolution: WORKSFORME → ---
Summary: subscribe tree slow to open "alt." with typedown. → subscribe tree slow to open "alt." using twisties
Product: Browser → Seamonkey

Updated

14 years ago
Assignee: sspitzer → mail
Status: REOPENED → NEW

Updated

11 years ago
Component: MailNews: Subscribe → MailNews: Message Display
QA Contact: stephend → search
Assignee: mail → nobody
QA Contact: search → message-display
Priority: P3 → --
This bug is being marked EXPIRED as it has seen no activity in a very long time.

If you think that the issue reported might still be relevant, please test with a recent release of SeaMonkey and if the problem persists feel free to re-open the report. Thank you.

http://www.seamonkey-project.org/
Status: NEW → RESOLVED
Last Resolved: 18 years ago10 years ago
Resolution: --- → EXPIRED
Bulk reopening incorrectly expired bugs - no activity does not constitute no bug - these need proper checking.
Status: RESOLVED → REOPENED
Resolution: EXPIRED → ---
Status: REOPENED → UNCONFIRMED

Comment 9

10 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.9.1pre) Gecko/20090621 SeaMonkey/2.0b1pre

Opening the alt sub tree takes under 1 second.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.