switch subscribe over to use the outliner

VERIFIED FIXED

Status

defect
VERIFIED FIXED
18 years ago
5 years ago

People

(Reporter: sspitzer, Assigned: sspitzer)

Tracking

(Blocks 5 bugs, {meta})

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

this bug tracks the switching of subscribe over to use the outliner.

1) implementing a subscribe view, getting rid of the subscribe datasource
2) fixing the subscribe.xul and subscribe.js to use the outliner

then I can implement a search and new view for subscribe, like we had for 4.x

a bunch of problems will go away when this is done, I'll go make bugs depend on 
this one.

note, this work is going to have to wait until a low risk period.
adding a bunch of bugs that are blocked by this.

Status: NEW → ASSIGNED
Keywords: meta
QA Contact: esther → stephend
Hardware: PC → All
No longer blocks: 48409

Comment 2

18 years ago
*** Bug 88516 has been marked as a duplicate of this bug. ***

Comment 3

18 years ago
*** Bug 88499 has been marked as a duplicate of this bug. ***

Updated

18 years ago
Blocks: 73948

Updated

18 years ago
Blocks: 88499
we need nsSubscribeTreeView and nsSubscribeSearchView (which will be implemented
on to of nsIOutlinerView)

right now, a nsSubscribeSearchView is hacked into nsNntpIncomingServer, which is
wrong. 
No longer blocks: 87924
Subscribe uses outliner entirely, now.  Marking a DUP of the bug that contains
the patch for subscribe.js/subscribe.xul, bug 110155.

*** This bug has been marked as a duplicate of 110155 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
re-opening.  this was fixed by bug 110155, so I'll be marking that now.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
marking fixed.
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED
Verified FIXED with:

Mac OS X 10.1.3 - 2002-03-29-08
Windows 2000 - 2002-03-29-16
Mandrake 8.1 - 2002-03-29-11
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey

Updated

11 years ago
Component: MailNews: Subscribe → MailNews: Message Display
QA Contact: stephend → search
You need to log in before you can comment on or make changes to this bug.