Closed Bug 629889 Opened 9 years ago Closed 9 years ago

open all in tabs is broken from Library when no browser window is open

Categories

(Firefox :: Bookmarks & History, defect, blocker)

defect
Not set
blocker

Tracking

()

VERIFIED FIXED
Firefox 4.0b11
Tracking Status
blocking2.0 --- final+

People

(Reporter: tabmix.onemen, Assigned: mano)

References

(Blocks 1 open bug)

Details

(Keywords: regression, Whiteboard: [softblocker][fx4-fixed-bugday])

Attachments

(1 file, 2 obsolete files)

The changes in bug 562998 completely broke PlacesUIUtils._openTabset when no browser window is open.

Steps:
1. open browser window.
2. open Library
3. close the browser window
4. try to open tabs, "open all in tabs" or group of tabs.

In PlacesUIUtils._openTabset:
> var where = aWindow.whereToOpenLink(aEvent, false, true);
whereToOpenLink function was not design to return "window" when there is no
browser window!!!

also there is typo
- aWindow.openDialog(win.getBrowserURL(), "_blank",
-                          "chrome,all,dialog=no", urls.join("|"));
+ aWindow.openDialog(aWindow.getBrowserURL(), "_blank",
+                          "chrome,all,dialog=no", urls.join("|"));
Assignee: nobody → mano
Keywords: regression
Blocks: 562998
we should probably either fix this regression or backout the fix before the final, asking softblocking.
blocking2.0: --- → ?
Duplicate of this bug: 630024
Attached patch patch (obsolete) — Splinter Review
Sorry!
Attachment #508455 - Flags: review?(mak77)
Attached patch correctness (obsolete) — Splinter Review
Attachment #508455 - Attachment is obsolete: true
Attachment #508465 - Flags: review?(mak77)
Attachment #508455 - Flags: review?(mak77)
Attached patch readabilitySplinter Review
Attachment #508465 - Attachment is obsolete: true
Attachment #508473 - Flags: review?(mak77)
Attachment #508465 - Flags: review?(mak77)
Comment on attachment 508473 [details] [diff] [review]
readability

thanks.
Attachment #508473 - Flags: review?(mak77) → review+
Comment on attachment 508473 [details] [diff] [review]
readability

Asking approval or blocking to land this regression fix. low risk since mostly restoring old code behavior.
Attachment #508473 - Flags: approval2.0?
blocking2.0: ? → final+
Whiteboard: [softblocker]
Attachment #508473 - Flags: approval2.0?
http://hg.mozilla.org/mozilla-central/rev/0162ac678b8f
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
> Steps:
> 1. open browser window.
> 2. open Library
> 3. close the browser window
> 4. try to open tabs, "open all in tabs" or group of tabs.

Problem seems to be fixed. Unable to reproduce with

Mozilla/5.0 (Windows NT 5.1; rv:2.0b11) Gecko/20100101 Firefox/4.0b11 ID:20110202143949
Verified on Linux, too: Mozilla/5.0 (X11; Linux i686; rv:2.0b12pre) Gecko/20110204 Firefox/4.0b12pre
Status: RESOLVED → VERIFIED
Whiteboard: [softblocker] → [softblocker][bugday0204]
Whiteboard: [softblocker][bugday0204] → [softblocker][bugday0204][fx4-fixed-bugday]
Whiteboard: [softblocker][bugday0204][fx4-fixed-bugday] → [softblocker][fx4-fixed-bugday]
Blocks: FF2SM
Target Milestone: --- → Firefox 4.0b11
Flags: in-testsuite?
Flags: in-litmus?
No longer blocks: FF2SM
You need to log in before you can comment on or make changes to this bug.