Crash in mozilla::layers::LayerManagerD3D10::Render [@ CDevice::DriverInternalError(long) ] mainly with NVIDIA GPU

RESOLVED FIXED in mozilla23

Status

()

P5
critical
RESOLVED FIXED
8 years ago
2 years ago

People

(Reporter: scoobidiver, Assigned: bas.schouten)

Tracking

(Depends on: 1 bug, Blocks: 1 bug, {crash, reproducible})

Trunk
mozilla23
x86
Windows 7
crash, reproducible
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [STR in comment 3][gfx-noted][platform-rel-nVidia], crash signature)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
It is #64 top crasher in 4.0b10 over the last week.
It happens mainly with NVIDIA even with recent graphic driver versions.
All comments talk about a driver crash.

Signature	CDevice::DriverInternalError(long)
UUID	3b741dab-4c8b-4ce3-ac0a-00a5d2110128
Time 	2011-01-28 13:48:17.660146
Uptime	10794
Last Crash	687756 seconds (1.1 weeks) before submission
Install Age	107543 seconds (1.2 days) since version was first installed.
Product	Firefox
Version	4.0b10
Build ID	20110121161358
Branch	2.0
OS	Windows NT
OS Version	6.1.7600
CPU	x86
CPU Info	GenuineIntel family 6 model 15 stepping 11
Crash Reason	0x00000879 / 0x00000000
Crash Address	0x75669617
User Comments	my graphics card chrased for a second and when it came back I opened a still working firefox and when I clicked in something it crashed
App Notes 	AdapterVendorID: 10de, AdapterDeviceID: 05e2, AdapterDriverVersion: 8.17.12.6099

Frame 	Module 	Signature [Expand] 	Source
0 	KERNELBASE.dll 	RaiseException 	
1 	d3d10_1core.dll 	CDevice::DriverInternalError 	
2 	dxgi.dll 	CD3D10Device::DriverInternalError 	
3 	dxgi.dll 	_allmul 	
4 	dxgi.dll 	CDXGISwapChainBase<IDXGISwapChain>::PresentImpl 	
5 	dxgi.dll 	CDXGISwapChainBase<IDXGISwapChain>::Present 	
6 	xul.dll 	mozilla::layers::LayerManagerD3D10::Render 	gfx/layers/d3d10/LayerManagerD3D10.cpp:534
7 	xul.dll 	mozilla::layers::LayerManagerD3D10::EndTransaction 	gfx/layers/d3d10/LayerManagerD3D10.cpp:295
8 	xul.dll 	nsDisplayList::PaintForFrame 	layout/base/nsDisplayList.cpp:527
9 	xul.dll 	nsLayoutUtils::PaintFrame 	layout/base/nsLayoutUtils.cpp:1560
10 	xul.dll 	PresShell::Paint 	layout/base/nsPresShell.cpp:6144
11 	xul.dll 	nsViewManager::RenderViews 	view/src/nsViewManager.cpp:448
12 	xul.dll 	nsViewManager::Refresh 	view/src/nsViewManager.cpp:414
13 	xul.dll 	nsViewManager::DispatchEvent 	view/src/nsViewManager.cpp:915
14 	xul.dll 	AttachedHandleEvent 	view/src/nsView.cpp:193
15 	xul.dll 	nsWindow::DispatchEvent 	widget/src/windows/nsWindow.cpp:3727
16 	xul.dll 	nsWindow::DispatchWindowEvent 	widget/src/windows/nsWindow.cpp:3755
17 	xul.dll 	nsWindow::OnPaint 	
18 	xul.dll 	nsView::GetNearestWidget 	view/src/nsView.cpp:1077
19 	xul.dll 	SearchTable 	obj-firefox/xpcom/build/pldhash.c:439
20 	user32.dll 	LoadCursorW 	

More reports at:
https://crash-stats.mozilla.com/report/list?range_value=2&range_unit=weeks&signature=CDevice%3A%3ADriverInternalError%28long%29
Depends on: 610380
Crash Signature: [@ CDevice::DriverInternalError(long) ]

Comment 1

8 years ago
This has been rising sharply in the last two days (2011-08-07 and -08), reporting as the #41 topcrash overall on 5 and #80 on 6 yesterday.

We've seen ~3 crashes per million ADU on 5 until 2011-08-06 and then 45 and 49 crashes / M ADU in the following two days. On 6, that's similar, rising from 1-4 before to 36 and 33 crashes per million ADU.
(Reporter)

Comment 2

7 years ago
It's #32 top crasher in 7.0.1 and #25 in 8.0b1.

According to comments, it happens mainly while switching to Tab Groups, switching or closing tabs, playing videos, returning from standby or playing games such as Everquest 2, City of Heroes, Battlefield 3.
A fairly easy way for me to reproduce this bug is as follows:

1. Open up several tabs (I have around 20 on perma-open)
2. Close three of them in quick succession with Ctrl-W
3. Click the tab-preview button (I have browser.allTabs.previews set to true).

I think this crashes very near to 100% of the time for me.
(Reporter)

Updated

7 years ago
Keywords: reproducible
Whiteboard: [STR in comment 3]
Bas, can you try out the STR?
Assignee: nobody → bas.schouten
got a other crash for this 

  Application Basics

        Name
        Firefox

        Version
        8.0

        User Agent
        Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0) Gecko/20100101 Firefox/8.0

        Profile Directory

          Open Containing Folder

        Enabled Plugins

          about:plugins

        Build Configuration

          about:buildconfig

        Crash Reports

          about:crashes

  Extensions

        Name

        Version

        Enabled

        ID

        BitComet Video Downloader
        1.29
        true
        {B042753D-F57E-4e8e-A01B-7379A6D4CEFB}

        Greasemonkey
        0.9.13
        true
        {e4a8a97b-f2ed-450b-b12d-ee082ba24781}

        Java Console
        6.0.29
        false
        {CAFEEFAC-0016-0000-0029-ABCDEFFEDCBA}

        Kaspersky URL Advisor
        9.0.0.192
        false
        linkfilter@kaspersky.ru

        Skype Click to Call
        5.6.0.8442
        false
        {82AF8DCA-6DE9-405D-BD5E-43525BDAD38A}

  Modified Preferences

      Name

      Value

        accessibility.typeaheadfind.flashBar
        0

        browser.history_expire_days.mirror
        180

        browser.places.importBookmarksHTML
        false

        browser.places.smartBookmarksVersion
        2

        browser.startup.homepage
        http://www.bbc.co.uk/

        browser.startup.homepage_override.buildID
        20111104165243

        browser.startup.homepage_override.mstone
        rv:8.0

        dom.max_script_run_time
        0

        extensions.lastAppVersion
        8.0

        network.cookie.lifetimePolicy
        2

        network.cookie.prefsMigrated
        true

        places.database.lastMaintenance
        1321561321

        places.history.expiration.transient_current_max_pages
        128264

        places.last_vacuum
        1300289927

        print.print_printer
        KODAK 5300 AiO

        print.printer_KODAK_5300_AiO.print_bgcolor
        false

        print.printer_KODAK_5300_AiO.print_bgimages
        false

        print.printer_KODAK_5300_AiO.print_command

        print.printer_KODAK_5300_AiO.print_downloadfonts
        false

        print.printer_KODAK_5300_AiO.print_edge_bottom
        0

        print.printer_KODAK_5300_AiO.print_edge_left
        0

        print.printer_KODAK_5300_AiO.print_edge_right
        0

        print.printer_KODAK_5300_AiO.print_edge_top
        0

        print.printer_KODAK_5300_AiO.print_evenpages
        true

        print.printer_KODAK_5300_AiO.print_footercenter

        print.printer_KODAK_5300_AiO.print_footerleft
        &PT

        print.printer_KODAK_5300_AiO.print_footerright
        &D

        print.printer_KODAK_5300_AiO.print_headercenter

        print.printer_KODAK_5300_AiO.print_headerleft
        &T

        print.printer_KODAK_5300_AiO.print_headerright
        &U

        print.printer_KODAK_5300_AiO.print_in_color
        true

        print.printer_KODAK_5300_AiO.print_margin_bottom
        0.5

        print.printer_KODAK_5300_AiO.print_margin_left
        0.5

        print.printer_KODAK_5300_AiO.print_margin_right
        0.5

        print.printer_KODAK_5300_AiO.print_margin_top
        0.5

        print.printer_KODAK_5300_AiO.print_oddpages
        true

        print.printer_KODAK_5300_AiO.print_orientation
        1

        print.printer_KODAK_5300_AiO.print_page_delay
        50

        print.printer_KODAK_5300_AiO.print_pagedelay
        500

        print.printer_KODAK_5300_AiO.print_paper_data
        9

        print.printer_KODAK_5300_AiO.print_paper_height
        11.00

        print.printer_KODAK_5300_AiO.print_paper_size_type
        0

        print.printer_KODAK_5300_AiO.print_paper_size_unit
        1

        print.printer_KODAK_5300_AiO.print_paper_width
        8.50

        print.printer_KODAK_5300_AiO.print_reversed
        false

        print.printer_KODAK_5300_AiO.print_scaling
        1.00

        print.printer_KODAK_5300_AiO.print_shrink_to_fit
        true

        print.printer_KODAK_5300_AiO.print_to_file
        false

        print.printer_KODAK_5300_AiO.print_unwriteable_margin_bottom
        0

        print.printer_KODAK_5300_AiO.print_unwriteable_margin_left
        0

        print.printer_KODAK_5300_AiO.print_unwriteable_margin_right
        0

        print.printer_KODAK_5300_AiO.print_unwriteable_margin_top
        0

        privacy.cpd.cookies
        false

        privacy.cpd.downloads
        false

        privacy.cpd.formdata
        false

        privacy.cpd.history
        false

        privacy.cpd.sessions
        false

        privacy.sanitize.migrateFx3Prefs
        true

        privacy.sanitize.timeSpan
        0

        security.warn_viewing_mixed
        false

  Graphics

        Adapter Description
        NVIDIA GeForce GTX 460

        Vendor ID
        10de

        Device ID
        0e22

        Adapter RAM
        1024

        Adapter Drivers
        nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um

        Driver Version
        8.17.12.8562

        Driver Date
        10-15-2011

        Adapter RAM (GPU #2)
        Unknown

        Adapter Drivers (GPU #2)
        Unknown

        Direct2D Enabled
        true

        DirectWrite Enabled
        true (6.1.7601.17563)

        ClearType Parameters
        ClearType parameters not found

        WebGL Renderer
        Google Inc. -- ANGLE -- OpenGL ES 2.0 (ANGLE 0.0.0.686)

        GPU Accelerated Windows
        1/1 Direct3D 10

support told me to add that information to the bug
(Reporter)

Updated

7 years ago
Blocks: 605749
(Reporter)

Updated

7 years ago
Keywords: topcrash
Looks practically the same as bug 612120. Calling Present seems to be failing hard for some reason.
It doesn't look we get any more information in the crash reports. It looks like something is screwy enough to crash us, but we're not recording what the errors are. I have a windows machine, so I can try the STR in the morning.

Based on the spec, the HRESULT we aren't checking could be one of:
Possible return values include: S_OK, DXGI_ERROR_DEVICE_RESET or DXGI_ERROR_DEVICE_REMOVED (see DXGI_ERROR), DXGI_STATUS_OCCLUDED (see DXGI_STATUS), or D3DDDIERR_DEVICEREMOVED.
A 10.0a2 report pointing to this ccan be found here: https://crash-stats.mozilla.com/report/index/bp-63472474-f2ee-46de-862b-7a4c32111217
I just hit this using a 1/10 nightly (https://crash-stats.mozilla.com/report/index/bp-c1513d24-846b-4790-9f70-a365c2120201) -- I wasn't doing anything special.  A bunch of tabs were open, I was in my Rdio tab, and I -may- have clicked a button or just moved the mouse.  No games etc. open.

I don't know that there are any HRESULT values that we could be checking; the crash is happening -inside- Present(), no?  Or do you mean that we got an error in an earlier Present, and that we're calling Present again while in a bad state?

This is using RaiseException though; in theory we could be wrapping Present in a SEH catch and at least recording the exception, or something higher... though I thought that we had a global exception handler, too.

Comment 10

7 years ago
Jeff, were you able to reproduce this?
(Reporter)

Updated

7 years ago
Crash Signature: [@ CDevice::DriverInternalError(long) ] → [@ CDevice::DriverInternalError(long)] [@ kernelbase.dll@0x9673]
FWIW, this has been hitting me maybe once a day as well. I have not put this theory to any form of scientific rigour, but it *seems* to always happen in the morning, when I get in to the office, about an hour or so after I've restored my machine from suspend. Additionally, it might be interesting to know that it also only happens after my graphics driver has crashed (usually, though, hours before, and before I've suspended my computer) and Windows restarted it.

Let me know if there's anything else I can try out. The STR in comment 3 don't reproduce the crash for me.
(Assignee)

Comment 12

7 years ago
We've discussed this issue before, this is exception 0x00000879. You can find quite a lot of it out there, and what you can find suggests its a continuable exception. In the past I've suggested try-catching this exception and continuing while setting the device as needing to be recreated (and if that fails to drop acceleration).

I still think this is the best idea. Let's try it on m-c and see if it helps!
Blocks: 720676
Duplicate of this bug: 741194
(Reporter)

Comment 14

7 years ago
(In reply to Bas Schouten (:bas) from comment #12)
> In the past I've suggested try-catching this exception and continuing while
> setting the device as needing to be recreated (and if that fails to drop 
> acceleration).
> I still think this is the best idea. Let's try it on m-c and see if it helps!
Was there a new bug filed or a patch written about that?
(Reporter)

Comment 15

7 years ago
It's #14 top browser crasher in 11.0, #12 in 12.0b6, #10 in 13.0a2, and #14 in 14.0a1.

Comment 16

7 years ago
This is staying constantly high, #13 in 12.* data from yesterday.

Any chance we can find a way to move forward on this?
Duplicate of this bug: 767012
I just hit this when my GPU/graphics driver crashed/reset (while playing starcraft) and then Firefox crashed.

https://crash-stats.mozilla.com/report/index/bp-6f1937f5-c68f-4652-8b25-1d2872120813 let me know if there is more useful information I can provide.
(Reporter)

Updated

6 years ago
Crash Signature: [@ CDevice::DriverInternalError(long)] [@ kernelbase.dll@0x9673] → [@ CDevice::DriverInternalError(long)] [@ kernelbase.dll@0x9673] [@ kernelbase.dll@0xc41f]
(Reporter)

Comment 19

6 years ago
It's #2 top crasher in the B2G emulator (18.0a2/20121115030319).

Comment 20

6 years ago
This signature is rising significantly on 18 beta in the last few days, but we need to check if that's only because we recently got symbols for some new library versions, so it might just be shifting from the unsymbolized to the symbolized variant.

Comment 21

6 years ago
Based on only my experience, I would guess a rise isn't just caused by new symbols. It's happened to me several times in the past couple of days, and I hadn't seen it previously. That coincides with both my updating to Firefox 18.0b6 (from beta 5) and also to NVIDIA drivers 310.70 (from 306.something).

Sometimes before the crash, the Firefox tab text and Firefox button text appear on glass (without their background which should be over the glass bar behind). After that happens, further (quick) switching around between tabs, or closing tabs, causes this crash for me.

Comment 22

6 years ago
(In reply to Robert Kaiser (:kairo@mozilla.com) from comment #20)
> This signature is rising significantly on 18 beta in the last few days [before Dec 26]
[...]

The final 310.70 drivers were released in December, and I got the update prompt on December 19th - sounds like the timing coincide with the increase.
(Assignee)

Comment 23

6 years ago
I will attempt to get a hold of folks at NVidia to see if they can help us out here.

Comment 24

6 years ago
(In reply to Bas Schouten (:bas.schouten) from comment #23)
> I will attempt to get a hold of folks at NVidia to see if they can help us
> out here.

Bas, ping? This continues to be the #14 topcrash on 18.0.1 atm.
Flags: needinfo?(bas)
(Assignee)

Comment 25

6 years ago
I've e-mailed NVidia and will update this bug as soon as I have a reply.
Flags: needinfo?(bas)
(In reply to Bas Schouten (:bas.schouten) from comment #25)
> I've e-mailed NVidia and will update this bug as soon as I have a reply.

Hey Bas, any news from folks at Nvidia yet ? Else what do you think about going with your suggestion in comment # 12 or any other ideas you may have, to move fwd on this top-crasher(#16 in 18.0.1)?
(Assignee)

Comment 27

6 years ago
(In reply to bhavana bajaj [:bajaj] from comment #26)
> (In reply to Bas Schouten (:bas.schouten) from comment #25)
> > I've e-mailed NVidia and will update this bug as soon as I have a reply.
> 
> Hey Bas, any news from folks at Nvidia yet ? Else what do you think about
> going with your suggestion in comment # 12 or any other ideas you may have,
> to move fwd on this top-crasher(#16 in 18.0.1)?

I've had no reply. I think going forward with that suggestion is a good idea but it's not trivial and I have little time to do it right now.
(Assignee)

Comment 28

6 years ago
Are there any crashes with the 313.95 driver btw here?

Comment 29

6 years ago
(In reply to Bas Schouten (:bas.schouten) from comment #28)
> Are there any crashes with the 313.95 driver btw here?

I think bjacob has a script that can figure this out.
Flags: needinfo?(bjacob)
(Reporter)

Comment 30

6 years ago
(In reply to Bas Schouten (:bas.schouten) from comment #28)
> Are there any crashes with the 313.95 driver btw here?
yes.
     92% (571/621) vs.   5% (8255/174276) nvwgf2um.dll
          0% (2/621) vs.   0% (12/174276) 8.17.12.5721
          0% (2/621) vs.   0% (3/174276) 8.17.12.5729
          0% (1/621) vs.   0% (3/174276) 8.17.12.5730
          0% (1/621) vs.   0% (1/174276) 8.17.12.5735
          0% (2/621) vs.   0% (8/174276) 8.17.12.5737
          0% (1/621) vs.   0% (7/174276) 8.17.12.5738
          0% (2/621) vs.   0% (4/174276) 8.17.12.5887
          0% (3/621) vs.   0% (3/174276) 8.17.12.5888
          2% (13/621) vs.   0% (69/174276) 8.17.12.5896
          0% (3/621) vs.   0% (9/174276) 8.17.12.5897
          2% (10/621) vs.   0% (28/174276) 8.17.12.5903
          0% (1/621) vs.   0% (1/174276) 8.17.12.5904
          2% (14/621) vs.   0% (49/174276) 8.17.12.5912
          1% (8/621) vs.   0% (25/174276) 8.17.12.5919
          3% (20/621) vs.   0% (41/174276) 8.17.12.5922
          4% (24/621) vs.   0% (32/174276) 8.17.12.5926
          4% (25/621) vs.   0% (55/174276) 8.17.12.5936
          0% (2/621) vs.   0% (4/174276) 8.17.12.5944
          0% (2/621) vs.   0% (7/174276) 8.17.12.5947
          2% (15/621) vs.   0% (19/174276) 8.17.12.5957
          0% (1/621) vs.   0% (2/174276) 8.17.12.5959
          0% (1/621) vs.   0% (28/174276) 8.17.12.5964
          4% (23/621) vs.   0% (32/174276) 8.17.12.5965
          0% (2/621) vs.   0% (2/174276) 8.17.12.5987
          4% (27/621) vs.   0% (36/174276) 8.17.12.5993
          0% (1/621) vs.   0% (26/174276) 8.17.12.5997
          0% (1/621) vs.   0% (8/174276) 8.17.12.6089
          0% (1/621) vs.   0% (62/174276) 8.17.12.6099
          0% (1/621) vs.   0% (11/174276) 8.17.12.6101
          0% (1/621) vs.   0% (18/174276) 8.17.12.6114
          1% (7/621) vs.   0% (11/174276) 8.17.12.6128
          0% (1/621) vs.   0% (1/174276) 8.17.12.6132
          1% (5/621) vs.   0% (6/174276) 8.17.12.6136
          0% (2/621) vs.   0% (2/174276) 8.17.12.6137
          0% (1/621) vs.   0% (5/174276) 8.17.12.6141
          0% (1/621) vs.   0% (1/174276) 8.17.12.6153
          0% (1/621) vs.   0% (3/174276) 8.17.12.6313
          0% (1/621) vs.   0% (5/174276) 8.17.12.6639
          1% (4/621) vs.   0% (79/174276) 8.17.12.6658
          0% (1/621) vs.   0% (6/174276) 8.17.12.6716
          0% (1/621) vs.   0% (4/174276) 8.17.12.6733
          0% (1/621) vs.   0% (3/174276) 8.17.12.6744
          0% (2/621) vs.   0% (4/174276) 8.17.12.6759
          0% (1/621) vs.   0% (38/174276) 8.17.12.6785
          0% (1/621) vs.   0% (4/174276) 8.17.12.6901
          0% (2/621) vs.   0% (26/174276) 8.17.12.6973
          0% (1/621) vs.   0% (1/174276) 8.17.12.7048
          1% (4/621) vs.   0% (90/174276) 8.17.12.7061
          0% (1/621) vs.   0% (2/174276) 8.17.12.7073
          0% (2/621) vs.   0% (94/174276) 8.17.12.7533
          0% (1/621) vs.   0% (5/174276) 8.17.12.7588
          0% (1/621) vs.   0% (10/174276) 8.17.12.8019
          1% (6/621) vs.   0% (88/174276) 8.17.12.8026
          1% (6/621) vs.   0% (133/174276) 8.17.12.8562
          0% (1/621) vs.   0% (2/174276) 8.17.12.8590
          1% (6/621) vs.   0% (94/174276) 8.17.12.9573
          1% (5/621) vs.   0% (119/174276) 8.17.12.9610
          0% (1/621) vs.   0% (8/174276) 8.17.12.9616
          0% (1/621) vs.   0% (28/174276) 8.17.12.9619
          0% (1/621) vs.   0% (1/174276) 8.17.12.9627
          0% (1/621) vs.   0% (4/174276) 8.17.12.9644
          0% (1/621) vs.   0% (1/174276) 8.17.12.9686
          2% (14/621) vs.   0% (230/174276) 8.17.13.142
          0% (1/621) vs.   0% (11/174276) 9.18.13.1033
          0% (1/621) vs.   0% (11/174276) 9.18.13.1054
          0% (1/621) vs.   0% (11/174276) 9.18.13.1061
          6% (35/621) vs.   0% (500/174276) 9.18.13.1070
         13% (80/621) vs.   1% (1176/174276) 9.18.13.1090
          0% (1/621) vs.   0% (5/174276) 9.18.13.1395   <--- HERE
          0% (1/621) vs.   0% (48/174276) 9.18.13.1396
          1% (6/621) vs.   0% (84/174276) 9.18.13.623
         24% (149/621) vs.   2% (3817/174276) 9.18.13.697
          0% (1/621) vs.   0% (20/174276) 9.18.13.774
Flags: needinfo?(bjacob)
(In reply to Robert Kaiser (:kairo@mozilla.com) from comment #29)
> (In reply to Bas Schouten (:bas.schouten) from comment #28)
> > Are there any crashes with the 313.95 driver btw here?
> 
> I think bjacob has a script that can figure this out.

Not ready-made script, but thanks to CSV files this can be done with a bash one-liner:

bjacob:~/crash-stats$ for p in `seq 1 4`; do echo "date: 2013020$p" && echo "crashes with 313.95 driver and this signature: `(zcat 2013020$p-pub-crashdata.csv.gz | grep 'CDevice::DriverInternalError(long)' | grep '3\.1395' | wc -l)`"  && echo "crashes with 313.95 driver: `(zcat 2013020$p-pub-crashdata.csv.gz | grep '3\.1395' | wc -l)`" && echo "crashes with this signature: `(zcat 2013020$p-pub-crashdata.csv.gz | grep 'CDevice::DriverInternalError(long)' | wc -l)`" && echo "total crashes: `(zcat 2013020$p-pub-crashdata.csv.gz | wc -l)`"; done
date: 20130201
crashes with 313.95 driver and this signature: 0
crashes with 313.95 driver: 29
crashes with this signature: 947
total crashes: 438094
date: 20130202
crashes with 313.95 driver and this signature: 0
crashes with 313.95 driver: 22
crashes with this signature: 884
total crashes: 414618
date: 20130203
crashes with 313.95 driver and this signature: 1
crashes with 313.95 driver: 25
crashes with this signature: 870
total crashes: 421017
date: 20130204
crashes with 313.95 driver and this signature: 1
crashes with 313.95 driver: 34
crashes with this signature: 989
total crashes: 456856


So there is no evidence here of any correlation between this signature and this driver version.
QA wanted: please reproduce this; str given in comment 3.
Keywords: qawanted
QA note: this is on Windows with NVIDIA graphics. May be dependent on NVIDIA driver version (see above).
If anyone is currently experiencing this bug, I would like your permission to send your minidump to nvidia. My report from last August has already been purged.
Flags: needinfo?
(Assignee)

Comment 35

6 years ago
Created attachment 735189 [details] [diff] [review]
Check for removed device before calling present

This is a patch which could both fix the crash in a 'reasonable' way (we'll drop one frame but that could be okay), as well as provide a lot of diagnostic information.
Attachment #735189 - Flags: review?(jmuizelaar)
Flags: needinfo?
Comment on attachment 735189 [details] [diff] [review]
Check for removed device before calling present

Review of attachment 735189 [details] [diff] [review]:
-----------------------------------------------------------------

::: gfx/layers/d3d10/LayerManagerD3D10.cpp
@@ +761,5 @@
> +  // and bails on composition. On the -next- frame we will then abandon
> +  // hardware acceleration from gfxWindowsPlatform::VerifyD2DDevice.
> +  // This might not be the 'optimal' solution but it will help us assert
> +  // whether our thoughts of the causes of the issues are correct.
> +  if (FAILED(mDevice->GetDeviceRemovedReason())) {

Add a report failure here.
Attachment #735189 - Flags: review?(jmuizelaar) → review+
https://hg.mozilla.org/mozilla-central/rev/82a60cd87361
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla23
Scoobidiver, can you verify via crash-stats in a couple days? I'd like to uplift this to Aurora and probably Beta if we can show that it helps.
QA Contact: scoobidiver
(Reporter)

Comment 40

6 years ago
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #39)
> Scoobidiver, can you verify via crash-stats in a couple days?
Here is a link to check on demand: https://crash-stats.mozilla.com/report/list?product=Firefox&version=Firefox%3A23.0a1&range_value=4&range_unit=weeks&signature=CDevice%3A%3ADriverInternalError%28long%29
(Reporter)

Comment 41

6 years ago
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #39)
> Scoobidiver, can you verify via crash-stats in a couple days?
Here is the crash history:
2013041503	0
2013041403	0
2013041303	1
2013041203	1
2013041103	5
2013041006	2 <- first build with the patch
2013041003	4
2013040903	6
2013040803	3
2013040703	4
2013040603	1
2013040510	2
2013040503	1
2013040403	2
2013040309	3
2013040303	3
2013040203	5

It's unclear how it improves things (lag effect between date and builddate), if it does. I would reopen this bug.
Yes, this is clearly still present in builds with the patch.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 43

6 years ago
It's #35 crasher in 20.0.1, #41 in 21.0b3, #22 in 22.0a2, and #61 in 23.0a1 so no longer a top crasher.
Keywords: topcrash

Comment 44

5 years ago
Mozilla/5.0 (Windows NT 6.1; rv:29.0) Gecko/20100101 Firefox/29.0 (20140115030229)
I tried to reproduce this crash with the steps in comment 3 and the All Tabs Restorer 1.3 extension given the tab preview feature was removed since Firefox 21. There was no crash though.

According to Socorro, the bug is still happening to some users though (only with this signature, the other two are gone):
https://crash-stats.mozilla.com/report/list?signature=CDevice%3A%3ADriverInternalError%28long%29&product=Firefox&query_type=contains&range_unit=weeks&process_type=any&hang_type=any&date=2014-01-15+15%3A00%3A00&range_value=4#reports
Keywords: qawanted

Updated

3 years ago
Crash Signature: [@ CDevice::DriverInternalError(long)] [@ kernelbase.dll@0x9673] [@ kernelbase.dll@0xc41f] → [@ CDevice::DriverInternalError(long)] [@ kernelbase.dll@0x9673] [@ kernelbase.dll@0xc41f] [@ CDevice::DriverInternalError]
This crash is still being reported in current Firefox versions with 311 reports in Firefox 48.0.2. However I no longer see a strong correlation to NVIDIA GPUs (94% Intel vs 3% NVIDIA vs 2% AMD)
Priority: -- → P5
Whiteboard: [STR in comment 3] → [STR in comment 3][gfx-noted]
platform-rel: --- → ?
Whiteboard: [STR in comment 3][gfx-noted] → [STR in comment 3][gfx-noted][platform-rel-nVidia]
platform-rel: ? → ---
I'm marking this bug as FIXED per comment #38,
also bug crashlog signature didn't appear from a long time (over half year) in Firefox (except some obsolete Fx <35, no crashes starting since Fx 35).
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.