[SeaMonkey] mochitest-browser-chrome: permanent failures in browser_purchase.js ("Got about:addons, expected http://example.com/browser/...", etc)

VERIFIED FIXED in mozilla2.0b12

Status

()

defect
--
major
VERIFIED FIXED
8 years ago
8 years ago

People

(Reporter: sgautherie, Assigned: neil)

Tracking

(Blocks 1 bug)

Trunk
mozilla2.0b12
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [perma-orange], URL)

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

8 years ago
Linux and Windows are affected, OSX is not :-|
I can reproduce on my Windows 2000.

{
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_purchase.js | Should have loaded the right page - Got about:addons, expected http://example.com/browser/toolkit/mozapps/extensions/test/browser/releaseNotes.xhtml?addon4
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_purchase.js | Should be back to the add-ons manager - Got about:blank, expected about:addons
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_purchase.js | Test timed out
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_purchase.js | Should not have seen an install of http://example.com/addon1.xpi in state 0
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_purchase.js | Found a tab after previous test timed out: http://example.com/browser/toolkit/mozapps/extensions/test/browser/releaseNotes.xhtml?addon4
}
(Reporter)

Updated

8 years ago
blocking-seamonkey2.1: --- → ?
status2.0: --- → ?
(Reporter)

Comment 1

8 years ago
(In reply to comment #0)
> Linux and Windows are affected, OSX is not :-|

Hum, it looks like OSX 10.5 does fail too, whereas OSX 10.16 passes :-:
Anyway.
(Reporter)

Comment 2

8 years ago
Code is:
{
// Tests that clicking the buy button from the details view works
add_test(function() {
  gBrowser.addEventListener("load", function() {
    if (gBrowser.currentURI.spec == "about:blank")
      return;
    gBrowser.removeEventListener("load", arguments.callee, true);

    is(gBrowser.currentURI.spec, TESTROOT + "releaseNotes.xhtml?addon4", "Should have loaded the right page");
}

This failure is odd: it seems gBrowser.currentURI.spec changes during callback execution :-(
(Assignee)

Comment 3

8 years ago
Posted patch Proposed patch (obsolete) — Splinter Review
So, our tabbrowsers have some minor differences and while we don't fire the about:blank that you're trying to avoid we do fire a different about:blank!
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #508720 - Flags: review?
(Assignee)

Comment 4

8 years ago
Comment on attachment 508720 [details] [diff] [review]
Proposed patch

Bah, typoed your name, please read comment #3 kthxbye
Attachment #508720 - Flags: review? → review?(bmcbride)
Comment on attachment 508720 [details] [diff] [review]
Proposed patch

>-  gBrowser.addEventListener("load", function() {
>-    if (gBrowser.currentURI.spec == "about:blank")
>+  gBrowser.addEventListener("load", function(event) {
>+    if (event.target.location.href == "about:blank")

You'll need to do the same for the other case where the tests checks this too.

(I assume you've tested this on a Firefox build, and/or run it through TryServer)
Attachment #508720 - Flags: review?(bmcbride) → review-
(Assignee)

Comment 6

8 years ago
Attachment #508720 - Attachment is obsolete: true
(Assignee)

Comment 7

8 years ago
Comment on attachment 509782 [details] [diff] [review]
Updated patch
[Checked in: Comment 9]

Passes on both my local Firefox and SeaMonkey builds.
Attachment #509782 - Flags: review?(bmcbride)
Comment on attachment 509782 [details] [diff] [review]
Updated patch
[Checked in: Comment 9]

Sorry for the delay - was off sick.
Attachment #509782 - Flags: review?(bmcbride) → review+
(Reporter)

Comment 9

8 years ago
Comment on attachment 509782 [details] [diff] [review]
Updated patch
[Checked in: Comment 9]

http://hg.mozilla.org/mozilla-central/rev/2ce5e1843ce8
Attachment #509782 - Attachment description: Updated patch → Updated patch [Checked in: Comment 9]
(Reporter)

Updated

8 years ago
Status: ASSIGNED → RESOLVED
blocking-seamonkey2.1: ? → ---
Last Resolved: 8 years ago
status2.0: ? → ---
Component: UI Design → Add-ons Manager
Flags: in-testsuite+
Product: SeaMonkey → Toolkit
QA Contact: ui-design → add-ons.manager
Resolution: --- → FIXED
Target Milestone: --- → mozilla2.0b12
(Reporter)

Comment 10

8 years ago
Still this bug as reported:
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1296824378.1296829595.24188.gz
WINNT 5.2 comm-central-trunk debug test mochitest-other on 2011/02/04 04:59:38
{
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_purchase.js | Should have loaded the right page - Got about:addons, expected http://example.com/browser/toolkit/mozapps/extensions/test/browser/releaseNotes.xhtml?addon4
}

New error(s), see bug 632396:
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1296847508.1296852650.24834.gz
WINNT 5.2 comm-central-trunk debug test mochitest-other on 2011/02/04 11:25:08
{
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_purchase.js | Should be 5 results - Got 1, expected 5
...
}

This bug can't be verified atm as it made no difference yet :-/
Let's wait for bug 632396!
Depends on: 632396
(Reporter)

Comment 11

8 years ago
The test passes, but:
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1297485532.1297489043.18251.gz&fulltext=1
WINNT 5.2 comm-central-trunk debug test mochitest-other on 2011/02/11 20:38:52
{
JavaScript strict warning: chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser-window/browser_purchase.js, line 140: reference to undefined property event.target.location
JavaScript error: chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser-window/browser_purchase.js, line 140: event.target.location is undefined
JavaScript strict warning: chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser-window/browser_purchase.js, line 140: reference to undefined property event.target.location
JavaScript error: chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser-window/browser_purchase.js, line 140: event.target.location is undefined
...
JavaScript strict warning: chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser-window/browser_purchase.js, line 164: reference to undefined property event.target.location
JavaScript error: chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser-window/browser_purchase.js, line 164: event.target.location is undefined
JavaScript strict warning: chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser-window/browser_purchase.js, line 164: reference to undefined property event.target.location
JavaScript error: chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser-window/browser_purchase.js, line 164: event.target.location is undefined
}
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 12

8 years ago
Looks like the test bogusly failed to look for the actual document load :-(
Attachment #511957 - Flags: review?(bmcbride)
Comment on attachment 511957 [details] [diff] [review]
Only listen to document loads
[Checked in: Comment 14]

Your about:blank is weird :)
Attachment #511957 - Flags: review?(bmcbride) → review+
(Assignee)

Comment 14

8 years ago
Pushed changeset acda9a0a6c6f to mozilla-central.
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED
(Reporter)

Updated

8 years ago
Attachment #511957 - Attachment description: Only listen to document loads → Only listen to document loads [Checked in: Comment 14]
(Reporter)

Comment 15

8 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1297896528.1297900353.15666.gz&fulltext=1
Rev3 WINNT 6.1 mozilla-central debug test mochitest-other on 2011/02/16 14:48:48

http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1297890609.1297893535.22210.gz&fulltext=1
OS X 10.6 comm-central-trunk debug test mochitest-other on 2011/02/16 17:23:43

V.Fixed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.