The default bug view has changed. See this FAQ.

[SeaMonkey] mochitest-browser-chrome: about 170 test failures caused by "incompatible" DOMi

VERIFIED FIXED in seamonkey2.1b3

Status

SeaMonkey
Startup & Profiles
--
major
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: sgautherie, Assigned: sgautherie)

Tracking

(Blocks: 1 bug)

Trunk
seamonkey2.1b3
Dependency tree / graph
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fixed by bug 631286] [perma-orange])

(Assignee)

Description

6 years ago
http://build.mozillamessaging.com/tinderboxpushlog/?tree=SeaMonkey
See "bugzilla@standard8.plus.com – Fri Feb 4 02:46:52 2011 PST"
Regression timeframe:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=f2a6a78478dc&tochange=51f36c6a7d38
Bug 627328...

I'm not sure whether this is a Core regression or not-yet-updated (SeaMonkey) tests.
(Assignee)

Updated

6 years ago
Blocks: 630462
(Assignee)

Updated

6 years ago
status2.0: --- → ?
It's hard to find which tests are exactly failing in SeaMonkey's TBPL. Could you given me a [few] mxr links? I had a test that needed to be updated in mozilla-central so it might be the same issue.
(Assignee)

Comment 2

6 years ago
I ran toolkit/mozapps/extensions/test/browser/browser_bug557956.js locally
and noticed that bug 631286 should help, if not fix this issue...

Maybe there's a "trick" that I'm not aware of, as updating SeaMonkey version was the changeset just before comment 0 timeframe :-/

Let's hope that's just that.
Depends on: 631286

Comment 3

6 years ago
Not sure how much what's set on AMO matters here. If it does, we'll in addition need to file bugs on venkman and ChatZilla updating their info on AMO for compatibility with 2.1b3, which their maintainers need to set.
(Assignee)

Comment 4

6 years ago
(In reply to comment #2)
> and noticed that bug 631286 should help, if not fix this issue...

Bug 631286, indeed :-<


(In reply to comment #3)
> Not sure how much what's set on AMO matters here.

AMO should not matter, afaik.
Assignee: nobody → sgautherie.bz
No longer blocks: 627328
Status: NEW → RESOLVED
Last Resolved: 6 years ago
status2.0: ? → ---
Component: XUL → Startup & Profiles
Flags: in-testsuite-
Product: Core → SeaMonkey
QA Contact: xptoolkit.widgets → profile-manager
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.1b3
(Assignee)

Comment 5

6 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1297218906.1297220835.10413.gz
OS X 10.5 comm-central-trunk debug test mochitest-other on 2011/02/08 18:35:06
{
mochitest-browser-chrome: 11221/0/8
}

V.Fixed
Status: RESOLVED → VERIFIED
Keywords: regression
Summary: [SeaMonkey] mochitest-browser-chrome: about 170 test failures after bug 627328 landing → [SeaMonkey] mochitest-browser-chrome: about 170 test failures caused by "incompatible" DOMi
Whiteboard: [perma-orange] → [fixed by bug 631286] [perma-orange]

Comment 6

6 years ago
(In reply to comment #4)
> (In reply to comment #3)
> > Not sure how much what's set on AMO matters here.
> AMO should not matter, afaik.
Although Mossop told me on IRC that AMO data overrides install.rdf, we shouldn't be pinging AMO on a test run, should we?

Comment 7

6 years ago
(In reply to comment #6)
> Although Mossop told me on IRC that AMO data overrides install.rdf, we
> shouldn't be pinging AMO on a test run, should we?

And we probably aren't as browser-chrome is green. We still probably should file bugs on those two add-ons to correct the AMO settings (or grab a hold of their maintainers on IRC).
You need to log in before you can comment on or make changes to this bug.