Closed Bug 630634 Opened 9 years ago Closed 9 years ago

After uninstalling restartless add-on, empty add-on bar reappears on next restart

Categories

(Firefox :: Toolbars and Customization, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Tracking Status
blocking2.0 --- final+

People

(Reporter: adw, Assigned: dietrich)

References

Details

(Whiteboard: [addon bar][hardblocker])

Attachments

(1 file)

Spun out from bug 627484 comment 25.

1. New profile.
2. Install a restartless add-on (or maybe it has to be an SDK-built add-on that uses a widget).  The add-on bar should appear.
3. Uninstall the add-on.  The add-on bar should disappear.
4. Restart.

Actual results:
The empty add-on bar appears on restart.

Expected results:
The add-on bar should remain hidden on restart.
Reproducible -> softblocker.
Assignee: nobody → dietrich
blocking2.0: --- → final+
Whiteboard: [addon bar] → [addon bar][softblocker]
Dave: my addon listener wasn't getting called when i uninstalled a restartless addon.

then i realized it *was* getting called... at shutdown.

then i realized that it was *actually* getting called whenever the AOM was closed.

shouldn't we be sending onUninstalling and onUninstalled when the uninstall happens? is this by design, or a bug?
Sort of by design, it's really a workaround for now to get the UI we wanted working in bug 553494. Basically when clicking uninstall we just disable the add-ons and don't uninstall them till the UI goes away.
That's... problematic.
Related to bug 620541, no?  If not, let's file a separate bug for the behavior described in comment 2.
Depends on: 620541
Kind of a mix of that, bug 582002 and bug 612168
Attached patch fixSplinter Review
handle enable/disable, which should've been done all along, but also works around the EM bug.
Attachment #511027 - Flags: review?(dtownsend)
Attachment #511027 - Flags: review?(dtownsend) → review+
http://hg.mozilla.org/mozilla-central/rev/afb62e95311a
Whiteboard: [addon bar][softblocker] → [addon bar][hardblocker]
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Oops, forgot to comment: Changed to hardblocker because the enable/disable support was absent, which is pretty broken.
You need to log in before you can comment on or make changes to this bug.