4.0b11 Flash Crash [@ NPSWF32.dll@0x16f07a ] on Youtube / Plugin fullscreen mode

RESOLVED INVALID

Status

External Software Affecting Firefox
Flash (Adobe)
--
critical
RESOLVED INVALID
7 years ago
2 years ago

People

(Reporter: Scott A., Assigned: jimm)

Tracking

({crash, regression, reproducible})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [4b11] [Flash 10.2 only][fixed by Flash 10.2.152.32], crash signature, URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b11) Gecko/20100101 Firefox/4.0b11
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b11) Gecko/20100101 Firefox/4.0b11

Huge spike in crash on 4.0b11, I can reproduce it 100% of the time.. Causes Address bar / toolbar to not respond, ultimately the browser needs to be restarted.

Reproducible: Always

Steps to Reproduce:
1. Open a Youtube video (http://www.youtube.com/watch?v=qi5nTb-NRFU)
2. Click Full Screen
3. Crash [@ NPSWF32.dll@0x16f07a ]
Actual Results:  
Plugin crashes, browser becomes unresponsive and needs restarted.

Expected Results:  
Not do that

https://crash-stats.mozilla.com/report/index/bp-cc802b6f-8e58-4ca1-b821-244ac2110202



Flash plugin: 
    Version: 10.2.152.14
    Shockwave Flash 10.2 r152

  Graphics:
        Adapter Description
        NVIDIA GeForce G102M

        Vendor ID
        10de

        Device ID
        0873

        Adapter RAM
        512

        Adapter Drivers
        nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um

        Driver Version
        8.17.12.6658

        Driver Date
        1-7-2011

        Direct2D Enabled
        true

        DirectWrite Enabled
        true (6.1.7600.20830, font cache 0.28 MB)

        WebGL Renderer
        Google Inc. -- ANGLE -- OpenGL ES 2.0 (ANGLE 0.0.0.541)

        GPU Accelerated Windows
        1/1 Direct3D 10
(Reporter)

Updated

7 years ago
blocking2.0: --- → ?
Keywords: crash, regression

Updated

7 years ago
Component: General → General
Product: Firefox → Core
QA Contact: general → general

Comment 1

7 years ago
Does this same crash happen with Flash 10.1? This may be the same as bug 630697.
Component: General → Plug-ins
QA Contact: general → plugins

Comment 2

7 years ago
For me, browser NOT crash. However, I have different Flash version.
AMD system, not Intel.

Mozilla/5.0 (Windows NT 6.1; rv:2.0b11pre) Gecko/20110202 Firefox/4.0b11pre ID:20110202030356

Grafică (Graphics)
      
Descrierea adaptorului NVIDIA GeForce 8600 GT 
ID furnizor 10de
ID dispozitiv 0402
RAM pentru adaptor 512
Drivere pentru adaptor  nvd3dum nvwgf2um,nvwgf2um
Versiune driver  8.17.12.6099
Dată driver  10-16-2010
Direct2D activat true
DirectWrite activat true (6.1.7600.20830, font cache n/a)
Motor de afișare WebGL  Google Inc. -- ANGLE -- OpenGL ES 2.0 (ANGLE 0.0.0.541)
Accelerare GPU Windows  1/1 Direct3D 10

FLASH

Shockwave Flash

    Fișier: NPSWF32.dll
    Versiune: 10.2.161.23
    Shockwave Flash 10.2 d161

Tip MIME 	Descriere 	Sufixe
application/x-shockwave-flash 	Adobe Flash movie 	swf
application/futuresplash 	FutureSplash movie 	spl

Shockwave for Director

    Fișier: np32dsw.dll
    Versiune: 11.5.9.615
    Adobe Shockwave for Director Netscape plug-in, version 11.5.9.615

Tip MIME 	Descriere 	Sufixe
application/x-director 	Shockwave Movie 	dir,dxr,dcr

about:buildconfig
Source

Built from http://hg.mozilla.org/mozilla-central/rev/1c2d53a2dcfb
Build platform
target
i686-pc-mingw32
Build tools
Compiler 	Version 	Compiler flags
d;D:\mozilla-build\msys\mozilla-build\python25\python2.5.exe -O e;D:\mozilla-build\msys\builds\moz2_slave\cen-w32-ntly\build\build\cl.py cl 	14.00.50727.762 	-TC -nologo -W3 -Gy -Fdgenerated.pdb -DNDEBUG -DTRIMMED -Zi -Zi -UDEBUG -DNDEBUG -GL -wd4624 -wd4952 -O1
d;D:\mozilla-build\msys\mozilla-build\python25\python2.5.exe -O e;D:\mozilla-build\msys\builds\moz2_slave\cen-w32-ntly\build\build\cl.py cl 	14.00.50727.762 	-GR- -TP -nologo -Zc:wchar_t- -W3 -Gy -Fdgenerated.pdb -wd4800 -DNDEBUG -DTRIMMED -Zi -Zi -UDEBUG -DNDEBUG -GL -wd4624 -wd4952 -O1
Configure arguments

--enable-application=browser --enable-update-channel=nightly --enable-update-packaging --enable-jemalloc --enable-tests
(Reporter)

Comment 3

7 years ago
(In reply to comment #1)
> Does this same crash happen with Flash 10.1? This may be the same as bug
> 630697.

No it does not crash with 10.1, only the 10.2 RCs .. This was a recent regression here though, I have used fullscreen with 10.2 before.

Comment 4

7 years ago
We probably need some Adobe devs to look at this, then.
I don't crash following the STR, but I do get a black screen when I go into full screen using the video in Comment 0 (using the same flash version). Other videos I tried play fine in FS mode.

I am running Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b11) Gecko/20100101 Firefox/4.0b11 and the machine has an Intel Graphics card.
Whiteboard: [4b11]

Comment 6

7 years ago
Works fine for me, without crash or black screen in full screen mode.

Mozilla/5.0 (Windows NT 6.1; rv:2.0b12pre) Gecko/20110203 Firefox/4.0b12pre
My system is netbook with Intel VGA.

Comment 7

7 years ago
yes and using the same flash version: 10.2.152.14

Updated

7 years ago
QA Contact: plugins → adobe-flash

Updated

7 years ago
blocking2.0: ? → -
(Reporter)

Comment 8

7 years ago
(In reply to comment #6)
> Works fine for me, without crash or black screen in full screen mode.
> 
> Mozilla/5.0 (Windows NT 6.1; rv:2.0b12pre) Gecko/20110203 Firefox/4.0b12pre
> My system is netbook with Intel VGA.

It doesn't happen with every single Youtube video so try it again with original STR link. Also the problem happens with the latest 10.2 RC2 that was released last week, test with that version.


Seems to happen with H/W off so I don't see how the graphics chip would change anything, maybe it's only a crash for Intel CPUs?  (unlikely)

Comment 9

7 years ago
http://www.youtube.com/watch?v=qi5nTb-NRFU -> full screen -> no crash
Flash version: 10.2.152.21 (latest RC2)
Intel Atom Netbook with Intel VGA.
D2D/D3D/DW disabled.

Comment 10

7 years ago
Cannot reproduce.

Flash: 10,2,152,21
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b11pre) Gecko/20110202 Firefox/4.0b11pre

Graphics  

Adapter Description Intel(R) HD Graphics

Vendor ID8086Device ID0046Adapter RAMUnknownAdapter Driversigdumd64 igd10umd64 igdumdx32 igd10umd32

Driver Version8.15.10.2266

Driver Date12-16-2010

Direct2D Enabledtrue

DirectWrite Enabledtrue (6.1.7600.16699, font cache n/a)

WebGL Renderer(WebGL unavailable)

GPU Accelerated Windows1/1 Direct3D 10
Scott: Are you running with any extensions in your profile? Just trying to rule out all possibilities.
I was able to reproduce this in the QA lab, but with a slightly different set of STR.

1. Load http://www.youtube.com/watch?v=7rE0-ek6MZA&feature=topvideos and start playing the video.
2. Select the "Shrink" button next to the full screen button
3. Plugin crashes, but the browser does not become unresponsive.

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b11) Gecko/20100101 Firefox/4.0b11
Using Flash Version: 10.2.152.14
Status: UNCONFIRMED → NEW
Ever confirmed: true
Step 2 should actually be the "Expand" button. http://crash-stats.mozilla.com/report/index/bp-17a24524-da69-45a8-a0b8-5ce172110204 is my crash report.
blocking2.0: - → ?
(Reporter)

Comment 14

7 years ago
(In reply to comment #13)
> Step 2 should actually be the "Expand" button.
> http://crash-stats.mozilla.com/report/index/bp-17a24524-da69-45a8-a0b8-5ce172110204
> is my crash report.

For me both the fullscreen and expand both do it but the crash with expand didn't cause the address bar to be unresponsive.


This is strange with all the different people that dont crash or crash with different steps.. Any reason for these differences?
Keywords: reproducible
Using a different machine and a different version of flash, I cannot reproduce the bug using  Mozilla/5.0 (Windows NT 6.1; rv:2.0b12pre) Gecko/20110204 Firefox/4.0b12pre.

Same videos, but Flash Version: 10.1.102.64
(Reporter)

Comment 16

7 years ago
May have been fixed by Bug 630697  which landed.
(Assignee)

Comment 17

7 years ago
(In reply to comment #16)
> May have been fixed by Bug 630697  which landed.

Can someone confirm this on a machine we know reproduces this?

Comment 18

7 years ago
Flash plugin or Browser window does not crash on the links provided (Comments: #0; #12)

build: Mozilla/5.0 (Windows NT 6.1; rv:2.0b12pre) Gecko/20110206 Firefox/4.0b12pre

OS: Windows 7

Flash v.: 10.2 r152
Using Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b12pre) Gecko/20110207 Firefox/4.0b12pre I can still reproduce the issue using the STR in Comment 12. I am using a clean profile with the same version of flash. I tried a few other videos, and while not all crash, most do. http://www.youtube.com/watch?v=icZRROply_4&feature=pyv&ad=9538662455&kw=battle%20la%20trailers is another example of one that crashes very easily.

Here are the graphics specs from this machine:

Graphics

        Adapter Description
        NVIDIA Quadro NVS 295

        Vendor ID
        10de

        Device ID
        06fd

        Adapter RAM
        256

        Adapter Drivers
        nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um

        Driver Version
        8.15.11.9038

        Driver Date
        7-14-2009

        Direct2D Enabled
        Blocked on your graphics driver. Try updating your graphics driver to version 257.21 or newer.

        DirectWrite Enabled
        false (6.1.7600.20830, font cache n/a)

        WebGL Renderer
        (WebGL unavailable)

        GPU Accelerated Windows
        0/1
(Reporter)

Comment 20

7 years ago
It still does on my laptop with b11 and final nightly. Flash 10.2 RC2 (10.1 does not crash)..

Laptop (plugin crashes): 
Core 2 Duo p8600
4GB ram
Nvidia G102M, latest driver
Win7 ult

funny thing is I put beta 11 and Flash 10.2 RC2 on my fathers computer with a fresh profile as well, same extensions and his does not crash with any combination of expand/fullscreen on any youtube video at any resolution, I tried everything to reproduce but couldn't.

Father Computer (doesn't crash):
Athlon 5000+ @ 3Ghz
4GB
ATI HD4650 - 11.1 driver
Win7 ult

I'm not sure if its related to the CPU/GPU or screen resolution or something else.

Comment 21

7 years ago
Yay, I hit it with different signature, do not know if is same issue.

Alternative method to reproduce:
1. Open http://www.youtube.com/watch?v=7rE0-ek6MZA&feature=topvideos with 360p.
2. Start playing the video.
3. Now hit very fast Expand, Shrink and Full screen until it crash.


Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b12pre) Gecko/20110207 Firefox/4.0b12pre
Flash Version: 10.2.152.21
The config is same as posted on comment 10

[@ hang | NtUserWaitMessage | NtUserWaitMessage | base::MessagePumpForUI::WaitForWork() ]
bp-9de65071-51db-4bfc-ae65-7a99e2110208

Comment 22

7 years ago
That is a hang; different, and not this bug.

Updated

7 years ago
Whiteboard: [4b11] → [4b11] Flash 10.2 only

Comment 23

7 years ago
Blocking on figuring out what's going on.
blocking2.0: ? → final+
Whiteboard: [4b11] Flash 10.2 only → [4b11] Flash 10.2 only [hardblocker]

Comment 24

7 years ago
Could this now be fixed with Flash 10.2.152.26 (which got released today)?

Comment 25

7 years ago
Could be, although I have other bug reports that are near-dups of this one with 10.2 final, so I doubt it. It is likely to have a different signature, because the symbols aren't all synced yet.
(Reporter)

Comment 26

7 years ago
(In reply to comment #24)
> Could this now be fixed with Flash 10.2.152.26 (which got released today)?

It's not.
Like all the other hard blockers, let's make sure to assign an owner immediately so we all know who's doing what.  We're in the endgame of Firefox 4 (less than 50 hard blockers remaining), and it's really important to stay on top of each and every issue that will keep us from releasing.
(Assignee)

Comment 28

7 years ago
We just fixed a bug that caused a full screen crash on youtube. The original patch that caused it landed in the 2/5 nightly. (This was after we tagged for beta 11, so it wasn't in that release.) It should be fixed in tomorrow's nightly. So we are getting mixed reports here. This was originally reported in beta 11, so there's still the open question of whether or not 10.2 fixed that particular problem.
(Assignee)

Updated

7 years ago
Assignee: nobody → jmathies

Comment 29

7 years ago
So is this really a dup of bug 632790?
(Assignee)

Comment 30

7 years ago
(In reply to comment #29)
> So is this really a dup of bug 632790?

No because it was reported before the patch that caused that bug landed.
(Assignee)

Comment 31

7 years ago
This doesn't need to block anymore, 2 crashes over the last three days. I think this just got mixed up in the full screen youtube crash, which was another issue.
blocking2.0: final+ → ---
(Assignee)

Updated

7 years ago
Whiteboard: [4b11] Flash 10.2 only [hardblocker] → [4b11] Flash 10.2 only

Comment 32

7 years ago
reproducable here using ff4.0b11 and flash 10.2. going to fullscreen mode in various video platforms (not only youtube) leads to a black screen while being able to listen to the sound.

afterwards plugincontainer.exe seems to be crashing - it keeps getting bigger and bigger until the computer stops to work properly. just right before it had about 3,5gb ram reserved and i even had a hard time to get it killed via taskmanager.

downgrading to flash 10.1 resolves the problem.

Comment 33

7 years ago
sorry, info on my system: win7 home premium x64. i5-460. intel hd graphics and geforce gt 435m using nvidia optimus.

Comment 34

7 years ago
Is it still an issue with Flash 10.2.152.32 released today?

Comment 35

7 years ago
Marcia, I know you have installed the new version. Can you test this out?
I wasn't able to reproduce the full screen crash, but rather the shrink/expand crash. But since I am have been running with the new version I have not seen any crashes related to using full screen in youtube as well as any other video sites (vimeo, hulu, etc). Perhaps mozillabugs can help us confirm if it is an issue with the new flash version.
(Reporter)

Comment 37

7 years ago
Back, for me this was resolved by updating to 10.2.152.32 , if this fixed it for others I will set this to resolved.

Comment 38

7 years ago
with 10.2.152.32 plugincontainer doesn't seem to crash for me any more but video playback becomes really buggy - in fullscreen youtube won't show any control buttons or even the progress bar. moreover, even not being in fullscreen mode sometimes the controls aren't reacting the way they should (just a black line instead of control buttons; menus don't show up but one can click the options nevertheless blindly). moving to fullscreen takes about a second more then before (where fullscreen starts more or less instantly).

i'm going back to 10.1 definitely. :(

Updated

7 years ago
Component: Plug-ins → Flash (Adobe)
Product: Core → Plugins
Whiteboard: [4b11] Flash 10.2 only → [4b11] [Flash 10.2 only][fixed by Flash 10.2.152.32]
Version: unspecified → 10.2

Comment 39

7 years ago
Has anyone tried it with the 10.3.180.42 beta plugin that was released a day or so ago?

Comment 40

7 years ago
Flash 10.2.153.1 is also out now.
Crash Signature: [@ NPSWF32.dll@0x16f07a ]

Comment 41

6 years ago
With Flash debug symbols, if these crashes still exist, they will be tracked in another bug.
I close it as invalid.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID

Comment 42

2 years ago
Version and milestone values are being reset to defaults as part of product refactoring.
Version: 10.2 → unspecified
You need to log in before you can comment on or make changes to this bug.