Last Comment Bug 631300 - Firefox Sync should synchronize "do not track" pref
: Firefox Sync should synchronize "do not track" pref
Status: VERIFIED FIXED
:
Product: Cloud Services
Classification: Client Software
Component: General (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Daniel Holbert [:dholbert]
:
Mentors:
Depends on: DNT
Blocks: 631639
  Show dependency treegraph
 
Reported: 2011-02-03 11:02 PST by Daniel Holbert [:dholbert]
Modified: 2011-03-02 12:30 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
fix (1.60 KB, patch)
2011-02-03 11:15 PST, Daniel Holbert [:dholbert]
philipp: review+
jst: approval2.0+
Details | Diff | Review

Description Daniel Holbert [:dholbert] 2011-02-03 11:02:58 PST
Just noticed that I'd enabled "do not track" in my Firefox profile on one machine, but that change didn't propagate to the rest of my Sync'ed machines.

This seems like the type of pref that makes a lot of sense to synchronize via sync, since a user who proactively takes the step to request not being tracked will presumably not want to be tracked on *any* of their machines.

(Sid: I assume you agree, but correct me if I'm off base here.)

Can we add this to the list of sync'd prefs?  AIUI, the pref to sync here would be:
  privacy.donottrackheader.enabled
so I think this just involves creating a bool pref named 
  services.sync.prefs.sync.privacy.donottrackheader.enabled
(right?)
Comment 1 Sid Stamm [:geekboy or :sstamm] 2011-02-03 11:05:27 PST
> (Sid: I assume you agree, but correct me if I'm off base here.)

Yes, sync it.
Comment 2 Philipp von Weitershausen [:philikon] 2011-02-03 11:08:22 PST
(In reply to comment #0)
> Can we add this to the list of sync'd prefs?  AIUI, the pref to sync here would
> be:
>   privacy.donottrackheader.enabled
> so I think this just involves creating a bool pref named 
>   services.sync.prefs.sync.privacy.donottrackheader.enabled
> (right?)

Correct. The services.sync.prefs.sync.* pref would also have to be set to true. It should live in browser/app/profile/firefox.js.
Comment 3 Daniel Holbert [:dholbert] 2011-02-03 11:15:31 PST
Created attachment 509498 [details] [diff] [review]
fix

fix as described. I expect it should work -- haven't tested yet, but I'm about to.
Comment 4 Daniel Holbert [:dholbert] 2011-02-03 11:47:36 PST
Comment on attachment 509498 [details] [diff] [review]
fix

Confirmed that this works in a build w/ this patch.

(successfully synchronized the enabled donottrack pref from profile A to profile B; then I disabled the pref in profile B and resync'd, and confirmed that the pref became disabled in profile A on its next sync.)

Requesting approval to land.
Comment 5 Daniel Holbert [:dholbert] 2011-02-04 13:21:21 PST
http://hg.mozilla.org/mozilla-central/rev/313e35cc080e
Comment 6 Tracy Walker [:tracy] 2011-03-02 12:30:47 PST
verified in beta12 against stage-auth

Note You need to log in before you can comment on or make changes to this bug.