Closed Bug 631539 Opened 9 years ago Closed 9 years ago

"Tagging started" and "All signed builds available" emails should be sent to release-drivers mailing list

Categories

(Release Engineering :: General, defect, P2)

x86
Linux
defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: rail, Assigned: rail)

References

Details

Attachments

(2 files, 2 obsolete files)

For both cases we use ChangeNotifier.
Attachment #509768 - Flags: review?(catlee)
Duplicate of this bug: 628287
Attachment #509768 - Flags: review?(catlee) → review+
I didn't see a "tagging started" email after I triggered 3.6.14 build2.

http://hg.mozilla.org/build/buildbotcustom/rev/09e7dbe6c7b1
(In reply to comment #3)
> I didn't see a "tagging started" email after I triggered 3.6.14 build2.

Hmmm, it worked fine in staging. Maybe ChangeNotifier isn't reconfig safe? Let's see how it will work next time after a downtime and a full master restart.
Attached patch Separate pass/all recipients (obsolete) — Splinter Review
Looks like (and iirc) we should send emails to the Mailman list as a separate message.
Attachment #513759 - Flags: review?(catlee)
Comment on attachment 513759 [details] [diff] [review]
Separate pass/all recipients

Do we know why we need to send a separate message to mailman?
Attachment #513759 - Flags: review?(catlee) → review+
(In reply to comment #6)
> Comment on attachment 513759 [details] [diff] [review]
> Separate pass/all recipients
> 
> Do we know why we need to send a separate message to mailman?

A comment in the patch to explain this would be good too.
Depends on: 635527
Attached patch Separate pass/all recipients (obsolete) — Splinter Review
* Added comments
* used for loop to avoid boilerplate
* tested in staging + test mailman list
Attachment #513759 - Attachment is obsolete: true
Attachment #513786 - Flags: review?(catlee)
Comment on attachment 513786 [details] [diff] [review]
Separate pass/all recipients

I think we should loop over all entries of AllRecipients + PassRecipients, since they could contain more than one item each.
Attachment #513786 - Flags: review?(catlee) → review-
(In reply to comment #9)
> I think we should loop over all entries of AllRecipients + PassRecipients,
> since they could contain more than one item each.

Sure. Also note, that extraRecipients have to be a tuple or list.
Attachment #513786 - Attachment is obsolete: true
Attachment #513800 - Flags: review?(catlee)
Attachment #513800 - Flags: review?(catlee) → review+
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.