Expose lsb-release information

RESOLVED DUPLICATE of bug 602209

Status

--
enhancement
RESOLVED DUPLICATE of bug 602209
8 years ago
7 years ago

People

(Reporter: a9016009, Unassigned)

Tracking

Trunk
Other
Other

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Maemo Browser
Build Identifier: 

https://bugzilla.mozilla.org/show_bug.cgi?id=624323 was forwarded to GNOME Bugzilla.
OS and OS Version are collected by Socorro, but in case it's Linux having distribution data would be even better for reproducing.
I don't know how hard this is to implement, but GNOME's bug-buddy tool for example extracts this information from files in /etc. See
http://git.gnome.org/browse/bug-buddy/tree/src/distribution.c line 79 for the list.

Reproducible: Always
We already collect this, it's in the minidumps. We just have to expose it:
http://code.google.com/p/google-breakpad/source/browse/trunk/src/client/linux/minidump_writer/minidump_writer.cc#473

Updated

8 years ago
Summary: In case of Linux OS, also collect the distribution name → Expose lsb-release information
Also apparently I filed this a while ago.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
No longer depends on: 573100
Resolution: --- → DUPLICATE
Duplicate of bug: 602209
(Assignee)

Updated

7 years ago
Component: Socorro → General
Product: Webtools → Socorro
You need to log in before you can comment on or make changes to this bug.