Run Valgrind builds on tryserver

RESOLVED DUPLICATE of bug 801955

Status

Release Engineering
General
P3
normal
RESOLVED DUPLICATE of bug 801955
7 years ago
4 years ago

People

(Reporter: philor, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [tryserver][linux])

(Reporter)

Description

7 years ago
To turn the Valgrind builds into something we can use to force someone to back their broken crap out of our nice tree, we need to have them running on the tryserver.

I'm on the fence about whether it should be in trychooser, but I think it's probably more reasonable not to put it there, to just treat it as yet another flavor of Linux build and do it whenever linux or linux64 is being built.

Comment 1

7 years ago
In the case we proceed with this can we avoid linux64 until we have more machines?
I'll try to look into this in the next couple weeks, at least for linux.
Assignee: nobody → lsblakk
Priority: -- → P3
Whiteboard: [tryserver][linux]
(Reporter)

Updated

6 years ago
Blocks: 639407
(Reporter)

Updated

6 years ago
Blocks: 639408
(Reporter)

Updated

6 years ago
Blocks: 639410
This is not something I have time for in this coming quarter. If possible, we might be able to get one of our summer interns to tackle it.
Assignee: lsblakk → nobody

Updated

6 years ago
Blocks: 696303
Duplicate of this bug: 592262

Updated

6 years ago
Blocks: 572808
(Assignee)

Updated

4 years ago
Product: mozilla.org → Release Engineering
What's involved with getting Valgrind runs onto the try server?  I'm working on getting the valgrind runs on tbpl green, and not being able to experiment via try is a real pain.  For example, I'm currently working on bug 940069, in which I need to work out if the CC is running during shutdown.  If Valgrind was available on try I could easily push a patch with some debugging print statements in it.  But because it's not I'm limited to things that are reasonable to land on mozilla-central.
This bug is subsumed by bug 801955.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 801955
You need to log in before you can comment on or make changes to this bug.