Open Bug 632272 Opened 11 years ago Updated 9 years ago

Right-click on bookmarks in folders not possible anymore on Mac

Categories

(SeaMonkey :: Bookmarks & History, defect)

x86
macOS
defect
Not set
normal

Tracking

(Not tracked)

People

(Reporter: adriank, Unassigned)

References

Details

(Keywords: regression, Whiteboard: [2012 Fall Equinox])

*Probably* since the places-bookmarks landing, it is not possible to right-click on bookmarks in *folders* on the personal-toolbar/bookmarks-bar. In Sm 2.0 and still in Sm 2.1b3pre nightlies on Windows, a right-click on such a bookmark opens the context-menu. On Mac with Sm 2.1 it's not the case anymore.

Steps to reproduce:
1) Create a folder on the personal toolbar
2) Place a bookmark in that folder
3) Open the folder and right-click on that bookmark

Current result:
-nothing happens

Expected result:
-context menu opens
Can you still reproduce this in current SeaMonkey versions?
Whiteboard: [2012 Fall Equinox][CLOSEME 2012-11-01 INCO]
Resolved per whiteboard
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → INCOMPLETE
Whiteboard: [2012 Fall Equinox][CLOSEME 2012-11-01 INCO] → [2012 Fall Equinox]
(In reply to Phoenix from comment #1)
> Can you still reproduce this in current SeaMonkey versions?

Yes, I still can reproduce it in 2.14b3-candidate (build1)
Status: RESOLVED → REOPENED
Resolution: INCOMPLETE → ---
Is this reproducible in Safe Mode?
Can you also check, in what exactly build problem appeared? 2.1b builds archive for original report date is here - http://ftp.mozilla.org/pub/mozilla.org/seamonkey/nightly/2011/02/
Status: REOPENED → NEW
If it disappeared with the places landing, it might be that places handles this correct. It's not a standard Mac behaviour.
Mozilla/5.0 (X11; Linux x86_64; rv:19.0) Gecko/19.0 Firefox/19.0 SeaMonkey/2.16a1 ID:20121103003004 c-c:c42bb5c1cfd0 m-c:2718739a1c83

The bug (if it's a bug) seems to be Mac-only: I can't reproduce it on this Linux x86_64 trunk build (right-clicking "Most Visited" on the Bookmarks toolbar drops a context menu: Open all in tabs | New Bookmark… New Folder… New Separator… | Cut Copy (Paste) | Delete | Properties).

(In reply to Stefan [:stefanh] from comment #5)
> If it disappeared with the places landing, it might be that places handles
> this correct. It's not a standard Mac behaviour.

Opening a context menu by right-clicking not a standard Mac behaviour? Well, well, well, it seems I still have to learn a lot about Mac standards.
(In reply to Stefan [:stefanh] from comment #5)
> If it disappeared with the places landing, it might be that places handles
> this correct. 

Ok, it does not work in Firefox for Mac (16.0.2) either... But I still think it is a regression...

> It's not a standard Mac behaviour.

Ok, right-click in folders on Mac Safari as well as Opera does not work. It seems like it does only work with Google Chrome.

(In reply to Tony Mechelynck [:tonymec] from comment #6)
> The bug (if it's a bug) seems to be Mac-only: I can't reproduce it on this
> Linux x86_64 trunk build (right-clicking "Most Visited" on the Bookmarks
> toolbar drops a context menu: Open all in tabs | New Bookmark… New Folder…
> New Separator… | Cut Copy (Paste) | Delete | Properties).

Yes, Mac-only.
See Also: → 300710
(In reply to Tony Mechelynck [:tonymec] from comment #6)
> Opening a context menu by right-clicking not a standard Mac behaviour? Well,
> well, well, it seems I still have to learn a lot about Mac standards.

Just to be clear: this bug is about not being able to open a context menu by right-clicking a menuitem (in an already opened menu) and that is not mac standard.
You need to log in before you can comment on or make changes to this bug.