Error after install Fennec through Android SDK

RESOLVED DUPLICATE of bug 632908

Status

Fennec Graveyard
General
RESOLVED DUPLICATE of bug 632908
7 years ago
7 years ago

People

(Reporter: Andreea Pod, Unassigned)

Tracking

Trunk
ARM
Android

Details

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
Created attachment 510606 [details]
Error screenshot

Mozilla /5.0 (Android;Linux armv7l;rv:2.0b12pre) Gecko/20110208 Firefox/4.0b12pre Fennec /4.0b5pre
Device: Samsung Galaxy S Captivate
OS: Android 2.1 update 1


Steps to perform:
1. Install the build from latest trunk using Android SDK
2. Open Fennec

Expected results:
The application should start with no problem

Actual results:
An error occurred (see the screenshot).
(Reporter)

Comment 1

7 years ago
Created attachment 510607 [details]
Log

I attached the log too.

Updated

7 years ago
Attachment #510607 - Attachment mime type: application/octet-stream → text/plain

Comment 2

7 years ago
Here's what looks like the important part from the log:

02-08 09:45:10.531 I/GeckoAppJava( 2844): Checking for an update
02-08 09:45:10.536 I/dalvikvm( 2844): Could not find method android.util.Base64.decode, referenced from method org.mozilla.gecko.GeckoAppShell.installWebApplication
02-08 09:45:10.536 W/dalvikvm( 2844): VFY: unable to resolve static method 122: Landroid/util/Base64;.decode (Ljava/lang/String;I)[B
02-08 09:45:10.536 D/dalvikvm( 2844): VFY: replacing opcode 0x71 at 0x007b
02-08 09:45:10.536 D/dalvikvm( 2844): Making a copy of Lorg/mozilla/gecko/GeckoAppShell;.installWebApplication code (312 bytes)
02-08 09:45:10.536 I/dalvikvm( 2844): Could not find method org.mozilla.gecko.GeckoApp.getExternalFilesDir, referenced from method org.mozilla.gecko.GeckoAppShell.loadGeckoLibs
02-08 09:45:10.536 W/dalvikvm( 2844): VFY: unable to resolve virtual method 414: Lorg/mozilla/gecko/GeckoApp;.getExternalFilesDir (Ljava/lang/String;)Ljava/io/File;
02-08 09:45:10.536 D/dalvikvm( 2844): VFY: replacing opcode 0x6e at 0x0054
02-08 09:45:10.536 D/dalvikvm( 2844): Making a copy of Lorg/mozilla/gecko/GeckoAppShell;.loadGeckoLibs code (1245 bytes)
02-08 09:45:10.536 I/dalvikvm( 2844): Could not find method org.mozilla.gecko.GeckoApp.getExternalFilesDir, referenced from method org.mozilla.gecko.GeckoAppShell.loadGeckoLibs
02-08 09:45:10.536 W/dalvikvm( 2844): VFY: unable to resolve virtual method 414: Lorg/mozilla/gecko/GeckoApp;.getExternalFilesDir (Ljava/lang/String;)Ljava/io/File;
02-08 09:45:10.536 D/dalvikvm( 2844): VFY: replacing opcode 0x6e at 0x0103
02-08 09:45:10.941 D/dalvikvm( 2844): Trying to load lib /data/data/org.mozilla.fennec/lib/libmozutils.so 0x47a6bba0
02-08 09:45:10.946 I/GeckoApp( 2844): start
02-08 09:45:10.946 I/GeckoApp( 2844): resume
02-08 09:45:10.956 D/dalvikvm( 2844): Added shared lib /data/data/org.mozilla.fennec/lib/libmozutils.so 0x47a6bba0
02-08 09:45:10.961 D/dalvikvm( 2844): No JNI_OnLoad found in /data/data/org.mozilla.fennec/lib/libmozutils.so 0x47a6bba0
02-08 09:45:11.376 W/dalvikvm( 2844): threadid=19: thread exiting with uncaught exception (group=0x4001dc20)
02-08 09:45:11.376 E/AndroidRuntime( 2844): Uncaught handler: thread Thread-9 exiting due to uncaught exception
02-08 09:45:11.506 E/AndroidRuntime( 2844): java.lang.NoSuchMethodError: org.mozilla.gecko.GeckoApp.getExternalFilesDir
02-08 09:45:11.506 E/AndroidRuntime( 2844): 	at org.mozilla.gecko.GeckoAppShell.loadGeckoLibs(GeckoAppShell.java:207)
02-08 09:45:11.506 E/AndroidRuntime( 2844): 	at org.mozilla.gecko.GeckoApp$3.run(GeckoApp.java:204)
02-08 09:45:11.506 E/AndroidRuntime( 2844): 	at java.lang.Thread.run(Thread.java:1096)

and then later on there are a _LOT_ of org.mozilla.firefox processes that all show thread 9 having an uncaught exception like so:

"Thread-9" prio=5 tid=17 NATIVE
  | group="main" sCount=1 dsCount=0 s=N obj=0x47b99358 self=0x393870
  | sysTid=6663 nice=0 sched=0/0 cgrp=default handle=3781840
  at android.os.BinderProxy.transact(Native Method)
  at android.app.ActivityManagerProxy.handleApplicationError(ActivityManagerNative.java:2358)
  at com.android.internal.os.RuntimeInit.crash(RuntimeInit.java:368)
  at com.android.internal.os.RuntimeInit$UncaughtHandler.uncaughtException(RuntimeInit.java:90)
  at java.lang.ThreadGroup.uncaughtException(ThreadGroup.java:887)
  at java.lang.ThreadGroup.uncaughtException(ThreadGroup.java:884)

but also a bunch of org.mozilla.fennec that show:

"main" prio=5 tid=3 NATIVE
  | group="main" sCount=1 dsCount=0 s=N obj=0x4001dd00 self=0xbd90
  | sysTid=2432 nice=0 sched=0/0 cgrp=bg_non_interactive handle=-1343993184
  at android.os.BinderProxy.transact(Native Method)
  at android.app.ActivityManagerProxy.handleApplicationError(ActivityManagerNative.java:2358)
  at com.android.internal.os.RuntimeInit.crash(RuntimeInit.java:368)
  at com.android.internal.os.RuntimeInit$UncaughtHandler.uncaughtException(RuntimeInit.java:90)
  at java.lang.ThreadGroup.uncaughtException(ThreadGroup.java:887)
  at java.lang.ThreadGroup.uncaughtException(ThreadGroup.java:884)
  at dalvik.system.NativeStart.main(Native Method)
(Reporter)

Comment 3

7 years ago
This is happening for the today's build too: 

Mozilla /5.0 (Android;Linux armv7l;rv:2.0b12pre) Gecko/20110209 Firefox/4.0b12pre Fennec /4.0b5pre
Device: Samsung Galaxy S Captivate
OS: Android 2.1 update 1

If you need the log I will attach it.

Comment 4

7 years ago
This is most likely a dup of bug 632908.  Andreea, could try the nightly build for Feb 10 when it comes out tomorrow and see if the issue is fixed?
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 632908
You need to log in before you can comment on or make changes to this bug.