When hitting the 'reply' button on the messages new header (in window mode, html format UN selected from account options ), it opens the reply window BEHIND instead of bringing it to focus.

RESOLVED DUPLICATE of bug 578017

Status

RESOLVED DUPLICATE of bug 578017
8 years ago
6 years ago

People

(Reporter: carlamc, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.1.16) Gecko/20101130 Firefox/3.5.16
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.13) Gecko/20101207 Thunderbird/3.1.7

When hitting the 'reply' button on the messages new header (in window mode, html format UN selected from account options ), it opens the reply window BEHIND instead of bringing it to focus like it used to (a week or so ago).  

It would also be best to even have the option for the original message to automatically close upon hitting 'reply'.
Right now it's terribly cumbersome with the multiple versions of the message staying open, and having to find the reply window to type in after hitting reply, rather than being able to just start typeing.

Reproducible: Always

Steps to Reproduce:
1. Open a message (in new window mode, with account-settings composition in text, NOT html mode)
2. Hit 'reply' from the button in the header that message (new header stuff)
3. see the problem

Comment 1

8 years ago
This happens for me as on Windows Server 2008 R2 ("Windows 7") as well.  I'm running Thunderbird 3.1.4.

On a large monitor, the new composition window is often not visibly eclipsed by the message-viewing window, but nevertheless, it does not receive focus.

The behavior is frustrating.  As you begin typing your reply, you realize you've just sent a bunch of keyboard-shortcut commands to the message-viewing window that still has focus.

By way of comparison, clicking "reply" on the main Thunderbird window does correctly shift focus to the new composition window.
Does this also happens in -safe-mode (see http://support.mozillamessaging.com/en-US/kb/Safe+Mode) ?

Any errors in Tools-> Error console ?

Comment 3

8 years ago
Still happening on OS X version 3.1.9!  Note this happens for me only after the first time the Reply button is hit (first time works properly).  Also note the preview pane is closed.

Comment 4

7 years ago
This "wrong" behavior is only when you use the "stock" Reply button on the right side of the message window (next to Forward, Junk, and Delete). If you put a Reply button on the next Toolbar up (the one with Get Mail, Write, Address Book, etc...) it works as it should.

Also works correctly if using the Reply command from the Message menu, (or its keyboard shortcut, Ctrl + R).

Easily repeatable here with TB 6.0.2 on fully patched Win XP.

VERY frustrating for new users.  Wish this would get some traction.
Thanks for all the hard work.
Jeffrey Bruton

Comment 5

7 years ago
I can verify that this workaround does work.  I'd really rather not use the Mail Toolbar, though, as I never use it for anything else.

Thanks for the info!

Comment 6

7 years ago
I have the same problem with TB 13.0 running on Windows XP. Hitting CTRL+R and CTRL+SHIFT+R is a workaround, now that I've gotten used to doing it. But it's still a pain in the neck.

Comment 7

6 years ago
Hi there,

Similar issues here on win 7 with 13.0.1. I tried in safe mode and still happened. Configured a new account and configured to my tastes and the last thing I changed was html to plain text compostion and it started happening again. Recently upgraded from XP, and it was ok then, but I just downloaded the latest version for the new W7 install and now I have problems. I`ve been a user since around v0.7

https://getsatisfaction.com/mozilla_messaging/topics/reply_mail_always_opens_up_behind_originating_mail?utm_content=reply_link&utm_medium=email&utm_source=reply_notification#reply_9267020

Comment 8

6 years ago
Can replicate this in 10.0.5esr and 16.0.1 (release). See Bug 578017

Comment 9

6 years ago
This bug's status should be set to confirmed, and it's probably a duplicate of bug 578017 as Richard found. I can confirm it with TB 16.0.1 under Windows 7.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 578017
You need to log in before you can comment on or make changes to this bug.