Update public suffix list for changes in .eg and .uk

RESOLVED FIXED

Status

()

Core
Networking: Domain Lists
RESOLVED FIXED
7 years ago
6 years ago

People

(Reporter: Peter Kasting, Assigned: gerv)

Tracking

({verified1.9.2})

unspecified
x86
Windows Vista
verified1.9.2
Points:
---

Firefox Tracking Flags

(status2.0 .x-fixed, status1.9.2 .18-fixed, status1.9.1 .20-fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Recently two Chromium bugs ( http://crbug.com/71638 and http://crbug.com/72360 ) have pointed out websites that run afoul of the current public suffix rules: police.uk and enc.eg, respectively.

Looks like we need to take a look at these registrars' current policies and update.
(Assignee)

Comment 1

6 years ago
Created attachment 519395 [details] [diff] [review]
Patch v.1

I checked a few sources and can't find any more omissions from the .uk list apart from police.uk. The .eg stuff is straight from Wikipedia.

Gerv
Assignee: nobody → gerv
Status: NEW → ASSIGNED
Attachment #519395 - Flags: review?(pkasting)
(Reporter)

Comment 2

6 years ago
Comment on attachment 519395 [details] [diff] [review]
Patch v.1

I'm sorry, this slipped through my radar somehow!
Attachment #519395 - Flags: review?(pkasting) → review+
(Assignee)

Comment 3

6 years ago
http://hg.mozilla.org/mozilla-central/rev/5b7a081209bd

Gerv
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Backed out due to xpcshell failure on all platforms.
See: http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1305900628.1305901763.25019.gz&fulltext=1
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 5

6 years ago
The cause of the failure was this bug; the new TLDs for .pk contain what Firefox things is a non-permitted codepoint (200E). And the Verisign IDN checker agrees:
http://mct.verisign-grs.com/conversiontool/convertServlet?input=%E2%80%8E%E2%80%8E%D9%BE%D8%A7%D9%83%D8%B3%D8%AA%D8%A7%D9%86&type=UTF8

I will check this all back in without that change, and we can open another bug to fix the problem.

Gerv
(Assignee)

Comment 6

6 years ago
Sorry, comment 5 was in the wrong bug (see bug 658084).

Gerv
(Assignee)

Comment 7

6 years ago
Attempt 2: http://hg.mozilla.org/mozilla-central/rev/a2affb2e653f

Gerv
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
(Assignee)

Updated

6 years ago
Attachment #519395 - Flags: approval2.0?
Attachment #519395 - Flags: approval1.9.2.18?
Attachment #519395 - Flags: approval1.9.1.20?
Comment on attachment 519395 [details] [diff] [review]
Patch v.1

Approved for 1.9.2.18 and 1.9.1.20, a=dveditz for release-drivers
Approved for the mozilla2.0 repository, a=dveditz for release-drivers

Mozilla only has plans to build 1.9.2 releases, but you're approved to land on the other two repos if you'd like.
Attachment #519395 - Flags: approval2.0?
Attachment #519395 - Flags: approval2.0+
Attachment #519395 - Flags: approval1.9.2.18?
Attachment #519395 - Flags: approval1.9.2.18+
Attachment #519395 - Flags: approval1.9.1.20?
Attachment #519395 - Flags: approval1.9.1.20+
(Assignee)

Comment 9

6 years ago
http://hg.mozilla.org/releases/mozilla-2.0/rev/6b705dc0c049
http://hg.mozilla.org/releases/mozilla-1.9.2/rev/36bf853240c7
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/0c002f56fbae

Gerv
status1.9.1: --- → .20-fixed
status1.9.2: --- → .18-fixed
status2.0: --- → .x-fixed
Verified for 1.9.2.18 in source.
Keywords: verified1.9.2
You need to log in before you can comment on or make changes to this bug.