Thunderbird uses IMAP server name as e-mail address domain when password is not provided during initial account configuration

RESOLVED DUPLICATE of bug 634078

Status

defect
--
minor
RESOLVED DUPLICATE of bug 634078
9 years ago
5 years ago

People

(Reporter: cheras, Unassigned)

Tracking

(Depends on 1 bug)

x86_64
Windows 7
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US) AppleWebKit/534.13 (KHTML, like Gecko) Chrome/9.0.597.84 Safari/534.13
Build Identifier: Thunderbird 3.1.7 / Thunderbird 3.1.2

Thunderbird uses IMAP server name as e-mail address domain when password is not provided during initial account configuration. This is conflicting when mail server name is different from mail address domain name, because Thunderbird asks for the password of an invalid mail address.

This happens in an institution where the IMAP server serves different domain names (identifying different areas of the institution). e.g.: username@domain.es is the mail address and IMAP sever is servername.es

Reproducible: Always

Steps to Reproduce:
1. Create mail account from scratch with mail address username@domain.es, don't provide password.
2. Provide IMAP server manually. The server name (servername.es) is different to domain from mail account.
3. Test config. Works well. Account succesfully created.
4. Fetch mail. Thunderbird asks for password.
Actual Results:  
Thunderbird asks for the password for username@servername.es, not username@domain.es, thus password is invalid.

This problem doesn't exist if password is provided during initial configuration.

Expected Results:  
Thunderbird should ask for the password of the provided mail account (username@domain.es) not for username@servername.es
Reporter

Updated

9 years ago
Version: unspecified → 3.1

Comment 1

9 years ago
this is a related issue when not providing a password (or at least, one that would be fixed if we had the password)
Would be fixed by bug 634078.
Depends on: 634078
(In reply to comment #0)
> Steps to Reproduce:
> 1. Create mail account from scratch with mail address username@domain.es,
> don't provide password.
> 2. Provide IMAP server manually. The server name (servername.es) is different
> to domain from mail account.

At where did you provide servername.es?
While auto-config?
Changed server name at Account Settings/Server Settings after account creation?

> 3. Test config. Works well. Account succesfully created.
> 4. Fetch mail. Thunderbird asks for password.
> Actual Results:  
> Thunderbird asks for the password for username@servername.es, not
> username@domain.es, thus password is invalid.

What string at what panel do you call by "for username@servername.es"?
What server-name is specified at Account Settings/Server Settings?
What user-id is specified at Account Settings/Server Settings?
Do you distinguish user-id & server-name which is needed to login to IMAP server and mail address which is assigned to the user-id on the server-name?  

Next, isn't it?
  server-name = servername.es 
  use-id      = username, instead of username@domain.es
  mail-addr   = username@domain.es
  At password dialog, "<user-id>@<server-name>" is shown,
  intead of "<user-id> AT(or OF) <server-name>".
IIRC, if user-id=a@b.c.d and server=x.y.z, a@b.c.d@x.y.z is shown in some dialogs relevant to IMAP, and it's already known issue.

> This problem doesn't exist if password is provided during initial configuration.

It's merely a result of next, isn't it?
- Correct server-name/user-id could be determined by auto-config of Tb,
  because correct password was provided by you to auto-config of Tb
  and login to server by auto-config of Tb was successuful as valid password.
- Because you provided correct password, Tb's password manager saved correct
  password, and the saved correct password was used by Tb upon next login.
Reporter

Comment 4

9 years ago
(In reply to comment #3)

> At where did you provide servername.es?

servername.es I provided during initial config (in fact steps 1-3 occur in that phase).

> What string at what panel do you call by "for username@servername.es"?

The string at the prompt asking for password while initial mail retrieval.

> What server-name is specified at Account Settings/Server Settings?

servername.es, the incoming emil server I provided during initial config.

> What user-id is specified at Account Settings/Server Settings?

username, the User Name I provided during initial config.

I it seems clearer we may use the following (based on your reply):

   server-name = IMAP server name 
   use-id      = User name
   domain-name = Domain

   Therefore...
   mail-addr   = use-id@domain-name

   At password dialog, "<user-id>@<server-name>" is shown,
   intead of "<use-id>@<domain-name>" (that is, mail-addr).

> IIRC, if user-id=a@b.c.d and server=x.y.z, a@b.c.d@x.y.z is shown in some
> dialogs relevant to IMAP, and it's already known issue.

This last issue is not the case in the issue we are discussing currently. The issue in this bug is a matter of Tb asking for the password of the <mail-addr> we provided, not <user-id>@<server-name>. Tb should work the same, independently of the moment you provide the password (Remember this issue doesn't appear if password is provided during the first prompt of initial config).

Thanks!
(In reply to comment #4)
>    At password dialog, "<user-id>@<server-name>" is shown,
>    intead of "<use-id>@<domain-name>" (that is, mail-addr).

Because password is required to login, and because login is requested to <server-name> using <user-id> instead of mail-addr assinged to the UserId, mail-addr is irrelevant to login to server.
Please see "Manage Identities...". Multiple mail addresses can be associated to an account defined in Tb. Mail address shown at Account Settings panel of an account is mail address defined in identity which is listed at top of "Manage Identities..."(main identity associated to the account).

Problem I refered is next;
  Tb tries to ask you "enter password for login using UserId=<user-id> AT
  <server-name>", and shows it as very confusing "<user-id>@<server-name>"
  in some dialogs.

> (Remember this issue doesn't appear if password is provided during the first prompt of initial config).

If you provide correct password at initial config and request "remember password", attempt to login to server during auto-config is successful, then password manager of Tb saves the correct password because of "remember password" is requested by you.
Does "this issue doesn't appear" in this context mean "password prompt is not displayed then funny <user-id>@<server-name> can not be seen"?
Or "<use-id>@<domain-name>" which you expected is shown at password prompt?
Or other?

Please note next;
  At auto-config, user need to specifiy;
     mail-address (<local-part>@<domain-part>)
     password for login to <sever-name> using <user-id>
  <sever-name> and <user-id> is determined by definition in ISPDB,
  or guessd from mail address,
     UserId=<local-part>, UserId=<local-part>@<domain-part>,
     ServerName=<domain-part> etc.
  or modified string you typed at config panel is used.
Confusing but this doesn't mean "password for mail-address".

Comment 6

6 years ago
This is an ongoing problem where Thunderbird places an @ 'at' between the username and the mail server ... where the mail server is a different domain than the email address domain.

Example: 
Domain Registrar and Hosting provider: NAME.COM
User sets up his own email accounts via cPanel X for his domain names.
NAME.COM tells user in order to use SSL that we must use the following configuration:

Username: 	username@user's domain (John@doe.com)
Password: 	Use the email account’s password.

Incoming Server: 	hs11.name.com
    IMAP: Port 993
    POP3: Port 995

Outgoing Server: 	hs11.name.com
    SMTP: Port 465


PROBLEM: hs11.name.com and user's domain ARE DIFFERENT!
ThunderChicken puts a @ between the two... i.e.; john@doe.com@hs11.name.com

SOLUTION: How do we stop TB from adding the @ or work with this FU arrangement?

==============================
ThunderChicken stats:

  Application Basics

    Name: Thunderbird
    Version: 17.0.5
    User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:17.0) Gecko/20130328 Thunderbird/17.0.5
    Profile Folder: Show in Finder
    Application Build ID: 20130328110546
    Enabled Plugins: about:plugins
    Build Configuration: about:buildconfig
    Crash Reports: about:crashes
    Memory Use: about:memory

  Mail and News Accounts
    account1:
      INCOMING: account1, , (none) Local Folders, plain, passwordCleartext

    account2:
      INCOMING: account2, , (imap) hs11.name.com:993, SSL, passwordCleartext
      OUTGOING: hs11.name.com:465, SSL, passwordCleartext, true


  Extensions
    CompactHeader, 2.0.7, true, {58D4392A-842E-11DE-B51A-C7B855D89593}
    Extra Folder Columns, 1.1.5, true, extra-cols@jminta_gmail.com
    Lightning, 1.9.1, true, {e2fda1a4-762b-4020-b5ad-a41df1933103}
    Test Pilot for Thunderbird, 1.3.9, true, tbtestpilot@labs.mozilla.com
Rob, if username = john@doo.com and hostname = imap.provider.com, then the IMAP URL is imap://john%40doo.com@imap.provider.com/... (whereby %40 = "@" encoded) - that's the standard. Similarly, we should <username>@<servername> in the password, dialog, so logically we would show "Please enter the password for john@doo.com@imap.provider.com". This is exactly what you configured when you put john@doo.com as username.

Either way, even if this was a bug, this would be a different bug.

Comment 8

6 years ago
(In reply to Ben Bucksch (:BenB) from comment #7)
> Rob, if username = john@doo.com and hostname = imap.provider.com, then the
> IMAP URL is imap://john%40doo.com@imap.provider.com/... (whereby %40 = "@"
> encoded) - that's the standard. Similarly, we should <username>@<servername>
> in the password, dialog, so logically we would show "Please enter the
> password for john@doo.com@imap.provider.com". This is exactly what you
> configured when you put john@doo.com as username.
> 
> Either way, even if this was a bug, this would be a different bug.

You are correct. Thank you for the reply. 
I clearly made 2 mistakes... Should have went to bed the 2nd time my head bounced off the monitor :D
OK, thanks.

(In reply to Ben Bucksch (:BenB) from comment #2)
> Would be fixed by bug 634078.
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 634078

Comment 10

5 years ago
I have the same issue and after reading this thread and 634078 thread I still don't know how to fix it.

My e-mail address is john@doo.com
The IMAP server is imap.provider.com

When I try to set up a mail account from scratch and I give my e-mail address john@doo.com + my password, then the account wizard offers the following after its automatic search

Incoming: IMAP, imap.doo.com, STARTTLS 
Outgoing: IMAP, mail.doo.com, STARTTLS 
Username: john

As the provider has no server named as doo.com, I corrected it manually to 
imap.provider.com  and I tried as 

Username:john 
and it
- sent login info
- asked for adding security exception
- was checking password and repeated it many tinmes without getting anywhere

I also tried 

Username:john@doo.com 

and it
- sent login info
- asked for adding security exception
- was checking password
and it came back 'Configuration could not be verified - its username or password wrong?"

When I tried changing an already existing acount that used to function for this e-mail address and server around October 2013, then it tried to connect to john@doo.com@imap.provider.com (as described in comment #7) which is a non-existent e-mail address and/or server.
> I still don't know how to fix it.

Just provide a password when you use the setup wizard.
If you do (and you say you do), then you're not hitting this bug.

> Incoming: IMAP, imap.doo.com, STARTTLS 

When reporting problems with the wizard, please always give the *actual* email domain that you use, not doo.com, because the wizard's has many cases and the behaviour heavily depends on the domain.

Comment 12

5 years ago
(In reply to Ben Bucksch (:BenB) from comment #11)
> > I still don't know how to fix it.
> 
> Just provide a password when you use the setup wizard.
> If you do (and you say you do), then you're not hitting this bug.
> 
> > Incoming: IMAP, imap.doo.com, STARTTLS 
> 
> When reporting problems with the wizard, please always give the *actual*
> email domain that you use, not doo.com, because the wizard's has many cases
> and the behaviour heavily depends on the domain.

Comment 13

5 years ago
(In reply to Ben Bucksch (:BenB) from comment #11)
When it requested I gave my password that I use for the webmail and I'm still hitting this bug, otherwise I wouldn't have search for this thread and asked for help.

my e-mail address finishes with  @index.hu
the server is imap.indamail.hu

The same provider has further addresses, anyone can register e-mail addresses with the following endings:
@index.hu
@indamail.hu
@vipmail.hu
@totalcar.hu
@velvet.hu
@torzsasztal.hu
@csinibaba.hu

Any help is much appreciated.

Comment 14

5 years ago
(In reply to Adam Foldes from comment #12)
When it requested I gave my password that I use for the webmail and I'm still hitting this bug, otherwise I wouldn't have searched for this thread and asked for help.

my e-mail address finishes with  @index.hu
the server is imap.indamail.hu

The same provider has further addresses, anyone can register e-mail addresses with the following endings:
@index.hu
@indamail.hu
@vipmail.hu
@totalcar.hu
@velvet.hu
@torzsasztal.hu
@csinibaba.hu

Any help is much appreciated.
Adam, yes, we always try to use the email address domain as IMAP server domain, if we can't find any better config. We only use it, if the server actually exists, and whether an IMAP server responds. That is by design, not a bug.

In this case, imap.index.hu *does* exist, and does respond as IMAP server. If that doesn't work, that's a bad configuration by the ISP. You are also being asked to confirm the configuration, and you have the option to change it. Please do so.
You need to log in before you can comment on or make changes to this bug.