When previewing personas, tab bar moves into title bar and jitters

RESOLVED FIXED in mozilla2.0b12

Status

()

Core
XUL
RESOLVED FIXED
7 years ago
4 years ago

People

(Reporter: mmm, Assigned: mmm)

Tracking

({regression})

Trunk
mozilla2.0b12
x86
Mac OS X
regression
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(blocking2.0 final+)

Details

(Whiteboard: [hardblocker] [has patch])

Attachments

(2 attachments, 1 obsolete attachment)

Created attachment 511198 [details]
Screen recording of problem.

According to dolske and fryn, this is a regression.
Have not tested platforms other than Mac to see if the problem shows up.
Blocks: 616010
Similarly to bug 616010, the UI does not jitter if already wearing a persona.
Tested out on nightlies, works in 02-04 (847a825087f2) but fails in 02-05 (4574f9e56d49). The corresponding changeset:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=847a825087f2&tochange=4574f9e56d49
Luckily there are still tinderbox builds. Narrowed it down to the change:
http://hg.mozilla.org/mozilla-central/rev/51f36c6a7d38 from bug 627328

Updated

7 years ago
Component: General → XUL
Product: Firefox → Core
QA Contact: general → xptoolkit.widgets
Summary: Tab bar moves into title bar and jitters when trying on a persona → When previewing personas, tab bar moves into title bar and jitters
Assignee: nobody → mars.martian+bugmail

Comment 4

7 years ago
Created attachment 511226 [details]
Mehdi's screen recording of the bug now in webm!
Created attachment 511235 [details] [diff] [review]
Patch v1, switched to using a script runner.

From reading bug 627328, it seemed like a script runner was thought of but never used.

Tested this out and it solves the problem on Mac, going to run try builds to check other platforms.
Attachment #511235 - Flags: review?(bzbarsky)
Should be a hardblocker IMO, the effect is nasty.
Blocks: 627328
blocking2.0: --- → ?
Keywords: regression

Updated

7 years ago
Attachment #511198 - Attachment is obsolete: true

Updated

7 years ago
Attachment #511226 - Attachment description: Free recording of problem. → Mehdi's screen recording of the bug now in webm!
blocking2.0: ? → final+
Whiteboard: [hardblocker]
Comment on attachment 511235 [details] [diff] [review]
Patch v1, switched to using a script runner.

r=me
Attachment #511235 - Flags: review?(bzbarsky) → review+

Updated

7 years ago
Whiteboard: [hardblocker] → [hardblocker] [has patch]
Flags: in-litmus?
Flags: in-litmus? → in-testsuite?
http://hg.mozilla.org/mozilla-central/rev/83a0538956cc
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED

Updated

7 years ago
Target Milestone: --- → mozilla2.0b12
You need to log in before you can comment on or make changes to this bug.