[traceback] KeyError: 'end'

VERIFIED FIXED in 6.0.8

Status

addons.mozilla.org Graveyard
Admin/Editor Tools
P5
normal
VERIFIED FIXED
7 years ago
2 years ago

People

(Reporter: stephend, Assigned: gkoberger)

Tracking

unspecified
6.0.8

Details

(URL)

(Reporter)

Description

7 years ago
I just entered "s" as an end date on https://addons.allizom.org/z/en-US/editors/reviewlog?start=2011-02-01&end=, and got this:

Traceback (most recent call last):

  File "/data/amo_python/www/preview/zamboni/vendor/src/django/django/core/handlers/base.py", line 109, in get_response
    response = callback(request, *callback_args, **callback_kwargs)

  File "/data/amo_python/www/preview/zamboni/apps/amo/decorators.py", line 22, in wrapper
    return func(request, *args, **kw)

  File "/data/amo_python/www/preview/zamboni/apps/editors/views.py", line 31, in wrapper
    return func(request, *args, **kw)

  File "/data/amo_python/www/preview/zamboni/apps/editors/views.py", line 150, in reviewlog
    if form.is_valid():

  File "/data/amo_python/www/preview/zamboni/vendor/src/django/django/forms/forms.py", line 121, in is_valid
    return self.is_bound and not bool(self.errors)

  File "/data/amo_python/www/preview/zamboni/vendor/src/django/django/forms/forms.py", line 112, in _get_errors
    self.full_clean()

  File "/data/amo_python/www/preview/zamboni/vendor/src/django/django/forms/forms.py", line 268, in full_clean
    self._clean_form()

  File "/data/amo_python/www/preview/zamboni/vendor/src/django/django/forms/forms.py", line 296, in _clean_form
    self.cleaned_data = self.clean()

  File "/data/amo_python/www/preview/zamboni/apps/editors/forms.py", line 45, in clean
    if data['end']:

KeyError: 'end'
crashes are lame
Assignee: nobody → gkoberger
Priority: -- → P5
Target Milestone: --- → Q2 2011
Duplicate of this bug: 640269
Target Milestone: Q2 2011 → 6.0.8
(Assignee)

Comment 3

7 years ago
http://github.com/jbalogh/zamboni/commit/d8b92a0
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

7 years ago
Things have moved around but STR from comment 0 still reproduce it:

Traceback (most recent call last):

  File "/data/amo_python/www/preview/zamboni/vendor/src/django/django/core/handlers/base.py", line 111, in get_response
    response = callback(request, *callback_args, **callback_kwargs)

  File "/data/amo_python/www/preview/zamboni/apps/amo/decorators.py", line 22, in wrapper
    return func(request, *args, **kw)

  File "/data/amo_python/www/preview/zamboni/apps/editors/views.py", line 39, in wrapper
    return func(request, *args, **kw)

  File "/data/amo_python/www/preview/zamboni/apps/editors/views.py", line 432, in reviewlog
    if form.is_valid():

  File "/data/amo_python/www/preview/zamboni/vendor/src/django/django/forms/forms.py", line 121, in is_valid
    return self.is_bound and not bool(self.errors)

  File "/data/amo_python/www/preview/zamboni/vendor/src/django/django/forms/forms.py", line 112, in _get_errors
    self.full_clean()

  File "/data/amo_python/www/preview/zamboni/vendor/src/django/django/forms/forms.py", line 268, in full_clean
    self._clean_form()

  File "/data/amo_python/www/preview/zamboni/vendor/src/django/django/forms/forms.py", line 296, in _clean_form
    self.cleaned_data = self.clean()

  File "/data/amo_python/www/preview/zamboni/apps/editors/forms.py", line 59, in clean
    if data['end']:

KeyError: 'end'
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 5

7 years ago
You are testing with old code; Hudson is backed up.

https://github.com/jbalogh/zamboni/commit/d8b92a0#L0L59

The 'editors/forms.py:59' line of code in your traceback is different from the code on github.

For reference, here's Hudson.  It has been stuck since yesterday at 2pm:
https://hudson.mozilla.org/job/amo-master/
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → FIXED
(Reporter)

Comment 6

7 years ago
Verified FIXED: https://addons.allizom.org/z/en-US/editors/reviewlog?start=2011-02-01&end=*fds (and more)

Thanks -- sorry, didn't know preview wasn't updating (again).
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.