Last Comment Bug 633066 - Remove nsICiter and make nsInternetCiter a static class
: Remove nsICiter and make nsInternetCiter a static class
Status: RESOLVED FIXED
[post-2.0]
:
Product: Core
Classification: Components
Component: Editor (show other bugs)
: unspecified
: x86 Windows 7
: -- normal (vote)
: mozilla5
Assigned To: Sebastian Kromp
:
: Makoto Kato [:m_kato]
Mentors:
Depends on:
Blocks: deCOM
  Show dependency treegraph
 
Reported: 2011-02-09 18:34 PST by Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary)
Modified: 2011-03-31 09:38 PDT (History)
2 users (show)
khuey: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
removed nsICiter and made nsInternetCiter static (9.67 KB, patch)
2011-03-30 11:49 PDT, Sebastian Kromp
ehsan: review+
Details | Diff | Splinter Review

Description Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2011-02-09 18:34:58 PST
nsICiter is completely internal to one small part of editor/ and can be removed, and then nsInternetCiter can be made a static class because its only member variable is its refcnt.
Comment 1 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2011-03-25 09:55:21 PDT
Ehsan, Sebastian is a new contributor working on his second bug.  I told him you wouldn't mind if he took this one :-)
Comment 2 :Ehsan Akhgari 2011-03-27 12:11:38 PDT
(In reply to comment #1)
> Ehsan, Sebastian is a new contributor working on his second bug.  I told him
> you wouldn't mind if he took this one :-)

I'd be very glad if he does!  :-)
Comment 3 Sebastian Kromp 2011-03-30 11:49:35 PDT
Created attachment 523072 [details] [diff] [review]
removed nsICiter and made nsInternetCiter static
Comment 4 :Ehsan Akhgari 2011-03-30 19:09:14 PDT
Comment on attachment 523072 [details] [diff] [review]
removed nsICiter and made nsInternetCiter static

This patch looks great, thanks!

I will land it for you on mozilla-central.
Comment 5 :Ehsan Akhgari 2011-03-30 19:40:28 PDT
Sebastian, here is a tip for you in order to generate better patches for other people to check in: <https://developer.mozilla.org/en/Mercurial_FAQ#How_can_I_generate_a_patch_for_somebody_else_to_check-in_for_me.3f>

You don't need to make any changes to this patch, but you can use those guidelines in the future!  Let me know if you need any help.  :-)
Comment 6 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2011-03-31 04:39:38 PDT
http://hg.mozilla.org/mozilla-central/rev/b7534c685c11
Comment 7 Sebastian Kromp 2011-03-31 09:38:52 PDT
(In reply to comment #5)
> Sebastian, here is a tip for you in order to generate better patches for other
> people to check in:
> <https://developer.mozilla.org/en/Mercurial_FAQ#How_can_I_generate_a_patch_for_somebody_else_to_check-in_for_me.3f>
> 
> You don't need to make any changes to this patch, but you can use those
> guidelines in the future!  Let me know if you need any help.  :-)

Thank you very much! I have changed everything according to these guidelines and will use it in future submissions =)

Note You need to log in before you can comment on or make changes to this bug.