Closed Bug 633164 Opened 9 years ago Closed 9 years ago

Zoomed ogg video renders at the wrong size until I move the mouse

Categories

(Core :: Audio/Video, defect, minor)

x86_64
Linux
defect
Not set
minor

Tracking

()

VERIFIED FIXED
mozilla2.0b12
Tracking Status
blocking2.0 --- final+

People

(Reporter: mats, Assigned: mats)

References

()

Details

(Keywords: regression, Whiteboard: [softblocker])

Attachments

(1 file, 1 obsolete file)

Zoomed ogg video renders at the wrong size until I move the mouse.

STEPS TO REPRODUCE
1. load http://en.wikipedia.org/wiki/File:Big_Buck_Bunny_small.ogv
2. click the play button on the (top) video and move the mouse away from it
3. CTRL++ a few times
4. move the mouse
5. CTRL+0

ACTUAL RESULTS
After 3, the video is zoomed to much.  After moving the mouse it's
rendered at the right size (sometimes I need to mouse over the video
itself to fix it).  At 5, the video is too small; again, moving the
mouse fixes it.

PLATFORMS AND BUILDS TESTED
Bug occurs in Firefox nightly build:
Mozilla/5.0 (X11; Linux x86_64; rv:2.0b12pre) Gecko/20110210 Firefox/4.0b12pre
I'm going to guess that bug 615870 caused this.
So an invalidate originating in the view system that doesn't come from the frame system is what we rely on to do the correct repainting here.
Or maybe an invalidate from the video code that needs to update the layer tree instead of just recomposite the layer tree.
Yeah, I think nsMediaDecoder::Invalidate under mSizeChanged should call frame->Invalidate().
Hmm, that doesn't actually fix it.
Well, it should anyway!
Assignee: nobody → tnikkel
blocking2.0: --- → final+
Whiteboard: [softblocker]
Attached patch wip (obsolete) — Splinter Review
It doesn't work because mSizeChanged isn't affected by zooming.

This patch seems to fix the issue for me.
Comment on attachment 512708 [details] [diff] [review]
wip

Seems right, but I don't know video that well.
Attachment #512708 - Flags: review?(roc)
Comment on attachment 512708 [details] [diff] [review]
wip

+    }
+    else {

} else {

Please add comments to mSizeChanged and mImageContainerSizeChanged detailing exactly what they mean.
Attachment #512708 - Flags: review?(roc) → review+
Assignee: tnikkel → matspal
No longer blocks: 633261
Attached patch v2Splinter Review
Nits fixed.  Please take a quick look at the updated comments and
let me know if they make sense.
Attachment #512708 - Attachment is obsolete: true
Attachment #512997 - Flags: review?(roc)
Attachment #512997 - Flags: approval2.0?
Attachment #512997 - Flags: review?(roc)
Attachment #512997 - Flags: review+
Attachment #512997 - Flags: approval2.0?
Attachment #512997 - Flags: approval2.0+
http://hg.mozilla.org/mozilla-central/rev/7a9b17cca93d
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla2.0b12
Cannot reproduce with Firefox 4.0b12pre 20110218 -- marking verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.