Closed Bug 633261 Opened 11 years ago Closed 11 years ago

With hardware acceleration enabled video output stalls after reopening a recently closed tab

Categories

(Core :: Graphics, defect)

All
macOS
defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 636817
Tracking Status
blocking2.0 --- final+

People

(Reporter: whimboo, Assigned: tnikkel)

References

Details

(Keywords: regression, Whiteboard: [softblocker])

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b12pre) Gecko/20110203 Firefox/4.0b12pre

Steps:
1. Open at least two tabs
2. Open in one tab: http://videos.mozilla.org/serv/air_mozilla/020311townhall.ogg
3. Close this tab
4. Undo close this tab

In step 2 the video starts playing, but in step 4 the video output stalls while the audio output shows that we are playing the video.

Regression range is between the builds 11020216 and 11020309.

PASS: http://hg.mozilla.org/mozilla-central/rev/e9c5611100b7
FAIL: http://hg.mozilla.org/mozilla-central/rev/094a7967e171

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=e9c5611100b7&tochange=094a7967e171

There are 4 possible candidates: bug 607838, bug 630461, 627139.
Same as bug 633051 maybe?
blocking2.0: ? → final+
Whiteboard: [softblocker]
It must be a different bug if sound is playing.
Henrik, does this only occur when the video is completely downloaded?  I can't reproduce it with a current nightly, but I haven't let the video download completely.  When I reopen the closed tab, the video download (and playback) is restarting from the beginning.
Actually, testing with a different file on a local HTTP server, I can't reproduce this when the video is completely downloaded either.
Aha. I can reproduce this on my 10.6 OS X laptop, so this is probably OS X only (I was testing on Linux before).  The video is playing after restoring the tab, but the video rect is not repainting.  If you hover over it with the controls, it repaints each time the controls update (a couple of times per second).
Last good build is e1d2e090c9a6, first bad build is 2a13f323dfa0.  This is a regression from bug 626962.
Blocks: 626962
Assignee: kinetik → nobody
Component: Video/Audio → Graphics
QA Contact: video.audio → thebes
Fixing bug 633164 would probably fix this, then
The fix in that bug doesn't fix this, so delinking bugs.
No longer depends on: 633164
Assignee: nobody → tnikkel
Where have people reproduced? I wasn't able to reproduce on Linux without hardware acceleration.
I've reproduced it on OS X with OpenGL, and Linux with OpenGL force-enabled.  I can't reproduce it on Linux without OpenGL.  Having tested right now, I'm also seeing it on Windows 7 with D3D10.  This and bug 636817 are probably the same.
If it only happens with acceleration I'm not going to have any luck with debugging this in the near future.
OS: Mac OS X → All
Hardware: x86 → All
Summary: Video output stalls after reopening an recently closed tab → With hardware acceleration enabled video output stalls after reopening a recently closed tab
(In reply to comment #10)
> seeing it on Windows 7 with D3D10.  This and bug 636817 are probably the same.

Hm, bug 636817 comment 17 shows a different regression window as I have found for OS X. So it's probably not the same regression.
OS: All → Mac OS X
Has the landing of bug 636817 fixed this?
Yes. Awesome.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 636817
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.