Closed Bug 633452 Opened 9 years ago Closed 9 years ago

Crash [@ nsPluginHost::GetPluginName(nsIPluginInstance*, char const**) ] [@ nsPluginHost::GetPluginName ]

Categories

(Core :: Plug-ins, defect, critical)

x86
All
defect
Not set
critical

Tracking

()

RESOLVED FIXED

People

(Reporter: scoobidiver, Assigned: jaas)

References

Details

(Keywords: crash, topcrash)

Crash Data

It is a crash signature that was supposed to be fixed by bug 621250.
It is #11 top crasher on Mac OS X in 4.0b11.
It is #327 top crasher on Windows in 4.0b11.

One comment says: "Crashed when trying to join a meeting on Webex"

Signature	nsPluginHost::GetPluginName
UUID	ad3fcd4f-9fd1-420c-b583-72d912110210
Time 	2011-02-10 18:18:35.7261
Uptime	27103
Last Crash	56978419 seconds (more than 3 months) before submission
Install Age	174892 seconds (2.0 days) since version was first installed.
Product	Firefox
Version	4.0b11
Build ID	20110203140743
Branch	2.0
OS	Mac OS X
OS Version	10.6.6 10J567
CPU	amd64
CPU Info	family 6 model 23 stepping 6
Crash Reason	EXC_BAD_ACCESS / KERN_INVALID_ADDRESS
Crash Address	0x20
App Notes 	Renderers: 0x22600,0x20400

Frame 	Module 	Signature [Expand] 	Source
0 	XUL 	nsPluginHost::GetPluginName 	modules/plugin/base/src/nsPluginHost.cpp:3760
1 	XUL 	DoStopPlugin 	layout/generic/nsObjectFrame.cpp:419
2 	XUL 	nsObjectFrame::StopPluginInternal 	layout/generic/nsObjectFrame.cpp:2665
3 	XUL 	nsObjectFrame::DestroyFrom 	layout/generic/nsObjectFrame.cpp:683
4 	XUL 	nsLineBox::DeleteLineList 	layout/generic/nsLineBox.cpp:342
5 	XUL 	nsBlockFrame::DestroyFrom 	layout/generic/nsBlockFrame.cpp:320
6 	XUL 	nsLineBox::DeleteLineList 	layout/generic/nsLineBox.cpp:342
7 	XUL 	nsBlockFrame::DestroyFrom 	layout/generic/nsBlockFrame.cpp:320
8 	XUL 	nsFrameList::DestroyFramesFrom 	layout/generic/nsFrameList.cpp:98
9 	XUL 	nsContainerFrame::DestroyFrom 	layout/generic/nsContainerFrame.cpp:272
10 	XUL 	nsFrameList::DestroyFramesFrom 	layout/generic/nsFrameList.cpp:98
11 	XUL 	nsContainerFrame::DestroyFrom 	layout/generic/nsContainerFrame.cpp:272
12 	XUL 	nsFrameList::DestroyFramesFrom 	layout/generic/nsFrameList.cpp:98
13 	XUL 	nsContainerFrame::DestroyFrom 	layout/generic/nsContainerFrame.cpp:272
14 	XUL 	nsFrameManager::Destroy 	layout/generic/nsIFrame.h:553
15 	XUL 	PresShell::Destroy 	layout/base/nsPresShell.cpp:2023
16 	XUL 	DocumentViewerImpl::DestroyPresShell 	layout/base/nsDocumentViewer.cpp:4260
17 	XUL 	DocumentViewerImpl::Destroy 	layout/base/nsDocumentViewer.cpp:1634
18 	XUL 	DocumentViewerImpl::Show 	layout/base/nsDocumentViewer.cpp:1905
19 	XUL 	nsPresContext::EnsureVisible 	layout/base/nsPresContext.cpp:1691
20 	XUL 	PresShell::UnsuppressAndInvalidate 	layout/base/nsPresShell.cpp:4610
21 	XUL 	PresShell::ProcessReflowCommands 	layout/base/nsPresShell.cpp:8029
22 	XUL 	PresShell::FlushPendingNotifications 	layout/base/nsPresShell.cpp:4897
23 	XUL 	PresShell::DidDoReflow 	layout/base/nsPresShell.cpp:4759
24 	XUL 	PresShell::ProcessReflowCommands 	layout/base/nsPresShell.cpp:7999
25 	XUL 	PresShell::FlushPendingNotifications 	layout/base/nsPresShell.cpp:4897
26 	XUL 	nsRefreshDriver::Notify 	layout/base/nsRefreshDriver.cpp:326
27 	XUL 	nsTimerImpl::Fire 	xpcom/threads/nsTimerImpl.cpp:428
28 	XUL 	nsTimerEvent::Run 	xpcom/threads/nsTimerImpl.cpp:517
29 	XUL 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:633
30 	XUL 	NS_ProcessPendingEvents_P 	nsThreadUtils.cpp:200
31 	XUL 	nsBaseAppShell::NativeEventCallback 	widget/src/xpwidgets/nsBaseAppShell.cpp:132
32 	XUL 	nsAppShell::ProcessGeckoEvents 	widget/src/cocoa/nsAppShell.mm:399
33 	CoreFoundation 	CoreFoundation@0x4e400 	
34 	CoreFoundation 	CoreFoundation@0x4c5f8 	

More reports at:
https://crash-stats.mozilla.com/report/list?product=Firefox&range_value=4&range_unit=weeks&signature=nsPluginHost%3A%3AGetPluginName
Assignee: nobody → joshmoz
I just ran into this when trying to start a WebEx conference. The first time I tried I got an error (no crash) saying:

Failed to download java download client!
Sorry, you do not have java download client enabled. Please try again or inform your Site Administrator to set up for you.
HOME

(screenshot: http://grab.by/90Bq )

Then the second time I try to load the conference, I get the crash.
>  *aPluginName = TagForPlugin(plugin)->mName.get();

We're crashing because "TagForPlugin" is returning NULL. That should never happen.
Status: NEW → ASSIGNED
Duplicate of this bug: 638716
Keywords: topcrash
This is easy to reproduce with Firefox 4. Go to this page, enter a name and email address, then try to join the test meeting. That will fail gracefully the first time but do it again and you'll crash.

http://www.webex.com/lp/jointest/
In Firefox 4, it is #3 top crasher on Mac OS X and #287 on Windows.

On Mac OS X, there is a clear correlation with Java:
    100% (397/397) vs.   9% (1336/15351) JavaRuntimeSupport
    100% (397/397) vs.  10% (1532/15351) JavaPlugin2_NPAPI
    100% (397/397) vs.  10% (1532/15351) JavaNativeFoundation
    100% (397/397) vs.  10% (1533/15351) JavaVM
blocking2.0: --- → .x+
The fix I just posted for bug 645289 should also fix this.
Should be fixed on mozilla-central by the patch for bug 645289. We can re-open if this shows up again.
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
blocking2.0: .x+ → Macaw
Depends on: 645289
Removing from Macaw based on comment 7. Tracking it in bug 645289.
blocking2.0: Macaw+ → ---
Crash Signature: [@ nsPluginHost::GetPluginName(nsIPluginInstance*, char const**) ] [@ nsPluginHost::GetPluginName ]
You need to log in before you can comment on or make changes to this bug.