Closed Bug 633827 Opened 9 years ago Closed 9 years ago

[de] The settings button in the FF button menu is too small for the german entry "Einstellungen"

Categories

(Firefox :: Theme, defect, trivial)

x86
Windows 7
defect
Not set
trivial

Tracking

()

VERIFIED FIXED
Firefox 4.0b12

People

(Reporter: mrtpcag, Assigned: Margaret)

References

Details

Attachments

(4 files, 2 obsolete files)

User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b11) Gecko/20100101 Firefox/4.0b11
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b11) Gecko/20100101 Firefox/4.0b11

The border displayed while holding the mouse over the entry "Einstellungen" in the FF button menu is some px smaller then the word "Einstellungen". This doesn't looks very well.

Reproducible: Always

Steps to Reproduce:
1. Click on the FF button
2. Hover the mouse on "Einstellungen"
Actual Results:  
The border is to small.

Expected Results:  
The width of the border should be increased by about 3px.
Component: Menus → de / German
Product: Firefox → Mozilla Localizations
QA Contact: menus → german.de
blocking2.0: --- → ?
Can you attach a screenshot?
Clearing blocking nom on unconfirmed bug about 3px error without blocking-rationale provided.
blocking2.0: ? → ---
This looks very much like bug 585253, should we do a similar stunt here?

Not sure what the right size would be.
Component: de / German → Menus
Product: Mozilla Localizations → Firefox
QA Contact: german.de → menus
Version: unspecified → Trunk
This looks like a different problem because the current max-width for menuitems is 42em, and this item is definitely not hitting that extreme.

I feel like this problem is probably caused by the fact that this isn't actually a menuitem, but rather an hbox inside a splitmenu element. I've noticed that in the en-US builds the Bookmarks
[sorry I accidentally submit my comment, continuing comment...]

... menuitem, the end of the "Bookmarks" label juts right against the edge of the element, so maybe the solution would be to add some padding to that hbox.
Component: Menus → Theme
QA Contact: menus → theme
Severity: major → trivial
Status: UNCONFIRMED → NEW
Ever confirmed: true
yeah, let's increase padding to the hbox.
Attached image adding 4px padding (obsolete) —
I was able to reproduce the screenshot of the problem in the German locale by swapping the options string. Adding 4px of padding to the end of the hbox results in this screenshot.

I just arbitrarily picked 4px because I thought it looks good. Alex, what do you think?
Assignee: nobody → margaret.leibovic
Status: NEW → ASSIGNED
Attachment #513164 - Flags: ui-review?(faaborg)
Attached patch patch (obsolete) — Splinter Review
After testing with Windows Classic and Linux, it seems this problem only exists with Windows Aero.

We can change the padding value if Alex thinks it should be different.
Attachment #513193 - Flags: review?(dao)
You should use an em value, like 0.5em.
Attached image adding 0.5em padding
I think this looks better than 4px.
Attachment #513164 - Attachment is obsolete: true
Attachment #513164 - Flags: ui-review?(faaborg)
Attached patch patch (using em)Splinter Review
Attachment #513193 - Attachment is obsolete: true
Attachment #513204 - Flags: review?(dao)
Attachment #513193 - Flags: review?(dao)
Attachment #513204 - Flags: review?(dao) → review+
Attachment #513204 - Flags: approval2.0?
Attachment #513204 - Flags: approval2.0? → approval2.0+
http://hg.mozilla.org/mozilla-central/rev/c5d9189cdf21
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 4.0b12
Thanks for fixing this bug! I first tried to fix it on my own, but i didn't get it. What would Firefox be without the developers... ;-)

Thanks!
Marking as verified fixed based on comment 15.
Status: RESOLVED → VERIFIED
Summary: [de] The settings button in the FF button menu is to small for the german entry "Einstellungen" → [de] The settings button in the FF button menu is too small for the german entry "Einstellungen"
Depends on: 635463
(In reply to comment #16)
> Marking as verified fixed based on comment 15.

Sorry, I think this was a mistake.
I didn't say I've seen the bugfix. I only thanked because I've seen the link to the changeset, which Margaret Leibovic posted. (comment 14)
Status: VERIFIED → RESOLVED
Closed: 9 years ago9 years ago
OK, now it's finally fixed. I've marked it as 'verified fixed'.

Thanks a lot!
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.