[HW Accel disabled] [Win64] Rendering of Menu bar and webpages with severe artifacts (black border toolbar button)

VERIFIED WORKSFORME

Status

()

Core
Graphics
--
major
VERIFIED WORKSFORME
7 years ago
6 months ago

People

(Reporter: Virtual, Assigned: m_kato)

Tracking

({nightly-community, regression})

Trunk
x86_64
Windows 7
nightly-community, regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

User-Agent:       Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:2.0b12pre) Gecko/20110218 Firefox/4.0b12pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:2.0b12pre) Gecko/20110218 Firefox/4.0b12pre

Works - https://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2011-02-18-03-mozilla-central/
fails - https://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2011-02-18-14-mozilla-central/

Reproducible: Always

Steps to Reproduce:
1. Disable "Use hardware acceleration when available" in Advanced General options in Firefox
2. restart Firefox
blocking2.0: --- → ?
Keywords: regression
Version: unspecified → Trunk
Duplicate of this bug: 635441
Status: UNCONFIRMED → NEW
Component: General → General
Ever confirmed: true
Product: Firefox → Core
QA Contact: general → general
Component: General → Graphics
QA Contact: general → thebes

Comment 4

7 years ago
I can confirm it.

Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:2.0b12pre) Gecko/20110218 Firefox/4.0b12pre
Is this Win64-only, or does it also happen on 32-bit builds?

Comment 6

7 years ago
(In reply to comment #5)
> Is this Win64-only, or does it also happen on 32-bit builds?

Looks like it.

Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:2.0b12pre) Gecko/20110219 Firefox/4.0b12pre = artifacts

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b12pre) Gecko/20110219 Firefox/4.0b12pre = no artifacts
Duplicate of this bug: 635457
Summary: Disabling hardware acceleration causes artifacts to appear → Win64: Rendering of Menu bar and webpages with severe artifacts

Comment 8

7 years ago
(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:2.0b12pre)
> Gecko/20110218 Firefox/4.0b12pre
> Build Identifier: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:2.0b12pre)
> Gecko/20110218 Firefox/4.0b12pre
> 
> Works -
> https://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2011-02-18-03-mozilla-central/
> fails -
> https://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2011-02-18-14-mozilla-central/
> 
> Reproducible: Always
> 
> Steps to Reproduce:
> 1. Disable "Use hardware acceleration when available" in Advanced General
> options in Firefox
> 2. restart Firefox
I'm getting the same problem with HW acceleration ENABLED in the Advanced General options.

Comment 9

7 years ago
This looks related:

http://hg.mozilla.org/mozilla-central/rev/c5d9189cdf21

Although it has probably uncovered an existing bug.
Blocks: 633827
I don't think this can block if it's Win x64 only.
blocking2.0: ? → -
64-bit Windows builds aren't supported, so this doesn't block.

Updated

7 years ago
Duplicate of this bug: 635555

Comment 13

7 years ago
An update has just caused this to spread to 32bit.
Duplicate of this bug: 635564
If it happens in 32bit I guess we renom.
blocking2.0: - → ?

Comment 16

7 years ago
To reiterate, this affects the menu bar as well as CSS transformed items.

See the sawtooth pattern around page images here:
http://gobliina.com/minefield64bugshots/Minefieldx64-artifacts-on-css-transformed-images.png
Can others reproduce this on 32-bit builds?
Summary: Win64: Rendering of Menu bar and webpages with severe artifacts → [hw accel disabled] Win64(?): Rendering of Menu bar and webpages with severe artifacts

Comment 18

7 years ago
Sorry, it was an update error I think. about:support revealed my (x86) version was actually x64 somehow. reinstalled and it works fine now.
I can reproduce in 64-bit Minefield with hardware acceleration disabled, but not 32-bit, even in the very latest tinderbox builds. Therefore, I suspect that comment 13 was mistaken, and this is 64-bit builds only.
blocking2.0: ? → -
Summary: [hw accel disabled] Win64(?): Rendering of Menu bar and webpages with severe artifacts → [hw accel disabled] [Win64] Rendering of Menu bar and webpages with severe artifacts
(In reply to comment #18)
> Sorry, it was an update error I think. about:support revealed my (x86) version
> was actually x64 somehow. reinstalled and it works fine now.

Ah, excellent! Thanks for following up.
(In reply to comment #8)
> I'm getting the same problem with HW acceleration ENABLED in the Advanced
> General options.

Are you sure that you are using hardware acceleration ?
Post your "Graphic" info from about:support please.

Updated

7 years ago
Duplicate of this bug: 635586

Updated

7 years ago
Duplicate of this bug: 635583

Comment 24

7 years ago
(In reply to comment #21)
> (In reply to comment #8)
> > I'm getting the same problem with HW acceleration ENABLED in the Advanced
> > General options.
> 
> Are you sure that you are using hardware acceleration ?
> Post your "Graphic" info from about:support please.

Adapter Description
        NVIDIA GeForce GTX 460

        Vendor ID
        10de

        Device ID
        0e22

        Adapter RAM
        768

        Adapter Drivers
        nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um

        Driver Version
        8.17.12.6658

        Driver Date
        1-7-2011

        Direct2D Enabled
        true

        DirectWrite Enabled
        true (6.1.7600.16699, font cache 11.80 MB)

        WebGL Renderer
        NVIDIA Corporation -- GeForce GTX 460/PCI/SSE2 -- 4.1.0

        GPU Accelerated Windows
        1/1 Direct3D 9
So looks like
D3D9 = enabled = artifacts
D3D9 = disabled = artifacts
D3D10 = enabled = no artifacts
D3D10 = disabled = artifacts

Based also on your and my info

Graphics
Adapter Description - NVIDIA GeForce 8600 GT
Vendor ID- 10de
Device ID - 0402
Adapter RAM - 256
Adapter Drivers - nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
Driver Version - 8.17.12.6666
Driver Date - 1-13-2011
Direct2D Enabled - true
DirectWrite Enabled - true (6.1.7600.16699, font cache 3,76 MB)
WebGL Renderer - NVIDIA Corporation -- GeForce 8600 GT/PCI/SSE2 -- 3.3.0GPU Accelerated Windows - 1/1 Direct3D 10


try also updating DirectX
http://www.microsoft.com/downloads/en/details.aspx?FamilyID=3b170b25-abab-4bc3-ae91-50ceb6d8fa8d
because it's odd that you're using Direct3D 9 instead of Direct3D 10 with your GPU
and what system you're using ?

Updated

7 years ago
Duplicate of this bug: 635621

Comment 27

7 years ago
My x1950 (dx9) also had artifacts regardless of whether d2d was blocked (due to a 'legacy' 10.2 driver) or forced.

Comment 28

7 years ago
I had this problem with a nvidia geforce 9500 gs
I upgraded the video driver and direct x  just in case and it disappeared. 

I was getting the artifacts with hardware acceleration enabled.

Comment 29

7 years ago
Just installed the 32bit version, and the problem dissapeared. My about:support page also says I'm using DirectX 10. Not sure what the problem was with the 64bit build.

Comment 30

7 years ago
x64 built: not working
x32 built: working

Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:2.0b12pre) Gecko/20110220 Firefox/4.0b12pre

Adapter Description Mobile Intel(R) 4 Series Express Chipset Family
Vendor ID8086
Device ID2a42
Adapter RAM Unknown
Adapter Drivers igdumd64 igd10umd64 igdumdx32 igd10umd32
Driver Version  8.641.1.1000
Driver Date 8-24-2009
Direct2D Enabled  false
DirectWrite Enabled false (6.1.7600.20830, font cache n/a)
WebGL Renderer(WebGL unavailable)
GPU Accelerated Windows1/1 Direct3D 9

switchable graphics with "real" graphics card:
Adapter Description ATI Mobility Radeon HD 3400 Series  
Vendor ID1002
Device ID95c4
Adapter RAM 256
Adapter Drivers atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64
Driver Version  8.641.1.1000
Driver Date 8-24-2009
Direct2D Enabled  Blocked on your graphics driver. Try updating your graphics driver to version 10.6 or newer.
DirectWrite Enabled false (6.1.7600.20830, font cache n/a)
WebGL Renderer(WebGL unavailable)
GPU Accelerated Windows0/1

Comment 31

7 years ago
If I manually enable hw acceleration in about:config, the problem disappears.

gfx.direct2d.force-enabled true
gfx.font_rendering.directwrite.enabled true

Adapter Description: ATI Mobility Radeon HD 5470
Vendor ID: 1002
Device ID: 68e0
Adapter RAM: 1024
Adapter Drivers: atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
Driver Version: 8.680.0.0
Driver Date: 11-18-2009
Direct2D Enabled: true
DirectWrite Enabled: true (6.1.7600.20830, font cache n/a)
WebGL Renderer:(WebGL unavailable)
GPU Accelerated Windows: 1/1 Direct3D 10
(In reply to comment #31)
> If I manually enable hw acceleration in about:config, the problem disappears.
> 
> gfx.direct2d.force-enabled true
> gfx.font_rendering.directwrite.enabled true
> 
> Adapter Description: ATI Mobility Radeon HD 5470
> Vendor ID: 1002
> Device ID: 68e0
> Adapter RAM: 1024
> Adapter Drivers: atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva
> atiumd6a atitmm64
> Driver Version: 8.680.0.0
> Driver Date: 11-18-2009
> Direct2D Enabled: true
> DirectWrite Enabled: true (6.1.7600.20830, font cache n/a)
> WebGL Renderer:(WebGL unavailable)
> GPU Accelerated Windows: 1/1 Direct3D 10

On another note, you guys should update your graphics drivers! :)

Updated

7 years ago
Duplicate of this bug: 635655

Comment 35

7 years ago
These values were both set to false on my system, setting them to true resolves the issue for me as well:
 gfx.direct2d.force-enabled true
 gfx.font_rendering.directwrite.enabled true

My Graphics card:
Adapter Description: ATI Mobility Radeon HD 5730
Vendor ID 1002
Device ID68c0
Adapter RAM1024
Adapter Drivers atiu9p64 aticfx64 aticfx64 atiu9pag aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
Driver Version 8.692.1.0
Driver Date1-22-2010
Direct2D Enabledtrue
DirectWrite Enabledtrue (6.1.7600.16385, font cache 32.02 MB)WebGL enderer(WebGL unavailable)GPU Accelerated Windows1/1 Direct3D 10




(In reply to comment #31)
> If I manually enable hw acceleration in about:config, the problem disappears.
> 
> gfx.direct2d.force-enabled true
> gfx.font_rendering.directwrite.enabled true
> 
> Adapter Description: ATI Mobility Radeon HD 5470
> Vendor ID: 1002
> Device ID: 68e0
> Adapter RAM: 1024
> Adapter Drivers: atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva
> atiumd6a atitmm64
> Driver Version: 8.680.0.0
> Driver Date: 11-18-2009
> Direct2D Enabled: true
> DirectWrite Enabled: true (6.1.7600.20830, font cache n/a)
> WebGL Renderer:(WebGL unavailable)
> GPU Accelerated Windows: 1/1 Direct3D 10

Updated

7 years ago
Duplicate of this bug: 635815
If you see this bug with Hardware Acceleration ENABLED be sure to:
-use newest GPU drivers (especially nVidia, AMD & Intel)
-use newest DirectX updates ( http://www.microsoft.com/downloads/en/details.aspx?FamilyID=3b170b25-abab-4bc3-ae91-50ceb6d8fa8d )
-use patched Windows (install all patches from Windows Update)

And finally if you do this all, post your Graphic info from about:support if you still see this.
Whiteboard: READ COMMENT 37 BEFORE COMMENTING

Comment 38

7 years ago
I have HA disabled and still getting the artifacts.  When I manually enable it they're still there.
Read then Comment #37 and post result when you do all what is written there. Thanks

Comment 40

7 years ago
I have tried everything in Comment 37 and double checked them. I get this bug with Accel on and Accel off. 

Screen Shot of Artifacts:
http://www.astallaslions.com/Untitled-1.jpg

  Application Basics

        Name
        Firefox

        Version
        4.0b12pre

        User Agent
        Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:2.0b12pre) Gecko/20110222 Firefox/4.0b12pre

        Profile Directory

          Open Containing Folder

        Enabled Plugins

          about:plugins

        Build Configuration

          about:buildconfig

  Extensions

        Name

        Version

        Enabled

        ID

  Modified Preferences

      Name

      Value

        accessibility.typeaheadfind.flashBar
        0

        browser.places.smartBookmarksVersion
        2

        browser.startup.homepage_override.buildID
        20110222030201

        browser.startup.homepage_override.mstone
        rv:2.0b12pre

        browser.tabs.warnOnClose
        false

        extensions.lastAppVersion
        4.0b12pre

        layers.accelerate-all
        true

        network.cookie.prefsMigrated
        true

        places.database.lastMaintenance
        1298313427

        places.history.expiration.transient_current_max_pages
        128835

        privacy.sanitize.migrateFx3Prefs
        true

        security.warn_viewing_mixed
        false

  Graphics

        Adapter Description
        NVIDIA GeForce 7800 GT

        Vendor ID
        10de

        Device ID
        0092

        Adapter RAM
        256

        Adapter Drivers
        nvd3dumx,nvd3dum

        Driver Version
        8.17.12.6658

        Driver Date
        1-7-2011

        Direct2D Enabled
        false

        DirectWrite Enabled
        false (6.1.7600.16699, font cache n/a)

        WebGL Renderer
        NVIDIA Corporation -- GeForce 7800 GT/PCI/SSE2 -- 2.1.2

        GPU Accelerated Windows
        0/1

Comment 41

7 years ago
Had the same issue after upgrading to newer version of b12pre. Upgraded graphic drivers as suggested and that fixed the problem... Simple solution, but not the first thing you'd think of as it was isolated to Firefox.

Previously:
Radeon HD4250 - Display Driver 8.710
HW acceleration was enabled in options
Direct2D Enabled: false
DirectWrite Enabled: false

Now:
Driver Version 8.821.0.0
Direct2D Enabled true
DirectWrite Enabled true (6.1.7601.17514, font cache n/a)


(In reply to comment #37)
> If you see this bug with Hardware Acceleration ENABLED be sure to:
> -use newest GPU drivers (especially nVidia, AMD & Intel)
> -use newest DirectX updates (
> http://www.microsoft.com/downloads/en/details.aspx?FamilyID=3b170b25-abab-4bc3-ae91-50ceb6d8fa8d
> )
> -use patched Windows (install all patches from Windows Update)
> 
> And finally if you do this all, post your Graphic info from about:support if
> you still see this.
(In reply to comment #40)
>         Direct2D Enabled
>         false
> 
>         DirectWrite Enabled
>         false (6.1.7600.16699, font cache n/a)
>
>         GPU Accelerated Windows
>         0/1

You have acceleration DISABLED based on what I see there.

Also go to about:config
Find layers.accelerate-all and reset this value to default

(In reply to comment #41)

Exactly, but don't forget that GPU drivers are most related to GPU acceleration.
And Mozilla block (as I remember) old drivers.

Updated

7 years ago
Duplicate of this bug: 636120

Updated

7 years ago
Duplicate of this bug: 636075
Duplicate of this bug: 636121
Duplicate of this bug: 636371
Duplicate of this bug: 636398

Comment 48

7 years ago
(In reply to Comment 42)

Ok I tried this, and ARTIFACTS disappeared! But something new happened, black bars where the tab names, minefield logo, and menubar text should be. This is also happening to Form Text (and actually is happening to the text as I fill out this form)

Screen Shot:
http://www.astallaslions.com/Untitled-2.jpg

Application Basics

        Name
        Firefox

        Version
        4.0b12pre

        User Agent
        Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:2.0b12pre) Gecko/20110222 Firefox/4.0b12pre

        Profile Directory

          Open Containing Folder

        Enabled Plugins

          about:plugins

        Build Configuration

          about:buildconfig

  Extensions

        Name

        Version

        Enabled

        ID

  Modified Preferences

      Name

      Value

        accessibility.typeaheadfind.flashBar
        0

        browser.places.smartBookmarksVersion
        2

        browser.startup.homepage_override.buildID
        20110222030201

        browser.startup.homepage_override.mstone
        rv:2.0b12pre

        browser.tabs.warnOnClose
        false

        extensions.lastAppVersion
        4.0b12pre

        gfx.direct2d.force-enabled
        true

        gfx.font_rendering.directwrite.enabled
        true

        layers.accelerate-all
        default

        layers.acceleration.force-enabled
        true

        network.cookie.prefsMigrated
        true

        places.database.lastMaintenance
        1298419979

        places.history.expiration.transient_current_max_pages
        128835

        places.last_vacuum
        1298506648

        privacy.sanitize.migrateFx3Prefs
        true

        security.warn_viewing_mixed
        false

  Graphics

        Adapter Description
        NVIDIA GeForce 7800 GT

        Vendor ID
        10de

        Device ID
        0092

        Adapter RAM
        256

        Adapter Drivers
        nvd3dumx,nvd3dum

        Driver Version
        8.17.12.6658

        Driver Date
        1-7-2011

        Direct2D Enabled
        true

        DirectWrite Enabled
        true (6.1.7601.17514, font cache n/a)

        WebGL Renderer
        NVIDIA Corporation -- GeForce 7800 GT/PCI/SSE2 -- 2.1.2

        GPU Accelerated Windows
        1/1 Direct3D 10

Comment 49

7 years ago
(In reply to comment #48)
> black bars where the tab names

>         NVIDIA Corporation -- GeForce 7800 GT/PCI/SSE2 -- 2.1.2
> 
>         GPU Accelerated Windows
>         1/1 Direct3D 10 (?)

I get the same on an x1950 with accel enabled. Perhaps it's something to do with dx9 only cards.
Could be the cause. Thanks for info.
Summary: [hw accel disabled] [Win64] Rendering of Menu bar and webpages with severe artifacts → [HW Acc disabled] [Dx9 GPUs wrongly use D3D10] [Win64] Rendering of Menu bar and webpages with severe artifacts
>> black bars where the tab names

>>         NVIDIA Corporation -- GeForce 7800 GT/PCI/SSE2 -- 2.1.2
>> 
>>         GPU Accelerated Windows
>>         1/1 Direct3D 10 (?)

>I get the same on an x1950 with accel enabled. Perhaps it's something to do
>with dx9 only cards.

Nope. I have a Nvidia GTX580, using the latest 266.58 WHQL drivers, Windows 7 Ultimate x64 with SP1 (so DirectX 10), Intel i7 930 (8 core) 2.80 GHz and 12 GB RAM. If I disable hardware acceleration I get the same artifacts you guys are experienced every time...
We all know that artifacts appear when Hardware Acceleration is DISABLED.
But you will also see it with HW Acc ENABLED when you have GPU that support only DirectX 9 and Firefox will start using Direct3D 10, instead of Direct3D 9.

In your case you should use Direct3D 11 (dunno if this is implanted yet, can someone confirm ?) or at least Direct3D 10.1.

Comment 53

7 years ago
Hi All,

I'm having the same problem.
Here's some info for those looking into finding a solution: -

My Hardware is a laptop with an Mobile Intel 945 chipset.
I'm running Windows 7 64Bit, and DirectX11 (with Auto Updates on, and service pack 1 installed).

The problem appears whether I'm using hardware acceleration or not.
Post your "Graphic" info from about:support like it's written on Whiteboard. Thanks

Comment 55

7 years ago
Oh, Sorry. I didn't understand that at 1st.

Graphics 
Adapter Description	Mobile Intel(R) 945 Express Chipset Family
Vendor ID	8086
Device ID	27a2
Adapter RAM	Unknown
Adapter Drivers	igdumd64
Driver Version	8.15.10.1930
Driver Date	9-23-2009
Direct2D Enabled	false
DirectWrite Enabled	false (6.1.7601.17514, font cache n/a)
WebGL Renderer	(WebGL unavailable)
GPU Accelerated Windows	0/1
(In reply to comment #55)
> Direct2D Enabled    false
> DirectWrite Enabled    false (6.1.7601.17514, font cache n/a)
> GPU Accelerated Windows    0/1

You didn't use hardware acceleration as I see.

Comment 57

7 years ago
Hmmm, That's strange. I've ticked the checkbox (in Options, Advanced, General tab; the frame titled "Browsing").
I guess that means Mozilla can't find any hardware acceleration on my machine..?

Comment 58

7 years ago
Adapter Description: ATI Mobility Radeon HD 2400 XT
Vendor ID: 1002
Device ID: 94c8
Adapter RAM: 256
Adapter Drivers: atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64
Driver Version: 8.632.1.2000
Driver Date: 8-17-2009
Direct2D Enabled: Blocked on your graphics driver. Try updating your graphics driver to version 10.6 or newer.
DirectWrite Enabled: false (6.1.7600.16699, font cache n/a)
WebGL Renderer:(WebGL unavailable)
GPU Accelerated Windows: 0/1
(In reply to comment #57)
> I guess that means Mozilla can't find any hardware acceleration on my
> machine..?

Your driver is too old. See bug 601079 comment 16.

Comment 60

7 years ago
Thanks for clearing that up for me.

Sadly my driver is the newest driver for my hardware.
Guess I'm just out of date.
(In reply to comment #58)
> Direct2D Enabled: Blocked on your graphics driver. Try updating your graphics
> driver to version 10.6 or newer.

Instead of posting, try reading what you post, because you got answer there. Also read comment #37 as it's written in whiteboard.

Comment 62

7 years ago
(In reply to comment #61)
> (In reply to comment #58)
> > Direct2D Enabled: Blocked on your graphics driver. Try updating your graphics
> > driver to version 10.6 or newer.
> 
> Instead of posting, try reading what you post, because you got answer there.
> Also read comment #37 as it's written in whiteboard.

There is no updated driver for my hardware. Hardware people are slackers for not having updated drivers.

Comment 63

7 years ago
(In reply to comment #62)
> (In reply to comment #61)
> > (In reply to comment #58)
> > > Direct2D Enabled: Blocked on your graphics driver. Try updating your graphics
> > > driver to version 10.6 or newer.
> > 
> > Instead of posting, try reading what you post, because you got answer there.
> > Also read comment #37 as it's written in whiteboard.
> 
> There is no updated driver for my hardware. Hardware people are slackers for
> not having updated drivers.

I'm on the wrong laptop. That only makes sense to me, anyway, this is a different ati card with updated drivers. so updated drivers fixed the problem and so here you go

Adapter Description: ATI Mobility Radeon HD 2400 XT
Vendor ID: 1002
Device ID: 94c8
Adapter RAM: 256
Adapter Drivers: aticfx64 aticfx64 aticfx32 aticfx32 atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64
Driver Version: 8.821.0.0
Driver Date: 1-26-2011
Direct2D Enabled: true
DirectWrite Enabled: true (6.1.7600.16699, font cache n/a)
WebGL Renderer: ATI Technologies Inc. -- ATI Mobility Radeon HD 2400 XT -- 3.3.10524 Compatibility Profile Context
GPU Accelerated Windows: 1/1 Direct3D 10

Comment 64

7 years ago
Wanted to give you a little more information if anyone ever takes this bug. I updated my drivers and I didn't see artifacts. HOWEVER, if I DISABLE use hardware acceleration when available, it comes right back. 

I don't think telling people it's your problem really works, if nothing else is messed up but Firefox and if Firefox used to work, people are not going to think oh drivers. It's Firefox's problem.

Adapter Description: NVIDIA GeForce 9500 GS
Vendor ID: 10de
Device ID: 0644
Adapter RAM: 512
Adapter Drivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
Driver Version: 8.17.12.6658
Driver Date: 1-7-2011
Direct2D Enabled : true
DirectWrite Enabled: true (6.1.7600.16699, font cache n/a)
WebGL Renderer: NVIDIA Corporation -- GeForce 9500 GS/PCI/SSE2 -- 3.3.0GPU Accelerated Windows: 1/1 Direct3D 10
Whiteboard: READ COMMENT 37 BEFORE COMMENTING → Do not post in this bug. Use the Windows 32-bit build of Firefox 4.

Comment 65

7 years ago
Come on people get it right the issue dont show with HARDWARE ACCELERATION TURNED ON. It only happens when its turned off som everyone that has said drivers fixed it TURN HARDWARE ACCELERATION OFF and see if you get the issue.

Comment 66

7 years ago
No, actually I have hardware acceleration turned on and its beginning to look worse than ever.
Duplicate of this bug: 636938

Updated

7 years ago
Duplicate of this bug: 637029

Updated

7 years ago
Duplicate of this bug: 637042

Comment 70

7 years ago
(In reply to comment #21)
> (In reply to comment #8)
> > I'm getting the same problem with HW acceleration ENABLED in the Advanced
> > General options.
> 
> Are you sure that you are using hardware acceleration ?
> Post your "Graphic" info from about:support please.

me too. i don't think that has anything to do with it. at least not for me.

Comment 71

7 years ago
reverting to 4.0b11pre resolved this issue for me.

Comment 72

7 years ago
I get issues with it on OR off. please see Comment 40 and Comment 48

Comment 73

7 years ago
(In reply to comment #31)
> If I manually enable hw acceleration in about:config, the problem disappears.
> 
> gfx.direct2d.force-enabled true
> gfx.font_rendering.directwrite.enabled true
> 
> Adapter Description: ATI Mobility Radeon HD 5470
> Vendor ID: 1002
> Device ID: 68e0
> Adapter RAM: 1024
> Adapter Drivers: atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva
> atiumd6a atitmm64
> Driver Version: 8.680.0.0
> Driver Date: 11-18-2009
> Direct2D Enabled: true
> DirectWrite Enabled: true (6.1.7600.20830, font cache n/a)
> WebGL Renderer:(WebGL unavailable)
> GPU Accelerated Windows: 1/1 Direct3D 10

this works for me in 4.0b13pre, thanks!
The DX9 GPUs wrongly use D3D10 part of this bug sounds -really-, unlikely. It might happen if you force-enable Direct2D. But I find it -extraordinarily- unlikely it would happen otherwise, where is this coming from?
So removing this, because HW Accel was FORCED there ( Comment #48 & Comment #49 ). Didn't see this on first glance :P
Summary: [HW Acc disabled] [Dx9 GPUs wrongly use D3D10] [Win64] Rendering of Menu bar and webpages with severe artifacts → [HW Accel disabled] [Win64] Rendering of Menu bar and webpages with severe artifacts
Duplicate of this bug: 637153

Comment 77

7 years ago
(In reply to comment #74)
> The DX9 GPUs wrongly use D3D10 part of this bug sounds -really-, unlikely. It
> might happen if you force-enable Direct2D. But I find it -extraordinarily-
> unlikely it would happen otherwise, where is this coming from?

It happens for me when layers.prefer-d3d9 is false and direct2d is force enabled. It also corresponds to the 'black bars over text' bug shown in comment 48.

Comment 78

7 years ago
I think comment 48 should be a separate bug as it is always reproducible for me on both 32bit and 64bit and it clearly not the same as the 64 bit only corruption.
No, because he forced this settings and used non-standard values, even if Firefox didn't enable it by default

gfx.direct2d.force-enabled = true (FALSE by default)
gfx.font_rendering.directwrite.enabled = true (FALSE by default)
layers.accelerate-all = default (DIDN'T EXIST by default)
layers.acceleration.force-enabled = true (FALSE by default)

Comment 80

7 years ago
Next update and the problem still exist.

Comment 81

7 years ago
Hi,
I have the same problem, with hardware acceleration enabled or disabled.
Setting gfx.direct2d.force-enabled = true makes it even worse 
here are my graphics properties :
Adapter Description NVIDIA Quadro FX 4500
Vendor ID10de 
Device ID009d
Adapter RAM 512
Adapter Drivers nvd3dumx,nvd3dum
Driver Version 8.17.12.6705
Driver Date 2-10-2011
Direct2D Enabled false
DirectWrite Enabled false (6.1.7600.16699, font cache n/a)
WebGL Renderer NVIDIA Corporation -- Quadro FX 4500/PCI/SSE2 -- 2.1.2
GPU Accelerated Windows 0/1
Please stop using the Windows 64 version of Firefox 4. We have no plans to fix this bug prior to Firefox 4's release.

You can get the Windows 32 version of Firefox at http://nightly.mozilla.org. Windows 32 is the only supported version of Firefox on Windows.

Comment 83

7 years ago
(In reply to comment #82)
> Please stop using the Windows 64 version of Firefox 4. We have no plans to fix
> this bug prior to Firefox 4's release.
> 
> You can get the Windows 32 version of Firefox at http://nightly.mozilla.org.
> Windows 32 is the only supported version of Firefox on Windows.

Bummer. Any possible idea of when will be released? Date range, quarter, year, anything? the 64 bit version feels like its literally 300% faster
(In reply to comment #81)
> GPU Accelerated Windows 0/1
>Setting gfx.direct2d.force-enabled = true makes it even worse 

Firstly, you didn't use hardware acceleration.
Secondly, read Whiteboard.
Thirdly, forcing something that isn't enabled by default and whining next to fix it, isn't a wise choice.



(In reply to comment #83)

Stop bumping this guys, it will not help with fixing this bug. We already got all needed info.
64bit version of Firefox 4 is NOT SUPPORTED. So right now, all programming power are directed to shipping 32bit.
Firefox 5 will officially support 64 bit it according to https://wiki.mozilla.org/Firefox/Roadmap#Firefox_5
Whiteboard: Do not post in this bug. Use the Windows 32-bit build of Firefox 4. → DO NOT POST in this bug. Use the Windows 32-bit build of Firefox 4.

Comment 85

7 years ago
(In reply to comment #84)
> (In reply to comment #81)
> > GPU Accelerated Windows 0/1
> >Setting gfx.direct2d.force-enabled = true makes it even worse 
> 
> Firstly, you didn't use hardware acceleration.
> Secondly, read Whiteboard.
> Thirdly, forcing something that isn't enabled by default and whining next to
> fix it, isn't a wise choice.
it is a shame that you just shout,
but here are some pics : 
1. GPU Accelerated Windows 2/2 Direct3D 9 
   http://img87.imageshack.us/i/screenshotya.png/
2. gfx.direct2d.force-enabled = true
   http://img87.imageshack.us/i/screenshottu.png/
   sorry for the black lines, but this is what I see when I start firefox when  
   gfx.direct2d.force-enabled = true

and ok ... I will uninstall FF4 64bit !!!

Comment 86

7 years ago
Do (In reply to comment #71)
> reverting to 4.0b11pre resolved this issue for me.

Where can I download this old version to revert back? Can't find it anywhere.. not even here:

ftp://ftp.mozilla.org/pub/firefox/releases/4.0b11/

Comment 87

7 years ago
(In reply to comment #82)
> Please stop using the Windows 64 version of Firefox 4. We have no plans to fix
> this bug prior to Firefox 4's release.
> 
> You can get the Windows 32 version of Firefox at http://nightly.mozilla.org.
> Windows 32 is the only supported version of Firefox on Windows.

"Just avoid using it in that way"

sorry, couldn't resist :D

Comment 88

7 years ago
(In reply to comment #82)
> Please stop using the Windows 64 version of Firefox 4. We have no plans to fix
> this bug prior to Firefox 4's release.
> 
> You can get the Windows 32 version of Firefox at http://nightly.mozilla.org.
> Windows 32 is the only supported version of Firefox on Windows.

People, do not use cars. Buy a bike!!!

Comment 89

7 years ago
As for the flash plugin update, Is it possible to have an alert when firefox detect a major driver update required by firefox ?

Example for this about:support message : "Direct2D Enabled: Blocked on your graphics driver. Try updating your graphics driver to version 10.6 or newer."
It may help the user to have this message on application startup, in addition of the about:support.

Comment 90

7 years ago
(In reply to comment #86)
> Where can I download this old version to revert back? Can't find it anywhere..
> not even here:

Seems 4.0b12pre is the latest version unaffected with this bug.
You can get it here:
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2011-02-12-03-mozilla-central/

Comment 91

7 years ago
(In reply to comment #90)
> (In reply to comment #86)
> > Where can I download this old version to revert back? Can't find it anywhere..
> > not even here:
> 
> Seems 4.0b12pre is the latest version unaffected with this bug.
> You can get it here:
> http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2011-02-12-03-mozilla-central/

The latest version unaffected is actually on February 18 (well, six days better than February 12 that Dmitry suggests... yeah, big deal...), here it is:

https://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2011-02-18-03-mozilla-central/

Sounds like this is a 64-bit only issue, and 64-bit support isn't in the roadmap for FireFox 4 (but rather FireFox 5), so after I get tired of the February 18th nightly, I'll likely uninstall 64-bit FireFox 4 and get the latest 32-bit nightly.

Updated

7 years ago
Duplicate of this bug: 638632

Comment 93

7 years ago
> 
> The latest version unaffected is actually on February 18 (well, six days better
> than February 12 that Dmitry suggests... yeah, big deal...), here it is:
> 
> https://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2011-02-18-03-mozilla-central/
> 
> Sounds like this is a 64-bit only issue, and 64-bit support isn't in the
> roadmap for FireFox 4 (but rather FireFox 5), so after I get tired of the
> February 18th nightly, I'll likely uninstall 64-bit FireFox 4 and get the
> latest 32-bit nightly.

You think the 32-bit version will match the speed of the 64-bit version? I am still in awe of its performance. I will be using the 2-18 build for a long time
Duplicate of this bug: 638744
(Assignee)

Comment 95

7 years ago
Maybe, this is PGO bug.  Althougth we don't have try server for win64 build, this may be able to fix by turned off PGO for libpixman.
Assignee: nobody → m_kato
(Assignee)

Comment 96

7 years ago
Created attachment 517354 [details] [diff] [review]
fix

I am testing this on my local env.
(Assignee)

Updated

7 years ago
Attachment #517354 - Flags: review?(jmuizelaar)
Duplicate of this bug: 639517

Comment 98

7 years ago
Nope. I am on 64Bit Windows with an Intel GMA X3100 and I see the problem with or without that box being checked. No sign of it in normal Firefox or anywhere else.

- 2 Bunny
(In reply to comment #96)
> Created attachment 517354 [details] [diff] [review]
> fix
> 
> I am testing this on my local env.

Can you find the code that is miscompiled? I'd like to be sure that we're not just hiding a bug in pixman.

Comment 100

7 years ago
Forcing Direct2D on fixes the issue partially (Using gfx.direct2d.force-enabled set to True) however the issue occurs on graphical updates. (New items being displayed for example, show flawlessly. When these items are updated from a page load or hover, they regain the sawtooth artifacts). Additionally, it seems that Direct2D initializes before the font rendering engine (With or without DirectWrite) - all text loads as a black box on start until queued for update. I sense corrupted memory or pointers.

This is on 13pre, GeForce 7600 GS.
(Assignee)

Comment 101

7 years ago
(In reply to comment #99)
> (In reply to comment #96)
> > Created attachment 517354 [details] [diff] [review]
> > fix
> > 
> > I am testing this on my local env.
> 
> Can you find the code that is miscompiled? I'd like to be sure that we're not
> just hiding a bug in pixman.

This is into pixman-x64-mmx-emulation.h.  Since x64 compiler doesn't support MMX instruction, pixman uses emulation code for MMX that is used by unaligned copy and composition.  Aligned copy and composition using SSE2 seem to be correct even if PGO.

I think that this issue is PGO bug of VC9 (and VC10).  Because non-PGO build can generate correct code.

Also, although I don't test yet, this may be fixed by bug 640250 (or patch series of http://lists.freedesktop.org/archives/pixman/2011-February/001037.html).
Does the patch on bug 640250 fix the problem?
(Assignee)

Comment 103

7 years ago
(In reply to comment #102)
> Does the patch on bug 640250 fix the problem?

Maybe... I will test it at this week.
(Assignee)

Comment 104

7 years ago
(In reply to comment #102)
> Does the patch on bug 640250 fix the problem?

This problem is fixed by it.  I verified it today.

Comment 105

7 years ago
how do we apply this patch?

Comment 107

7 years ago
(In reply to comment #104)
> (In reply to comment #102)
> > Does the patch on bug 640250 fix the problem?
> 
> This problem is fixed by it.  I verified it today.

Can you put your fixed version on a file sharing site so we all can try it out instead of us having to try and patch it are self? It's to complicated for me to do it myself.

Comment 108

7 years ago
(In reply to comment #107)
> (In reply to comment #104)
> > (In reply to comment #102)
> > > Does the patch on bug 640250 fix the problem?
> > 
> > This problem is fixed by it.  I verified it today.
> 
> Can you put your fixed version on a file sharing site so we all can try it out
> instead of us having to try and patch it are self? It's to complicated for me
> to do it myself.

Suppose we'll be using the 2-18 build for awhile.
Please read the whiteboard: Do not post in this bug. Use the windows 32-bit version of Firefox. Use the February 18th build. Force on acceleration. Whatever you do, do not post in this bug.
Comment on attachment 517354 [details] [diff] [review]
fix

Seems like pixman update is a better option here.
Attachment #517354 - Flags: review?(jmuizelaar) → review-
(Assignee)

Updated

7 years ago
Depends on: 640250
Duplicate of this bug: 642610

Updated

7 years ago
Duplicate of this bug: 644942

Comment 113

7 years ago
I am on Win7 x64 with A GeForce GT 240M and yes I use the x64 build + I read the whiteboard too. I just need to add some potentially useful info here for the others faced with this. Besides, I don't quite agree with the DON'T-POST-HERE policy anyways, so...

I come from bug 644932. I needed to disable HW acceleration in order to get rid of the artifacts caused by that bug, but then I got hit by the artifacts reported here. I noticed that after disabling the HW acceleration -through the UI- both gfx.direct2d.force-enabled and gfx.direct2d.disabled were set to true(?) at the same time. Keeping the HW acceleration off got rid of the artifacts reported in bug 644932 and manually setting gfx.direct2d.disabled back to false got rid the artifacts reported here.

So, please check if you still get the artifacts after setting gfx.direct2d.disabled to false. Remember to report back with your results.

PS: bug 644932 was a temporary regression that got fixed within the day with the very next build, so no need to disable HW acceleration anymore -unless you have other reasons to do so-.
(In reply to comment #113)
> PS: bug 644932 was a temporary regression that got fixed within the day with
> the very next build, so no need to disable HW acceleration anymore -unless you
> have other reasons to do so-.

The main issue for people disabling hardware acceleration is blurriness of the fonts when HW Acc is enabled.
Duplicate of this bug: 645378
This should be fixed now. Can someone confirm?
(Assignee)

Comment 117

7 years ago
(In reply to comment #116)
> This should be fixed now. Can someone confirm?

Unfortunately, tindebox won't be able to build PGOed nightly for win64 until fixing bug 636296.  We should keep open until nightly is available.

Also, I can verify it on local build...

Updated

7 years ago
Summary: [HW Accel disabled] [Win64] Rendering of Menu bar and webpages with severe artifacts → [HW Accel disabled] [Win64] Rendering of Menu bar and webpages with severe artifacts (black border toolbar button)

Updated

7 years ago
Duplicate of this bug: 647963

Updated

7 years ago
Duplicate of this bug: 649305
(Assignee)

Comment 120

7 years ago
verified nightly 2011-04-12
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
Status: RESOLVED → VERIFIED
blocking2.0: - → ---
Whiteboard: DO NOT POST in this bug. Use the Windows 32-bit build of Firefox 4.
You need to log in before you can comment on or make changes to this bug.