The default bug view has changed. See this FAQ.

Use native rendering for indeterminate progress bar (Cocoa)

RESOLVED FIXED in mozilla6

Status

()

Core
Widget: Cocoa
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: mounir, Assigned: mounir)

Tracking

Trunk
mozilla6
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Assignee)

Description

6 years ago
The widget is ready for that but it would required looking at the content states. Should be easy.
(Assignee)

Comment 1

6 years ago
Created attachment 512730 [details] [diff] [review]
Patch v1
Assignee: nobody → mounir.lamouri
Status: NEW → ASSIGNED
Attachment #512730 - Flags: review?(mstange)
(Assignee)

Updated

6 years ago
Depends on: 633913
(Assignee)

Updated

6 years ago
Whiteboard: [needs review]
Comment on attachment 512730 [details] [diff] [review]
Patch v1

Looks good, but please request another review from roc because I'm not a peer for the xpwidgets code.

One thing: I'm not sure whether you should bother with the content null check since we mostly skip it in the rest of the file. The only cases when I've seen frames with null content was during frame destruction and when the frame is an nsViewportFrame, and none of those cases can be hit in native theme drawing as far as I know.
Attachment #512730 - Flags: review?(mstange) → review+
(Assignee)

Comment 3

6 years ago
Created attachment 512748 [details] [diff] [review]
Patch v1.1

r=mstange
Attachment #512730 - Attachment is obsolete: true
Attachment #512748 - Flags: review?(roc)
(Assignee)

Comment 4

6 years ago
Created attachment 513140 [details] [diff] [review]
Patch v1.2

I realized I should use nsWidgetAtoms intsead of nsGkAtoms.
Attachment #512748 - Attachment is obsolete: true
Attachment #513140 - Flags: review?(roc)
Attachment #512748 - Flags: review?(roc)
(Assignee)

Updated

6 years ago
Blocks: 634086
Attachment #513140 - Flags: review?(roc) → review+
(Assignee)

Updated

6 years ago
Whiteboard: [needs review] → [ready to land][waits for dependencies]
(Assignee)

Comment 5

6 years ago
Pushed:
http://hg.mozilla.org/mozilla-central/rev/00d5a081d5d3
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Whiteboard: [ready to land][waits for dependencies]
Target Milestone: --- → mozilla6

Updated

6 years ago
Depends on: 655860
Backed out in http://hg.mozilla.org/mozilla-central/rev/dd9ba28d2bd9 to resolve bug 655860.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 7

6 years ago
The regression wasn't caused by these patches. Re-landed:
http://hg.mozilla.org/mozilla-central/rev/9e265e80c3ff
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
(Assignee)

Updated

6 years ago
No longer depends on: 655860
You need to log in before you can comment on or make changes to this bug.