The resizer is displayed in the wrong position on orphan tabs

VERIFIED FIXED in Firefox 4.0b12

Status

defect
P2
normal
VERIFIED FIXED
8 years ago
3 years ago

People

(Reporter: raymondlee, Assigned: ttaubert)

Tracking

({regression})

Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 2 obsolete attachments)

(Reporter)

Description

8 years ago
It happens in the latest trunk.

Steps to reproduce
1. Drag a tab item from a group to an empty space to create an orphan tabs

Expected result:
The resizer appears at the bottom right of the orphan tab

Actual result:
The resizer appears at the top right of the orphan tab
(Reporter)

Comment 1

8 years ago
Posted image Screenshot
(Assignee)

Updated

8 years ago
Assignee: nobody → tim.taubert
Status: NEW → ASSIGNED
OS: Mac OS X → All
Hardware: x86 → All
Posted patch patch v1 (obsolete) — Splinter Review
Do we need a test for this?
Attachment #512410 - Flags: review?(ian)
(Assignee)

Updated

8 years ago
Duplicate of this bug: 634271
Comment on attachment 512410 [details] [diff] [review]
patch v1

Seems like a test would be pretty straight-forward: create an orphan and check the location of its resizer. Might as well give it a shot.

Otherwise looks good.
Attachment #512410 - Flags: review?(ian) → review-
Posted patch patch v2 (with test) (obsolete) — Splinter Review
Attachment #512410 - Attachment is obsolete: true
Attachment #512611 - Flags: review?(ian)
Comment on attachment 512611 [details] [diff] [review]
patch v2 (with test)

Beautiful!

Nice use of registerCleanupFunction, by the way. Another thing to consider (for next time) is to add one last registerCleanupFunction right before the finish() that verifies the ending state.
Attachment #512611 - Flags: review?(ian) → review+
(Assignee)

Updated

8 years ago
Attachment #512611 - Flags: approval2.0?
Comment on attachment 512611 [details] [diff] [review]
patch v2 (with test)

a=beltzner
Attachment #512611 - Flags: approval2.0? → approval2.0+
Attachment #512611 - Attachment is obsolete: true
(Assignee)

Updated

8 years ago
Keywords: checkin-needed
http://hg.mozilla.org/mozilla-central/rev/8bad52b42fc1
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → Firefox 4.0b12
verified with minefield build of 20110217
Status: RESOLVED → VERIFIED
Looks like this has landed; removing the "checkin-needed" keyword
Keywords: checkin-needed
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.