The add-ons manager opens in the background if browser.tabs.loadBookmarksInBackground is true

RESOLVED FIXED in Firefox 10

Status

()

Firefox
General
RESOLVED FIXED
7 years ago
6 years ago

People

(Reporter: mossop, Assigned: dao)

Tracking

Trunk
Firefox 10
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Previously the add-ons manager would open in the foreground but now it opens in the background for me. Guessing this is a change from bug 593687.

Was it intentional? Seems wrong to me.
(Reporter)

Comment 1

7 years ago
Maybe the setting has nothing to do with it, seems to always open in the background for me.
(Assignee)

Comment 2

7 years ago
The pref controlling this is browser.tabs.loadBookmarksInBackground.

Bug 610203 adds an inBackground parameter that switchToTabHavingURI could use to override the pref.
Depends on: 610203
(Reporter)

Comment 3

7 years ago
Seems a little wrong but a non-default setting so not worth much time right now I guess
Summary: The add-ons manager opens in the background if "when I open a link in a new tab switch to it immediately" is unchecked → The add-ons manager opens in the background if browser.tabs.loadBookmarksInBackground is true

Updated

6 years ago
Duplicate of this bug: 690640
(Assignee)

Comment 5

6 years ago
Created attachment 565525 [details] [diff] [review]
patch
Assignee: nobody → dao
Status: NEW → ASSIGNED
Attachment #565525 - Flags: review?(gavin.sharp)
(Assignee)

Updated

6 years ago
Component: Add-ons Manager → General
Product: Toolkit → Firefox
QA Contact: add-ons.manager → general
Attachment #565525 - Flags: review?(gavin.sharp) → review+
(Assignee)

Comment 6

6 years ago
http://hg.mozilla.org/integration/mozilla-inbound/rev/be16a71b5ab4
Target Milestone: --- → Firefox 10
https://hg.mozilla.org/mozilla-central/rev/be16a71b5ab4
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.