If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Problem with drop down menus on Nike and also on other sites

VERIFIED FIXED

Status

()

Core
Plug-ins
--
major
VERIFIED FIXED
7 years ago
7 years ago

People

(Reporter: orangezilla, Unassigned)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(blocking2.0 -)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b12pre) Gecko/20110215 Firefox/4.0b12pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b12pre) Gecko/20110215 Firefox/4.0b12pre

When hovering over horizontal down menus at Nike, they eventually break, flipping over to the right or left, see attachments.

Reproducible: Always

Steps to Reproduce:
1. Go to http://www.nike.com/nikeos/p/nikegolf/en_US/ mouse over products menu on left, breaks, flips to right.
2. Go to main Nike site http://www.nike.com/nikeos/p/nike/en_US/?&ref= mouse over more, duplicate pops up on left, mouse over Nike swish logo to remove
3. Go to http://nikerunning.nike.com/nikeos/p/nikeplus/en_US/commerce/men mouse over Nike swish logo, it duplicates to right, when move mouse away duplicate disappears
Actual Results:  
Menus break partially or fully

Expected Results:  
Menus should work as in other browsers

This first broke partially between 10th-11th November 8Pre builds when moving the mouse pointer on the golf page from athletes up to vision menu flips the menu to the center of the page 

http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=df1d1ff6b489&tochange=0f17e5f1eb01

this is probably connected to the same pushlog for text breaking on drop down menus on ESPN & Gamespy when overlapping Flash ads/videos (unresolved)
https://bugzilla.mozilla.org/show_bug.cgi?id=632423#c10

All of these problems then broke further after the 31st December, with the Nike Golf menu flipping if you mouseover anywhere on the menu, and at the same time ESPN and Gamespy text on drop down menus overlapping Flash changed to greyscale AA, probably the same pushlog applies for this change
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=b083bc8b79ab&tochange=f9f48079910f

(unable to narrow down on this change as can't get debug builds to work on my system)
(Reporter)

Comment 1

7 years ago
Created attachment 512572 [details]
Nike Golf Menu 11th Nov 8Pre jumps to right
(Reporter)

Comment 2

7 years ago
Created attachment 512573 [details]
Nike homepage menu 11th Nov 8Pre jumps to left
(Reporter)

Updated

7 years ago
Version: unspecified → Trunk
I can confirm this, additional info is this also happens without D2D. I doubt this belongs in Gfx.
(Reporter)

Comment 4

7 years ago
Yes, the Nike problems occurs with hardware acceleration on or off, ESPN & Gamespy issues occur only if hardware acceleration is off, all platforms seem to be affected by the Nike issue
http://input.mozilla.com/en-US/beta/search?q=nike&product=firefox&version=&date_start=&date_end=
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

7 years ago
That Nike site has 343 Errors, 157 warning(s) when run through the HTML W3C validator. Hard to tell what exactly is going on.
(Reporter)

Comment 6

7 years ago
It works on all stable releases of other browsers though, IE8, Opera 11, Chrome/Iron 9. IE9 RC does have trouble with it though it also had other bugs in common with FF4 that have now been fixed in FF i.e. https://bugzilla.mozilla.org/show_bug.cgi?id=630159
blocking2.0: --- → ?

Comment 7

7 years ago
orangezilla@yahoo.com said, It works on all stable releases of other browsers though, IE8, Opera 11,
Chrome/Iron 9.

Occasionally even a blind squirrel finds a nut.

Comment 8

7 years ago
Mozilla/5.0 (Windows NT 6.1; rv:2.0b12pre) Gecko/20110215 Firefox/4.0b12pre ID:20110215030353

that menus are Flash, and seems to be fine with OOPP disabled here.
Flash 10.2.152.26
(Reporter)

Updated

7 years ago
blocking2.0: ? → ---
Keywords: regression
blocking2.0: --- → ?
--> Core::Plug-Ins as per comment 8
Component: Graphics → Plug-ins
QA Contact: thebes → plugins

Comment 10

7 years ago
ESPN/gamespy is a different bug, already blocking. I don't think the remaining nike bug here (which I only see on Windows) is a blocker, and may be just a bug in the Flash .swf, it's very hard to tell.
blocking2.0: ? → -

Comment 11

7 years ago
Oh, I see the Nike thing on Linux too, but not Mac.
(Reporter)

Comment 12

7 years ago
I confirm the Nike problems as well as the ESPN/Gamespy Arena issues do not occur with plugin container disabled.
blocking2.0: - → ?

Comment 13

7 years ago
I see it on Mac OSX 10.6.6

Updated

7 years ago
blocking2.0: ? → -
(Reporter)

Comment 14

7 years ago
(In reply to comment #11)
> Oh, I see the Nike thing on Linux too, but not Mac.
Feedback seems broken ATM but sure I saw complaints on OSX, could be older though.

http://input.mozilla.com/en-US/beta/search?q=nike&product=firefox&version=&date_start=&date_end(In reply to comment #10)

> ESPN/gamespy is a different bug, already blocking.
Is it, not listed as blocking on the page?
https://bugzilla.mozilla.org/show_bug.cgi?id=632423
(Reporter)

Comment 15

7 years ago
(In reply to comment #13)
> I see it on Mac OSX 10.6.6

Selecting all on the input dashboard seems to be broken, but selecting beta 8 shows two Mac OSX feedback complaints for Jan 5th as well as Robert's above

http://input.mozilla.com/en-US/beta/search?q=nike&product=firefox&version=4.0b8&date_start=&date_end=
(Reporter)

Comment 16

7 years ago
Seems like either Nike has fixed this or it has been fixed this side, can anyone confirm?

Comment 17

7 years ago
(In reply to comment #16)
> Seems like either Nike has fixed this or it has been fixed this side, can
> anyone confirm?

Still screwed up for me using FF4b12 on OSX 10.6.6
(Reporter)

Comment 18

7 years ago
(In reply to comment #17)
> (In reply to comment #16)
> > Seems like either Nike has fixed this or it has been fixed this side, can
> > anyone confirm?
> 
> Still screwed up for me using FF4b12 on OSX 10.6.6
Yeah it's broken in the Beta, but using the latest nightly all links at the top work

Mozilla/5.0 (Windows NT 6.1; rv:2.0b13pre) Gecko/20110227 Firefox/4.0b13pre
20110227030400
(Reporter)

Comment 19

7 years ago
Seems to have been fixed by bug 631388 and/or bug 634844, marking as resolved

thanks to Keldorn
http://forums.mozillazine.org/viewtopic.php?f=23&t=2116361&p=10474673#p10474673
(Reporter)

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Verified fixed with Mozilla/5.0 (Windows NT 6.1; rv:2.0b13pre) Gecko/20110303 Firefox/4.0b13pre
Status: RESOLVED → VERIFIED

Comment 21

7 years ago
Created attachment 517726 [details]
Shows problem on FF4 rc build1

OK. However this is NOT FIXED on FF4rc candidate build1 on OSX. The side menus still jump down and are unusable when trying to access on this site

http://www.nike.com/nikeos/p/nikegolf/en_US/

I will attach a screenshot file Nike_demo_rc1.png

Comment 22

7 years ago
The patches from comment 19 only affect Linux/Windows. Mac uses an entirely different codepath, and if you see a bug it's different from the one that was originally filed here and deserves a new report.

Comment 23

7 years ago
(In reply to comment #22)
> The patches from comment 19 only affect Linux/Windows. Mac uses an entirely
> different codepath, and if you see a bug it's different from the one that was
> originally filed here and deserves a new report.

Sorry. It says all platforms. Will file a report.
You need to log in before you can comment on or make changes to this bug.