[Windows SeaMonkey (and Firefox)] reftest: permanent "TEST-UNEXPECTED-PASS | file:///e:/builds/slave/test/build/reftest/tests/layout/reftests/bugs/632781-verybig.html | image comparison (==)" after bug 632781

VERIFIED FIXED

Status

()

Core
Graphics
--
major
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: sgautherie, Assigned: bz)

Tracking

(Blocks: 1 bug)

Trunk
x86
Windows Server 2003
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fixed by bug 649924] [perma-orange])

(Reporter)

Description

6 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1297823917.1297826844.11829.gz
WINNT 5.2 comm-central-trunk debug test reftest on 2011/02/15 18:38:37
{
REFTEST TEST-UNEXPECTED-PASS | file:///e:/builds/slave/test/build/reftest/tests/layout/reftests/bugs/632781-verybig.html | image comparison (==)
}

Regression timeframe:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=796db5299d3d&tochange=eeb1dd9e7028
"Disable the test for bug 632781 for all Windows platforms because apparently layersGPUAccelerated is not what we expect it to be on Windows XP"

NB: Yet another (graphics) bug due to Firefox and SeaMonkey test builders differences not accounted for...
So, do the SeaMonkey tinderbox machine have hw accel enabled or disabled?
(Reporter)

Comment 2

6 years ago
(In reply to comment #1)
> do the SeaMonkey tinderbox machine have hw accel enabled or disabled?

Windows (at least) SeaMonkey boxes don't have acceleration atm: see bug 628589.
Depends on: 628589
(Reporter)

Comment 3

6 years ago
By chance, I noticed that Firefox (silently) has this bug too:

http://tbpl.mozilla.org/?tree=MozillaTry&rev=e6d22b368e6b&noignore=1
http://tinderbox.mozilla.org/showlog.cgi?log=MozillaTry/1302805827.1302808177.5132.gz
Rev3 WINNT 6.1 tryserver opt test reftest-no-accel on 2011/04/14 11:30:27
{
...
REFTEST TEST-UNEXPECTED-PASS | file:///c:/talos-slave/test/build/reftest/tests/layout/reftests/bugs/632781-verybig.html | image comparison (==)
...
reftest-no-d2d-d3d: 5866/13/248
}

Could the test conditions be fixed or the test be disabled until it fully succeeds?
status2.0: --- → ?
Summary: [Windows SeaMonkey] reftest: permanent "TEST-UNEXPECTED-PASS | file:///e:/builds/slave/test/build/reftest/tests/layout/reftests/bugs/632781-verybig.html | image comparison (==)" after bug 632781 → [Windows SeaMonkey (and Firefox)] reftest: permanent "TEST-UNEXPECTED-PASS | file:///e:/builds/slave/test/build/reftest/tests/layout/reftests/bugs/632781-verybig.html | image comparison (==)" after bug 632781
The graphics team should get back to you on how best to address this issue.  I don't know a lot about this code.
reftest-no-d2d-d3d is a different test machine with all acceleration disabled, aka "the same as seamonkey."

You could disable the test for now, or investigate why layersGPUAccelerated is not set correctly on Windows XP.

Updated

6 years ago
Blocks: 633047
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Reporter)

Updated

6 years ago
Blocks: 653481
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
You can't be having an unexpected-pass anymore, since it's no longer fails-if(winWidget).
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 13

6 years ago
(In reply to TinderboxPushlog Robot from comment #10)
> bill%wg9s.com
> REFTEST TEST-UNEXPECTED-FAIL |

(In reply to TinderboxPushlog Robot from comment #11)
> bill%wg9s.com
> REFTEST TEST-UNEXPECTED-FAIL |

These two 'TEST-UNEXPECTED-FAIL' are not this bug.

***

(In reply to Phil Ringnalda (:philor) from comment #12)
> You can't be having an unexpected-pass anymore, since it's no longer
> fails-if(winWidget).

http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1320872427.1320878140.4178.gz&fulltext=1
WINNT 5.2 comm-central-trunk debug test reftest on 2011/11/09 13:00:27
{
REFTEST TEST-PASS | file:///e:/builds/slave/test/build/reftest/tests/layout/reftests/bugs/632781-verybig.html | image comparison (==)
}

V.Fixed, by bug 649924:
http://hg.mozilla.org/mozilla-central/rev/cd7a7ad30fca
Assignee: nobody → bzbarsky
Status: RESOLVED → VERIFIED
status2.0: ? → ---
Depends on: 649924
Flags: in-testsuite-
Resolution: WORKSFORME → FIXED
Whiteboard: [perma-orange] → [fixed by bug 649924] [perma-orange]
(Reporter)

Updated

6 years ago
No longer blocks: 653481
You need to log in before you can comment on or make changes to this bug.