Closed Bug 634895 Opened 9 years ago Closed 7 years ago

Memory usage increases after each time the computer wakes up from hibernation (sleep)

Categories

(Firefox :: General, defect)

4.0 Branch
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: rakshithbekal, Unassigned)

References

Details

(Keywords: memory-leak, Whiteboard: [MemShrink:P2])

User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b12pre) Gecko/20110216 Firefox/4.0b12pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b12pre) Gecko/20110216 Firefox/4.0b12pre

Keeping firefox open For a long time and hibernating/sleeping windows causes firefox to use a lot of memory and hangs due to more memory consumption.
After Logging into windows and clicking on the already opened firefox, It takes a few seconds to stabilize and navigating across opened tabs takes more time and results in hangs more often until after a few minutes when It adjusts resulting in a higher memory consumption than the originally opened firefox at the beginning.

Reproducible: Always

Steps to Reproduce:
1.Keep firefox open for a long time with atleast more than 5 tabs
2.note the memory taken by it
3.after a long usage hibernate It
4.Open It again after a while 
5.Check the memory increased memory consumption
6.and experience frequent hangs
Actual Results:  
hangs and high memory usage

Expected Results:  
smoothly and in a stabilized way

I thing running everything as different process gets the job done
I see the same on OS X. Also I got a couple of reports of other users on OS X who are affected by the same issue. I haven't seen it before with Firefox 3.6. On my new MBP Firefox consumes now nearly 800MB with a couple of tabs open. The memory increases each time I wake up the box in the morning. When I'm back at home by end of next week I can do some more testing with my old MBP.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 7 → All
Hardware: x86 → All
Summary: Keeping firefox open For a long time and hibernating/sleeping windows causes firefox to use a lot of memory and hangs due to more memory consumption → Huge memory usage after a while when using hibernation (sleep)
Version: unspecified → 4.0 Branch
Yes, I've noticed hangs with Firefox 4 and conflicts with another large program along with the FF 4/OS X menu freezing bug. Force Quiting has become necessary. Since I have a new machine, I was thinking the other program required a update, but actually Firefox 4 is more recent issue.

The FF 4 menu freezing bug I had has not reappeared since the re-install of Status-4-Evar add-on. 

Other OS X users with less RAM and integrated graphics machines on the Apple Forums report slowdowns and beach ball effects with FF 4. For me it only occurs if I use a lot of my memory with other large memory use programs.

If I reinstall Firefox, will the add-ons, persona and setup remain?

Will it fix the memory issue? Thanks
I went ahead and reinstalled FF 4 over the previous one. Lets see if that resolves the issue now.
Summary: Huge memory usage after a while when using hibernation (sleep) → Memory usage increases after each time the computer wakes up from hibernation (sleep)
Keywords: mlk
No longer blocks: mlk-fx5+
This report does not have enough details to be acted upon usefully.  I'm marking it as a duplicate of bug 659855, which is the tracking bug for all memory leaks in Firefox 4 betas.

Also, Firefox 5 has better memory behaviour than Firefox 4 (http://blog.mozilla.com/nnethercote/2011/05/25/firefox-5-has-fewer-leaks-than-firefox-4/), so you might like to try it.  You can get a beta version of Firefox 5 from http://beta.mozilla.org.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: mlk-fx4-beta
Thanks Nicholas, on 5b now.
hunt, does the memory usage seem better?
FWIW, it sounds like bug 656120 might fix these problems.  If anyone still sees the problem, trying a Nightly build (from nightly.mozilla.org) may give better results.
I haven't had time to check it in the last couple of weeks. I will try to reproduce or verify by next week.
So this is still not fixed for me. I do not see a big improvement to previous releases of Firefox over time. The memory is always increasing each time my machine wakes up from hibernation. Probably I should log details from about:memory before putting the machine into sleep and once again after wakeup. But before I wanna do this let me ask a question. What is the 'heap-unclassified' entry?

938.57 MB (100.0%) -- explicit
├──480.03 MB (51.15%) -- heap-unclassified
├──317.96 MB (33.88%) -- js

It uses half of the memory allocated by Firefox. Is there anything method to get more information about such memory?
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
I can confirm this running 5b on Win7x64. 
Another observation is rapid memory growth on slow and unstable (UMTS) connections.
>  What is the 'heap-unclassified' entry?

Heap memory that isn't covered by any of the memory reporters.  We're actively working on reducing it;  see bug 563700.
Whiteboard: [MemShrink]
Nicholas, so what could I do to get more information about what's going on? All other memory values look fairly ok to me except the unclassified one. Any other chance to get more details?
Status: REOPENED → NEW
(In reply to Henrik Skupin (:whimboo) from comment #12)
> Nicholas, so what could I do to get more information about what's going on?
> All other memory values look fairly ok to me except the unclassified one.

How is it not ok -- is "heap-unclassified" increasing?

> Any other chance to get more details?

Not really, sorry.  We're improving the coverage gradually but it'll take a while.
Whiteboard: [MemShrink] → [MemShrink:P2]
Henrik: I assume you're still on OS X.  What version of Firefox are you using?  If it's FF6 or earlier there's a good chance that FF7 will fix it.
It's 7.0a2 (2011-08-08). So I doubt that any improvements which went into 7.0 yet, have fixed it.
Hi,

I'm experiencing the same problem. Heap-unclassified is increasing constantly. For example, 5 minutes after I started firefox (7.0.1 on a ubuntu 11.04), here are the memory values :

564.56 MB (100.0%) -- explicit
├──539.24 MB (95.52%) -- heap-unclassified
├───21.37 MB (03.79%) -- js
│   ├───9.03 MB (01.60%) -- compartment([System Principal])
│   │   ├──4.89 MB (00.87%) -- (7 omitted)
│   │   └──4.14 MB (00.73%) -- gc-heap
│   │      └──4.14 MB (00.73%) -- (7 omitted)
│   ├───8.00 MB (01.42%) -- stack
│   ├───3.33 MB (00.59%) -- gc-heap-chunk-unused
│   └───1.01 MB (00.18%) -- (3 omitted)
└────3.94 MB (00.70%) -- (4 omitted)

Without any tab opened and without any add-on.

Does anybody find the problem or a fix around to avoid this issue ?

Thx
What do you mean by "5 minutes after starting Firefox"?  Is this a new session?  Are you restoring the Firefox session after hibernation?  From your description, I don't see how this relates to the original bug, though it does sound like some kind of bug.

Can you reproduce this?  That is a huge amount of heap-unclassified.
Thanks for your interest,

After starting firefox, in both case new session or restoring session.

Maybe This issue is not exactly the same that the one discussed in this thread but it's related to a big memory consumption.

It was reproducable, each time I started firefox. So reproducable that I decided to completely remove firefox and reinstall it. Now I don't experience this issue any more...

Charles.
Okay, well, in the future you should file a new bug for a new issue.  For memory-related issues, put [MemShrink] in the white board.  Anyways, at this point, there's probably no need to file a new issue, as the problem went away, and there isn't really enough information to go on.  Thanks for the report, though.
It's not getting better here. Today I have Aurora using 1,152.13 MB (100.0%) -- explicit and 443.92 MB (38.53%) -- heap-unclassified.
Whimboo, do you still see this?
Actually I haven't seen any memory increases based on hibernation mode lately while running Aurora builds. Even without sleep mode I always have about 1GB of memory use for a couple of tabs and extensions installed. But that is not related to this particular bug.
I'm going to be optimistic and close this, based on comment 22.  Please reopen if you still see memory increases after hibernation.
Status: NEW → RESOLVED
Closed: 9 years ago8 years ago
Resolution: --- → WORKSFORME
Is this really being considered resolved or has it been moved to another bug #?  I found it first with FF4 and still see it on 2 different Win XP SP3 PCs through v18.0.2.

I have FF running with multiple tabs open. Hibernate
On reboot there is heavy HDD activity and FF is VERY slow or unusable for several minutes until it stabilizes enough to use.  (It's usually easier to kill FF in the task manager then wait for it.)

The heavy HDD usage slows the whole system down.

Checking the memory usage (especially virtual memory), it is up 50% or more from what was used by FF before hibernation.

It's almost like FF isn't aware the pages are preloaded and caches them all again(?)

I've had to get in the habit of making sure FF is closed before hibernation.

Interestingly, FF seems to use virtual memory by about 3:2 over physical memory even though plenty of physical memory is available.
Do you have some numbers from before/after the hibernation? Something really useful would be the output of about:memory attached as text files to this bug.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
originaldrm ...

(In reply to Henrik Skupin (:whimboo) [away 03/15 - 03/22] from comment #25)
> Do you have some numbers from before/after the hibernation? Something really
> useful would be the output of about:memory attached as text files to this
> bug.
Flags: needinfo?(originaldrm)
Flags: needinfo?(originaldrm)
reclosing
Status: REOPENED → RESOLVED
Closed: 8 years ago7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.