revert experienced_first_use to experienced_first_run

VERIFIED FIXED

Status

defect
VERIFIED FIXED
8 years ago
3 years ago

People

(Reporter: ttaubert, Assigned: ttaubert)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Since bug 626791 landed the pref "experienced_first_use" determines whether the "switch to next group" shortcut is active and whether we show the "move to group" context menu items.

We should detect in TabView.init() if the user has tabs in multiple groups and set the value accordingly. Upgraders (including me) were confused because some functionality is gone.
(Assignee)

Updated

8 years ago
Assignee: nobody → tim.taubert
(Assignee)

Updated

8 years ago
Status: NEW → ASSIGNED
Or just keep calling the pref experienced_first_run, as suggested earlier.
(In reply to comment #1)
> Or just keep calling the pref experienced_first_run, as suggested earlier.

Would it be ok the rename the preference, only? Renaming the TabView property too would be consistent but is semantically incorrect as "TabView.firstRunExperienced = true" somewhere deep in the code is somewhat confusing.
Yep.
(Assignee)

Updated

8 years ago
Summary: set experienced_first_use for upgraders (beta/nightly users) → revert experienced_first_use to experienced_first_run
Posted patch patch v1 (obsolete) — Splinter Review
Attachment #513288 - Flags: review?(ian)
Comment on attachment 513288 [details] [diff] [review]
patch v1

Cool
Attachment #513288 - Flags: review?(ian) → review+
(Assignee)

Updated

8 years ago
Attachment #513288 - Flags: approval2.0?
Note to approvers:

An easy fix that will ensure beta/nightly upgraders that used panorama before will not lose their "move to group" context menu item or "switch to next group" shortcut.
Comment on attachment 513288 [details] [diff] [review]
patch v1

a=beltzner
Attachment #513288 - Flags: approval2.0? → approval2.0+
Attachment #513288 - Attachment is obsolete: true
(Assignee)

Updated

8 years ago
Keywords: checkin-needed
http://hg.mozilla.org/mozilla-central/rev/0f879ec8b3d2
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
(Assignee)

Updated

8 years ago
Duplicate of this bug: 637276

Comment 12

8 years ago
Verified with: Mozilla/5.0 (X11; Linux i686; rv:2.0) Gecko/20100101 Firefox/4.0
Status: RESOLVED → VERIFIED
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.