No warning when closing multiple tabs of a Tab Group

RESOLVED DUPLICATE of bug 521629

Status

Firefox Graveyard
Panorama
RESOLVED DUPLICATE of bug 521629
7 years ago
2 years ago

People

(Reporter: Gavin, Unassigned)

Tracking

Trunk
x86
Windows Vista

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.0; WOW64; rv:2.0b11) Gecko/20100101 Firefox/4.0b11
Build Identifier: Mozilla/5.0 (Windows NT 6.0; WOW64; rv:2.0b11) Gecko/20100101 Firefox/4.0b11

I use TabCandy in Firefox 4 Beta 11 to create 2 tab group, and each of them has multiple tabs.
Then I switch to a tab group, and then click the close button of Firefox's title bar to close all this tab group's tabs.
The "Warn me when closing multiple tabs" option has been checked. And this time, Firefox close all the tabs including another tab group's tabs which I do not switch to without any warning. In other word, Firefox end the whole firefox.exe process without any warning.

In fact, this bug also occurs when closing multiple tabs without any Tab Groups.

Sorry for my poor English.

Reproducible: Always

Steps to Reproduce:
1.Make sure the "Warn me when closing multiple tabs" option has been checked.
2.Create some Tab Group with multiple tabs.
3.Switch to a Tab Group.
4.Click the close button to close Firefox.
Actual Results:  
Firefox close all the Tab Groups' tabs without any warning.

Expected Results:  
Firefox should warn me and it should just close the current Tab Group's tabs.

Comment 1

7 years ago
I believe the intention was to avoid pestering the user with a confirm prompt, and instead offer undo functionality. See bug 587341.

(Also, correcting platform, since the field refers to the build of Minefield, not the OS)
Hardware: x86_64 → x86
Version: unspecified → Trunk

Comment 2

7 years ago
Ed's got it right. We don't want to give a dialog on an explicit action that is eminently recoverable from.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID

Comment 3

7 years ago
Wontfix rather than invalid?

Comment 4

7 years ago
(In reply to comment #3)
> Wontfix rather than invalid?

There's a guideline floating around somewhere that suggests that "invalid" means that the bug is invalid because it is by design. "wontfix" suggests that we know it's a bug, but aren't going to fix it for some reason.
(Reporter)

Comment 5

7 years ago
(In reply to comment #2)
> Ed's got it right. We don't want to give a dialog on an explicit action that is
> eminently recoverable from.

If I closed a Tab Group in TabCandy, I can undo this action, that's ok. But if I click the title bar's close button, Firefox close the whole prcocess without any warning despite the "Warn me when closing multiple tabs" option is checked.
That's a serious problem! I can't recover all the tabs! And sometimes, it may cause me lose data.
(Reporter)

Comment 6

7 years ago
Now I have found more details of this bug: Firefox 4 Beta 11 warns me only there are multiple Firefox Windows opened, not tabs. And if I closed all other windows leave one window, and then I close the final window, Firefox just close, no warning.

Comment 7

7 years ago
(In reply to comment #5)
> (In reply to comment #2)
> > Ed's got it right. We don't want to give a dialog on an explicit action that is
> > eminently recoverable from.
> 
> If I closed a Tab Group in TabCandy, I can undo this action, that's ok. But if
> I click the title bar's close button, Firefox close the whole prcocess without
> any warning despite the "Warn me when closing multiple tabs" option is checked.

So you are closing the entire Firefox window from the tabbed browser? And you can hit this behavior regardless of whether you are using tab groups?
(Reporter)

Comment 8

7 years ago
(In reply to comment #7)
> (In reply to comment #5)
> > (In reply to comment #2)
> > > Ed's got it right. We don't want to give a dialog on an explicit action that is
> > > eminently recoverable from.
> > 
> > If I closed a Tab Group in TabCandy, I can undo this action, that's ok. But if
> > I click the title bar's close button, Firefox close the whole prcocess without
> > any warning despite the "Warn me when closing multiple tabs" option is checked.
> 
> So you are closing the entire Firefox window from the tabbed browser? And you
> can hit this behavior regardless of whether you are using tab groups?

Exactly. If there only one Firefox window, no matter I'm using tab groups or just opened a couple of tabs in that window, Firefox just close the entire firefox.exe process without warning. And if there are 2 Firefox window or more, it works fine.
This issue just like the [url=https://bugzilla.mozilla.org/show_bug.cgi?id=521629]bug 521629[/url]
(Reporter)

Comment 9

7 years ago
In Bug 627705, people said this is by design and ask us just to restore the session.

The problem is, can Firefox restore the words I'm typing or other data in the web site?
Is this restore feature works properly with Ajax-based web sites(For example, can Firefox remember the page number which I'm browsing in the Ajax-based web page)?

And the serious problem is, If I'm using tab groups and close Firefox, the restore session feature can only restore one tab groups' tabs(The tab group which I currently browsing before I close Firefox)!  Oh my God!

If this is by design, I have to say this is the most stupid decision!

Comment 10

7 years ago
With that information you are correct, this behavior is a bug. Though bug 521629 is the more appropriate place for discussion (since this sounds like a duplicate of that)
Resolution: INVALID → DUPLICATE
Duplicate of bug: 521629
(Assignee)

Updated

2 years ago
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.