Prompt for session-handling on exit

RESOLVED DUPLICATE of bug 636777

Status

()

--
critical
RESOLVED DUPLICATE of bug 636777
8 years ago
8 years ago

People

(Reporter: beneficentone, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b11) Gecko/20100101 Firefox/4.0b11
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b11) Gecko/20100101 Firefox/4.0b11

Bug 588482 has led to a situation where many users – in all likelihood the majority who currently exit Firefox expecting to have their session available on restart – will lose data.  This is because, as at Beta 11, Firefox exits with no prompt, and if they have a custom home page or blank page set as the page to display on startup, this is all they’ll get, with no information on how to restore their session.

I propose the following.  I believe it addresses all concerns relating to the above, without changing the functionality of the Bug 588482 changes, and with the added benefit of privacy and transparency improvements, keeping the user in control and preventing annoying accidental exit by inadvertently closing the last window.  Furthermore, it should be straightforward to implement.

On exiting a saveable session the following dialog box would be displayed:


Do you want Firefox to save your session and make it available from the History menu?

[ ]   Do not ask next time

[ ]   Restore my session automatically on startup instead of showing my home page


[Save and Quit*]   [Quit]   [Cancel]

* focus
checkboxes default to unchecked


If ‘Restore my session automatically...’ is checked, the [Quit] button becomes greyed out; it becomes available again if the box is unchecked.  This, of course, is because after clicking [Quit] there would be no session to restore.

If ‘Do not ask next time’ is checked, the [Quit] button becomes greyed out; it becomes available again if the box is unchecked.  This is because the clearing of the session data is intended to be an ad-hoc action, and users can easily misunderstand the implications and then be unable to undo them.  (An advanced user could tweak the settings in about:config if, for some reason, they wanted every session not saved and no prompt on exit.)

The order of the checkboxes is significant: if ‘Do not ask next time’ was at the bottom this could lead to confusion.

If ‘Restore my session automatically...’ is checked, the value for Options > General > ‘When Firefox starts’ changes to ‘Show my windows and tabs from last time’.  This checkbox is ‘sticky’ – ie if checked by the user on first exit it remains checked on the second.

The old value for Options > General > ‘When Firefox starts’ – ie home page – should be retained, so that if the user checks ‘Restore my session automatically...’ on the first exit but not the second, their normal startup behaviour can be reinstated.

The prompt to save session should also be displayed if there’s a single tab open and that tab is a ‘Restore Session – Well, this is embarrassing’ one.

A final refinement would be to have an ‘Exit’ section in Options > General with a checkbox for ‘Prompt on exit’, in case the user has dismissed the prompt but would like it back.  The issue there, though, would be over the General page getting too crowded.

Reproducible: Always

Steps to Reproduce:
1. Home page other than about:home
2. Restart Firefox - no prompt on exit so immediate user concern
3. No information on how to restore a session that, in previous versions, was  restored by default
Actual Results:  
User's home page is displayed.  While their session has been saved they have no way of knowing this and so are liable to lose data.

Expected Results:  
User's session is restored, or the user is informed how to restore their session.

See Details
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → Trunk
Version: Trunk → unspecified

Comment 1

8 years ago
In short this is a request to back out bug 592822?
(Reporter)

Comment 2

8 years ago
(In reply to comment #1)
> In short this is a request to back out bug 592822?

Not exactly.  That still wouldn't tell the user where their session had gone: previously, after clicking [Save and Quit] and restarting, the session would immediately be restored.

This gives us a modified dialog that (a) tells the user that their session will be on the History menu, (b) gives them an option to restore immediately on restart (and without the annoying behaviour of starting the restored session in a new window and leaving the old one open) and (c) gives them the option of clearing their session data, something not currently available from Tools > Clear Recent History.
(Reporter)

Comment 3

8 years ago
A couple of notes:

(1) As implied but not stated above, clicking [Quit] would clear the session data (but not individual history items). This facility is not currently available. ('Recently Closed Tabs' and 'Recently Closed Windows' are already cleared on restart.)

(2) As mentioned in comment #2 above, the ‘Restore my session automatically...’ option does away with the annoying empty window mentioned here: https://bugzilla.mozilla.org/show_bug.cgi?id=593421#c44

(3) I suggest "Quit Firefox" as the dialog box title, the same as the old quit dialog.

(4) Re: "The prompt to save session should also be displayed if there’s a single tab open and that tab is a ‘Restore Session – Well, this is embarrassing’ one." This bug has now been addressed.
(Reporter)

Comment 4

8 years ago
There has been some discussion here on this issue: http://groups.google.com/group/mozilla.dev.apps.firefox/browse_thread/thread/1796b7255f23067a?pli=1 If Firefox developers don't realise what the default session restore behaviour actually was throughout the Fx3 cycle (prompt on exit, restore immediately), no wonder this issue isn't being addressed!

Alex Faaborg mentioned the possibility of some action on this if over 5% of users have customised their home page, and Michael Lefevre estimated the number to be around 13%. Alexander Limi mentioned the possibility of a one-off change of all home pages to about:home, but was unclear whether this might be done before the release of Firefox 4.0.

There are issues with the homepage-changing option: if it happened upon upgrade users might think it was a glitch and revert to their own before ever seeing the big restore button (which doesn't appear at all unless there's a restorable session). Still, it would be better than nothing, IF it happened at 4.0.

Because of the concern that users will change their minds about wanting the session after exit, I've revised my quit prompt solution to the following:


[Title:] Quit Firefox

Do you want Firefox to restore this session automatically next time?

[Yes]     [No*]     [Cancel]

* default


All sessions are saved. If the user clicks [Yes] Firefox behaves on startup as if Options > General > 'When Firefox starts' was set to 'Show my windows and tabs from last time', but does not change the home page preference, allowing the normal home page to be displayed on an occasion where the user selected [No].

The session is not opened in a new window, so it's more convenient for the user than clicking the big button on about:home, saving them 3 clicks getting back to and closing the parent window.

It provides the useful facility of being able to hit [Cancel] if the last window was accidentally closed.  'Do not ask next time' is dispensed with to reduce clutter. (Advanced users could change the about:config
value to not display it, in which case Firefox would assume 'No' re restoring the session.)

There are other foolproof solutions for avoiding the user losing their session through believing it wasn't saved, but none that have been proposed. This solution preserves the existing functionality while also taking full advantage of the ability to restore ad hoc or not at all.

Meanwhile, Beta 11 is already being offered as an alternative to 3.6.13 on the main 'Get Firefox' page, so mainstream users are already starting to lose data, and it remains unclear whether this will be addressed by 4.0, when the remaining 50,000,000 users not using about:home will start to be exposed to the issue.
Ben, would not a better (or at least more realistic given timeframes) solution be to make sure that the "what's new" page shown when Fx 4 is installed, tells the user how to get to the Firefox -> History -> Restore previous session link? As long as users that don't have about:home set, know how to find the feature under history, then they aren't going to loose anything...
(Reporter)

Comment 6

8 years ago
(In reply to comment #5)
> Ben, would not a better (or at least more realistic given timeframes) solution
> be to make sure that the "what's new" page shown when Fx 4 is installed, tells
> the user how to get to the Firefox -> History -> Restore previous session link?
> As long as users that don't have about:home set, know how to find the feature
> under history, then they aren't going to loose anything...

Users don't tend to read it. Admittedly, they're more likely to being a major release, but then there'll be a lot to get into such a page. It would certainly be a help to have it in there somewhere, and yes, all people need to know is that their session's available from the History menu for this not to be an issue.  But, short of having a glaring flashing GIF at the top of the page, I doubt most users would pick up on it.

Comment 7

8 years ago
(In reply to comment #0)
> I propose the following.  I believe it addresses all concerns relating to the
> above, without changing the functionality of the Bug 588482 changes, and with
> the added benefit of privacy and transparency improvements, keeping the user in
> control and preventing annoying accidental exit by inadvertently closing the
> last window.  Furthermore, it should be straightforward to implement.

It is unreasonable to expect privacy towards other people accessing your profile, just think about history and cache data.
(Reporter)

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 636777

Comment 9

8 years ago
Sorry, but I don't see the point to file 3 separate bugs about the same issue (this bug, bug 636777 and bug 636716), and marking the older one with many people in the CC list as a duplicate of another more recent bug. You should rather focus on this bug only, and mark the other two you filed as duplicates of this bug.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Reporter)

Comment 10

8 years ago
(In reply to comment #9)
> Sorry, but I don't see the point to file 3 separate bugs about the same issue
> (this bug, bug 636777 and bug 636716), and marking the older one with many
> people in the CC list as a duplicate of another more recent bug. You should
> rather focus on this bug only, and mark the other two you filed as duplicates
> of this bug.

I did this for three reasons: (1) The original bug description was interwoven with my (now obsolete) solution, which makes it less clear than it could be, (2) the title refers to a solution rather than the bug (I changed my mind about how I would file it half way through) making it harder to find and (3), more information is now known about what the issues are and what users it affects.

Have now added CCs to other bug.  In future, I'll be more careful about my wording of original bug description.  There's not much that progresses things in this thread - the main discussion happened on dev.apps.firefox - but if people still want this to be the main one after the CC adds then fine.
(Reporter)

Comment 11

8 years ago
(In reply to comment #9)
> Sorry, but I don't see the point to file 3 separate bugs about the same issue
> (this bug, bug 636777 and bug 636716), and marking the older one with many
> people in the CC list as a duplicate of another more recent bug. You should
> rather focus on this bug only, and mark the other two you filed as duplicates
> of this bug.

NB: Bug 636716 is a different bug, relating specifically to users with the blank home page option; it would occur for users who knew about History > Restore Previous Session as well, but simply changed their mind about restoring and exited.

Comment 12

8 years ago
Bug still exists in Firefox 4.0 final release. Apparently, the default preference that tells Firefox to show that dialog is changed.
(Reporter)

Comment 13

8 years ago
Remarked as duplicate of Bug 636777.  For a detailed description of the situation in Firefox 4.0 final release see https://bugzilla.mozilla.org/show_bug.cgi?id=636777#c22
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 636777
You need to log in before you can comment on or make changes to this bug.