"/tests/dom/tests/mochitest/ajax/prototype/test_Prototype.html or /tests/dom/tests/mochitest/bugs/test_bug463000.html | Exited with code 1 during test run" (with "Assertion failure: scopeChain_ == calleeValue().toObject().getParent()")

RESOLVED FIXED

Status

()

defect
--
major
RESOLVED FIXED
9 years ago
7 years ago

People

(Reporter: dholbert, Unassigned)

Tracking

(Blocks 1 bug, {assertion, intermittent-failure, regression})

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [perma-orange on (Windows) SeaMonkey], )

Looks like we have a new randomorange:

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1298105574.1298106333.15139.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central debug test mochitests-2/5 on 2011/02/19 00:52:54

s: talos-r3-snow-054

Assertion failure: scopeChain_ == calleeValue().toObject().getParent(), at /builds/slave/cen-osx64-dbg/build/js/src/jsinterpinlines.h:124
TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/ajax/prototype/test_Prototype.html | Exited with code 1 during test run
INFO | automation.py | Application ran for: 0:11:13.645725
INFO | automation.py | Reading PID log: /var/folders/H5/H5TD8hgwEqKq9hgKlayjWU+++TM/-Tmp-/tmp9pZb8Ypidlog
PROCESS-CRASH | /tests/dom/tests/mochitest/ajax/prototype/test_Prototype.html | application crashed (minidump found)
Operating system: Mac OS X
                  10.6.6 10J567
CPU: amd64
     family 6 model 23 stepping 10
     2 CPUs

Crash reason:  EXC_BAD_ACCESS / KERN_INVALID_ADDRESS
Crash address: 0x0

Thread 0 (crashed)
 0  XUL!JS_Assert [jsutil.cpp:657c2a92ee2b : 80 + 0x5]
    rbx = 0x294f9a90   r12 = 0x27351f78   r13 = 0x00000000   r14 = 0xffffffff
    r15 = 0x057abf08   rip = 0x01ab2aa3   rsp = 0x5fbfaf30   rbp = 0x5fbfaf50
    Found by: given as instruction pointer in context
 1  XUL!JSStackFrame::resetInvokeCallFrame [jsinterpinlines.h:657c2a92ee2b : 124 + 0x4d]
    rbx = 0x294f9a90   r12 = 0x27351f78   r13 = 0x00000000   r14 = 0xffffffff
    r15 = 0x057abf08   rip = 0x01a966c1   rsp = 0x5fbfaf60   rbp = 0x5fbfaf80
    Found by: call frame info
 2  XUL!js::InvokeSessionGuard::invoke [jsinterpinlines.h:657c2a92ee2b : 601 + 0x8]
    rbx = 0x057abf20   r12 = 0x27351f78   r13 = 0x00000000   r14 = 0xffffffff
    r15 = 0x057abf08   rip = 0x0193f271   rsp = 0x5fbfaf90   rbp = 0x5fbfb000
    Found by: call frame info
 3  XUL!array_extra [jsarray.cpp:657c2a92ee2b : 2851 + 0x12]
    rbx = 0x057abf20   r12 = 0x27351f78   r13 = 0x00000000   r14 = 0xffffffff
    r15 = 0x057abf08   rip = 0x01938ad1   rsp = 0x5fbfb010   rbp = 0x5fbfb1d0
    Found by: call frame info
 4  XUL!array_forEach [jsarray.cpp:657c2a92ee2b : 2908 + 0x14]
    rbx = 0x057abe90   r12 = 0x27351f78   r13 = 0x00000000   r14 = 0xffffffff
    r15 = 0x057abf08   rip = 0x01938e72   rsp = 0x5fbfb1e0   rbp = 0x5fbfb200
    Found by: call frame info
 5  0x119a94ff2
    rbx = 0x057abe90   r12 = 0x27351f78   r13 = 0x00000000   r14 = 0xffffffff
    r15 = 0x057abf08   rip = 0x19a94ff3   rsp = 0x5fbfb210   rbp = 0x5fbfb290
    Found by: call frame info
(Note that bug 619565 is filed on this same assertion-failure in a Jesse-crafted testcase.)
perma-orange on SeaMonkey (Windows at least):

http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1298096634.1298097787.18199.gz
WINNT 5.2 comm-central-trunk debug test mochitests-2/5 on 2011/02/18 22:23:54
{
Assertion failure: scopeChain_ == calleeValue().toObject().getParent(), at e:\builds\slave\comm-cen-trunk-w32-dbg\build\mozilla\js\src\jsinterpinlines.h:124
...
TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/ajax/prototype/test_Prototype.html | Exited with code -1073741819 during test run
}

Regression timeframe:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=b5fdead607d4&tochange=b0bf06306261
(3 changesets...)
Blocks: SmTestFail
(In reply to comment #8)
> perma-orange on SeaMonkey (Windows at least):
> 
> Regression timeframe:
> http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=b5fdead607d4&tochange=b0bf06306261
> (3 changesets...)

Very likely bug 631135.
Blocks: 631135
Severity: normal → major
blocking2.0: --- → ?
Keywords: regression
OS: Mac OS X → All
Whiteboard: [orange] → [orange] [perma-orange on (Windows) SeaMonkey]
Summary: Sporadic "/tests/dom/tests/mochitest/ajax/prototype/test_Prototype.html | Exited with code 1 during test run" (with "Assertion failure: scopeChain_ == calleeValue().toObject().getParent()") → Sporadic "/tests/dom/tests/mochitest/ajax/prototype/test_Prototype.html or /tests/dom/tests/mochitest/bugs/test_bug463000.html | Exited with code 1 during test run" (with "Assertion failure: scopeChain_ == calleeValue().toObject().getParent()")
Looks like this actually started on Waldo's push:
   http://hg.mozilla.org/mozilla-central/rev/9d6f665f7f84
which was 2 pushes before the failure in comment 0, with a failure that I mis-starred as another test_Prototype randomorange (my bad):
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1298093613.1298094445.5700.gz
Rev3 Fedora 12 mozilla-central debug test mochitests-2/5 on 2011/02/18 21:33:33
s: talos-r3-fed-008

mochitest-2 looks to have been green for many cycles before that, and Waldo's push was the only JS-related one for a little while at that point.  His push & the assertion also both mention 'scope'.  So I think this was probably introduced by that push.

Waldo, mind investigating?  This is failing on some platform nearly once per cycle (and sometimes twice)
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1298156499.1298156820.25967.gz
Rev3 MacOSX Leopard 10.5.8 mozilla-central debug test mochitests-5/5 on 2011/02/19 15:01:39

s: talos-r3-leopard-006
TEST-UNEXPECTED-FAIL | /tests/toolkit/components/passwordmgr/test/test_basic_form_2pw_1.html | Exited with code 1 during test run
PROCESS-CRASH | /tests/toolkit/components/passwordmgr/test/test_basic_form_2pw_1.html | application crashed (minidump found)
Thread 0 (crashed)
TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | missing output line for total leaks!
This is hardly sporadic.  We ought to be able to track this one back to a changeset given how frequently it happens.
Summary: Sporadic "/tests/dom/tests/mochitest/ajax/prototype/test_Prototype.html or /tests/dom/tests/mochitest/bugs/test_bug463000.html | Exited with code 1 during test run" (with "Assertion failure: scopeChain_ == calleeValue().toObject().getParent()") → "/tests/dom/tests/mochitest/ajax/prototype/test_Prototype.html or /tests/dom/tests/mochitest/bugs/test_bug463000.html | Exited with code 1 during test run" (with "Assertion failure: scopeChain_ == calleeValue().toObject().getParent()")
We know exactly which changeset, it's just that the backout isn't obvious due to interaction with another patch.
I backed out the patch, so it's gone.

The actual issue seems to be bug 619565, which may be resolved very soon.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
blocking2.0: ? → ---
Whiteboard: [orange] [perma-orange on (Windows) SeaMonkey] → [perma-orange on (Windows) SeaMonkey]
You need to log in before you can comment on or make changes to this bug.